Issues getting Android phone to connect and stay connected to 5ghz SSID

Waylo

Occasional Visitor
I recently purchased an AX86U and have the latest Merlin firmware on it.

I've been having issues getting my S10E Samsung Android phone to reliably connect to the 5ghz SSID.

On occasion, it will connect to the SSID and behave normally. Most times, it will attempt to log in but have "authentication" issues, or refuse to connect without any error displayed on the phone, or connect with the "connected without internet" error. Most of the time, if I check the phone after some time has passed, it has disconnected and has the same issues reconnecting.

The signal strength is very good. This is the normal 5ghz band, not a guest SSID. Another phone of mine doesn't seem to have any issues staying on the same network, so it could be an issue unique to this phone.

Here are the settings for the 5ghz page:
1663219514249.png


Are there any settings worth disabling or changing?

I've perused the router log but can't tell if there's a smoking gun here. Here are some relevant entries (using the MAC address to trim the other log entries):

Line 2678: Sep 14 22:14:28 wlceventd: wlceventd_proc_event(505): eth7: Auth AA:03:3F:03:A7:F1, status: Successful (0)
Line 2679: Sep 14 22:14:28 wlceventd: wlceventd_proc_event(534): eth7: Assoc AA:03:3F:03:A7:F1, status: Successful (0)
Line 2737: Sep 14 22:16:41 wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind AA:03:3F:03:A7:F1, status: 0, reason: Disassociated due to inactivity (4)
Line 2738: Sep 14 22:16:41 wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind AA:03:3F:03:A7:F1, status: 0, reason: Previous authentication no longer valid (2)
Line 2739: Sep 14 22:16:42 wlceventd: wlceventd_proc_event(486): eth7: Disassoc AA:03:3F:03:A7:F1, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8)
Line 2757: Sep 14 22:17:26 wlceventd: wlceventd_proc_event(505): eth7: Auth AA:03:3F:03:A7:F1, status: Successful (0)
Line 2758: Sep 14 22:17:26 wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind AA:03:3F:03:A7:F1, status: 0, reason: Unspecified reason (1)
Line 2759: Sep 14 22:17:26 wlceventd: wlceventd_proc_event(505): eth7: Auth AA:03:3F:03:A7:F1, status: Successful (0)
Line 2760: Sep 14 22:17:26 wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind AA:03:3F:03:A7:F1, status: 0, reason: Unspecified reason (1)
Line 2761: Sep 14 22:17:26 wlceventd: wlceventd_proc_event(505): eth7: Auth AA:03:3F:03:A7:F1, status: Successful (0)
Line 2762: Sep 14 22:17:26 wlceventd: wlceventd_proc_event(534): eth7: Assoc AA:03:3F:03:A7:F1, status: Successful (0)
Line 2763: Sep 14 22:17:30 wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind AA:03:3F:03:A7:F1, status: 0, reason: Previous authentication no longer valid (2)
Line 2764: Sep 14 22:17:30 wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind AA:03:3F:03:A7:F1, status: 0, reason: Previous authentication no longer valid (2)
Line 2765: Sep 14 22:17:33 wlceventd: wlceventd_proc_event(505): eth7: Auth AA:03:3F:03:A7:F1, status: Successful (0)
Line 2766: Sep 14 22:17:33 wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind AA:03:3F:03:A7:F1, status: 0, reason: Unspecified reason (1)
Line 2767: Sep 14 22:17:33 wlceventd: wlceventd_proc_event(505): eth7: Auth AA:03:3F:03:A7:F1, status: Successful (0)
Line 2773: Sep 14 22:17:43 wlceventd: wlceventd_proc_event(469): eth7: Deauth_ind AA:03:3F:03:A7:F1, status: 0, reason: Unspecified reason (1)
Line 2774: Sep 14 22:17:43 wlceventd: wlceventd_proc_event(505): eth7: Auth AA:03:3F:03:A7:F1, status: Successful (0)

It looks like the router recognizes the phone is connecting. Lets it happen. And then quickly deauthorizes it.

Appreciate any direction you can provide.
 
Last edited:

Crimliar

Senior Member
One thing that can cause this is the WPA setting. Try setting:
Wireless > General > Authentication Method : WPA2
then have your phone "forget" the connection, followed by re-connecting.

If that works you can then play with different WPA settings on the router, remembering to have the phone "forget" at the start of each itteration.
 

BreakingDad

Very Senior Member
On Phone:

Settings>connections>wifi>menu icon 3 dots>advanced>switch to mobile data (turn off)
 

Waylo

Occasional Visitor
One thing that can cause this is the WPA setting. Try setting:
Wireless > General > Authentication Method : WPA2
then have your phone "forget" the connection, followed by re-connecting.

If that works you can then play with different WPA settings on the router, remembering to have the phone "forget" at the start of each itteration.
Thanks. It's been on WPA2, but I had tried WPA3 when I first purchased the router and that resulted in losing an IOT device, which I understand is common.

I did go through the "forget" procedure and for now, it seems to be working.
 

Waylo

Occasional Visitor
On Phone:

Settings>connections>wifi>menu icon 3 dots>advanced>switch to mobile data (turn off)
Yup, one of the first things I did when I first got the phone (and on any Android phone).
 

Waylo

Occasional Visitor
Just found this thread:
which may have more suggestions for my problem. Even though it's not the exact model, it is the AX generation.
 
Last edited:

BreakingDad

Very Senior Member
Was thinking about this thread, have you turned off roaming assist, have you tried settings a static control channel ? Auto seems to be picking 149 which depending on where you are located can be a srd channel.

Perhaps something more standard like 32-48 might help?

Also are you dhcping the phones settings (auto) from the router or manually assigning? believe these phones have issues with manual.
 
Last edited:

Waylo

Occasional Visitor
Thanks everyone for your kind suggestions. This type of issue doesn't seem to be isolated, given the number of existing threads. That's interesting and unfortunate. Fortunately, this forum is a gold mine of suggestions and helpful experts.

Roaming assist is off. I haven't made the channel static, but that is on the list of possible fixes to try. I have been doing auto DHCP assignments all along.

Just for posterity, here's a compiled list of things I've found, and tried, or may plan to try, for a variety of wifi issues:

Done:
"Forget" wifi settings on phone, then re-enter password credentials, if the phone gets immediately rejected from logging on (router logs point to a reauthorization issue)
Turn off AX for 2.4ghz
Turn off smart connect
Set 2.4ghz bandwidth to 20mhz only
Set SSID and password to alphanumeric characters only
Turned off WPA3 (a specific IOT device, a ceiling fan, was incompatible with this setting)
Disable WPS
Disable universal beamforming
Disable roaming assistant for 5ghz
Enabled 160mhz

Other options for the future:
1. Power cord pull (instead of just reboot)
2. Flash 386.7_0 (reports of this working for steady 5ghz connections, whereas the current latest 386.7_2 does have issues)
3. Flash 386.3_3 (reports of this working for steady 5ghz connections, and all subsequent ones did not, until 386.7_0)
4. Set 5ghz channel to 149, or 36
5. Enable DFS
6. Full wipe x several times
7. Flash beta Asus FW 9.0.0.4_388_20477

I do require YazFi, unfortunately, for creating VLAN separation for guest and IOT networks, which confounds some of these troubleshooting efforts. However, none of the guest network VLANs are 5ghz.
 
Last edited:

BreakingDad

Very Senior Member
I do require YazFi, unfortunately, for creating VLAN separation for guest and IOT networks, which confounds some of these troubleshooting efforts. However, none of the guest network VLANs are 5ghz.

I actually put my wife's iphone SE on it's own separate guest network 2.4ghz (as she doesn't need the speed just a good connection)

It wasn't playing nicely with the roaming and works better isolated on its own like that. It's weird because there is no issue with any other phones in the house (samsung,moto and apple)

It made me think that maybe you could isolate a 5ghz guest network just for that phone and see if that would work on the offending cell.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top