1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Issues with Time Scheduling...

Discussion in 'Asuswrt-Merlin' started by macster2075, Jun 16, 2019.

  1. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    Hi..
    Recently my son notified me he lost inter connection during the time of day where he is allowed to use it.
    When I checked the settings, they are not changed and they are the same as they were before.

    I've noticed if I disable Time Scheduling, then his connection is fixed, but as soon as I enable it, no internet.
    I have attached a screenshot of the settings for his PC.

    As you can see from the pic, the only times internet is blocked is Mon-Thurs 12 am to 8 am, except on the weekends.

    Even if I select all times to be OPEN, meaning allowed all times (lite gray)... it still breaks internet connection. The only way it works is by disabling the feature altogether.

    I have tried rebooting, deleting the PC setting and re-adding the PC to the settings.. nothing has worked.
    This started happening after the last update.

    Any suggestions?
     

    Attached Files:

  2. martinr

    martinr Part of the Furniture

    Joined:
    Nov 27, 2014
    Messages:
    2,208
    Location:
    Manchester, United Kingdom
    It coincided with the last update; is that to 384.11_2? Which firmware were you running prior to the update?

    Which router model?

    Is that the only glitch you’ve noticed since the update? And other than the update, nothing else was changed?

    Can you see what syslog says when the device gets disconnected?
     
    Last edited: Jun 16, 2019
  3. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    Asus RT-AC68U
    I have v384.11_2 and I had the previous one before this one (384.11_0).

    The only thing that changed was that his computer was connecting through wifi before, how it's connected straight to the router using Ethernet cable. Other than that, nothing else.

    EDIT...
    Not only it's an issue with his PC.. his phone or any device that is part of the Time Scheduling... if it's enabled, nothing has internet.
     
  4. dave14305

    dave14305 Very Senior Member

    Joined:
    May 19, 2018
    Messages:
    1,350
    When switching from wireless to wired, his MAC address would be different so a new rule would be needed. But since you did that already, it’s hard to say what’s up. Do you have NAT acceleration enabled or disabled per the Time Scheduling instructions?
     
  5. martinr

    martinr Part of the Furniture

    Joined:
    Nov 27, 2014
    Messages:
    2,208
    Location:
    Manchester, United Kingdom
    Can you turn on the time scheduling and get it to disconnect him them look on syslog and see if it gives a reason for the disconnection?

    I suspect you might end up doing a reset; when did you last carry out a reset to factory default settings and was it done according to L&LD’s guide?
    https://www.snbforums.com/threads/n...l-and-manual-configuration.27115/#post-205573
     
  6. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    I did do a factory reset, but the issue still persists. Even if I add my own PC to the list, as soon as I enable the Time Scheduling, it will break the connection.
    As soon as I disable it, I get connected.

    I never had issues until very recently and it was working perfectly.
     
  7. martinr

    martinr Part of the Furniture

    Joined:
    Nov 27, 2014
    Messages:
    2,208
    Location:
    Manchester, United Kingdom
    And please just confirm that after the reset to factory default settings you manually entered all your settings ie you didn’t restore them from a backup file.

    And syslog: does that give any indication why the connection breaks when Time Scheuling is turned on?
     
  8. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    yes.. I manually entered the settings all over again.
    Not sure how to check for syslog.
     
  9. martinr

    martinr Part of the Furniture

    Joined:
    Nov 27, 2014
    Messages:
    2,208
    Location:
    Manchester, United Kingdom
    U
    Thanks
    Syslog. I should have said System Log and you would have known. Second from the bottom in the list on the left when you log in to the webui on the router. It’s ot the easiest thing to interpret. But if you force a disconnection with Time Scheduling and then go in and look at the System Log, you possibly will see some entries related to it. Finding those entries should not be too difficult, depending on how many entries came afterwards for other reasons. Interpretation of them might not be so simple! But there are plenty of forum members quite adept at that, so just post any pertinent entries. Possibly, it might give a clue.
     
  10. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    I will check the system log today...it’s just weird that this feature starting giving issues now when it’s been working fine.

    And as i’ve mentioned before...it’s not just my son’s pc, it’s any device I add to the Time Scheduling....no matter what times i select..if the devices are on the list and the feature is On...it will break the conection.
     
  11. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    9,761
    On the main Time Scheduling page, is the drop down listed as 'Time', 'Disable' or 'Block'?

    It should be set to 'Time' if you want the schedule to work. :)

    If this is already set correctly to 'Time' does setting it to 'Disable' allow the client to work without interrupting internet access?

    If so, and 'Time' doesn't work properly, this may be the time to do a full M&M Config and start setting up the router manually and minimally with the most important features first, then adding slowly any additional features you need after testing all the previous settings continue to work without issue (even after a GUI initiated reboot).

    Please see my signature below for the M&M Config guide and other links to get your router and/or network to a good/known state as quickly as possible.

    Note: if seeing this post using a mobile device, physically turning it sideways to landscape mode may allow you to see signatures. :)
     
    martinr likes this.
  12. dave14305

    dave14305 Very Senior Member

    Joined:
    May 19, 2018
    Messages:
    1,350
    Does your router in SSH see the system time correctly? Probably so, but need to verify.
    If you want to confirm the low-level settings of Time Scheduling, you can run these commands in the SSH session:
    Code:
    nvram show 2>/dev/null | grep ^MULTI | sort
    iptables -t nat -S PCREDIRECT
    date
    I would compare the IP and MAC addresses of the devices currently from the Wireless Log to the iptables output and nvram output. Do any devices use MAC randomization? Are their IP addresses changing often?

    You don't have to share the output if you're queasy about divulging MAC addresses, but if something is amiss we might be able to spot it.
     
    L&LD and martinr like this.
  13. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    I noticed something very peculiar... Now, it seems Time Scheduling is "working", but there is a very long delay in showing webpages... some won't even come up, but some do after like a 5-8 second delay... If I turn the feature off, Youtube or any other website pulls right away.. as soon as I turn it On, they either don't pull up or take a long time to pull...it feels like the Time Schedule feature broke something... I will try going back to the previous version where it worked fine to see... if it works, then it's definitely something with this version.
     
    martinr likes this.
  14. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    Ok..
    So now I am even more puzzled.
    I have gone back to the version I had before that I knew Time Scheduling was working. I did a factory restore on v384.10_2.
    No settings were done, except adding the wifi network names and the router admin password.. that's it.. everything else stayed factory.

    I went ahead and added my own PC to the Time Scheduling list.... and I turned it ON.. now, some websites open up, on others I get the following message saying I don't have internet.
    As you can see from the pictures, I have made sure that the time zone is correct and based on the times I have selected, I should be able to have internet at this hour...but Time Scheduling is breaking something and I cannot see what it is. I will post another with syslog...
     

    Attached Files:

  15. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    Im sorry guys.. I don't know how to post a copy of the syslog.. the site does not allow me to... I keep getting an error.
     
  16. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
  17. dave14305

    dave14305 Very Senior Member

    Joined:
    May 19, 2018
    Messages:
    1,350
    Do you have an /etc/TZ file on your router? I can’t remember if this is built-in or if I created mine through entware.

    Your syslog shows that dnsmasq is reporting in UTC time, and your screenshots show you are in EDT (you need to adjust your DST end date to the 1st Sun in Nov).
     
  18. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    oh.. why is that.. I don't remember ever having to mess with that setting.. I did a factory setting and that is what was selected. The factory selected Eastern, but didn't change the other setting.. very strange.
     
  19. macster2075

    macster2075 Regular Contributor

    Joined:
    Jan 21, 2019
    Messages:
    144
    Still having the same issue after setting the 1st Sun in Nov... as soon as I enable Time Scheduling, internet breaks.
     
  20. dave14305

    dave14305 Very Senior Member

    Joined:
    May 19, 2018
    Messages:
    1,350
    Yeah, that wasn’t going to be a fix, but just an aside. I’ve mimicked your schedule and still have Internet on my device. Can you use PuTTY to ssh and run the iptables command below? Shown with my output.
    Code:
    iptables -t nat -S PCREDIRECT
    -N PCREDIRECT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 00:00:00 --timestop 01:00:00 --weekdays Sun --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 08:00:00 --timestop 23:59:59 --weekdays Sun --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 08:00:00 --timestop 23:59:59 --weekdays Mon --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 08:00:00 --timestop 23:59:59 --weekdays Tue --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 08:00:00 --timestop 23:59:59 --weekdays Wed --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 08:00:00 --timestop 23:59:59 --weekdays Thu --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 08:00:00 --timestop 23:59:59 --weekdays Fri --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 00:00:00 --timestop 01:00:00 --weekdays Sat --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 -i br0 -m time --timestart 08:00:00 --timestop 23:59:59 --weekdays Sat --kerneltz -j ACCEPT
    -A PCREDIRECT -s 192.168.1.250/32 ! -d 192.168.1.0/24 -i br0 -p tcp -m tcp --dport 80 -j DNAT --to-destination 192.168.1.1:18099