Japanese language locked RT-AC88U Fixed

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Kaido88

New Around Here
Hi I have searched a lot of information on how to change the language on some language locked versions of the RT-AC88U specifically the Japanese version of this router that wont let you change any other language than the one that was provided even in the GUI there would be no language option at the top right corner of the page. I have read some people tried to do it with SSH and code it in but that seemed like to a lot of work for something that should of already been there. I wanted to find an easier way so I installed the latest stable version of Asuswrt-merlin RT-AC88U_384.19_0 which made the GUI show the language bar at the top but it only showed Japanese and still would not change to English. After almost loosing hope and giving up I went back to see if there were any new beta versions and behold there was one that was released this week for pre beta test builds 386.1_alpha4-gd4b7146753 so I decided to try it and it worked the language bar at the top right now could change from Japanese to English very surprised and very happy with the result I thought I'd share the information if anyone else was trying to solve the problem with a simple firmware update. You can download it from this link https://onedrive.live.com/?authkey=!AGY2taGX02nVmWA&id=CCE5625ED3599CE0!1427&cid=CCE5625ED3599CE0
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top