Killswitch not working??

Uxxer

New Around Here
Hello, everyone
I have a problem with the router asus ax88u and the latest Merlin firmware (RT-AX88U_386.7_0.zip 2022-06-23)
The kill switch function does not work for me.
If I switch vpn on then I have the ip of the vpn provider if I switch vpn off I have the normal WAN connection with the kill switch activated!
I added pictures.

I am desperate I am grateful for any help!
Thanks
 

Attachments

  • Screenshot 2022-07-05 000017.png
    Screenshot 2022-07-05 000017.png
    179.9 KB · Views: 29
  • Screenshot 2022-07-05 000054.png
    Screenshot 2022-07-05 000054.png
    129.9 KB · Views: 28
  • Screenshot 2022-07-05 000510.png
    Screenshot 2022-07-05 000510.png
    52.8 KB · Views: 30
  • Screenshot 2022-07-05 000636.png
    Screenshot 2022-07-05 000636.png
    52 KB · Views: 29
  • Screenshot 2022-07-05 000803.png
    Screenshot 2022-07-05 000803.png
    218.6 KB · Views: 30

eibgrad

Part of the Furniture
By design, the killswitch will NOT work if you purposely disable the OpenVPN client! It's intended for situations where you've configured the OpenVPN client to autostart, and then the VPN fails *unexpectedly*. But NOT if you purposely disable it. IOW, if YOU turn it OFF, it's off completely, killswitch and all.
 

eibgrad

Part of the Furniture
Yes. Just kill the OpenVPN client process based on either the name or PID (process ID), as found in the process table (ps command).

Code:
killall openvpn

or

Code:
kill $(ps | grep vpnclient1 | awk '{print $1}') # assumes client #1

The killall command will kill all OpenVPN clients *and* servers, that's why using the PID might be preferred in some cases.
 

Uxxer

New Around Here
I have another question, where do I have to enter the command? Sorry about the second post
 

eibgrad

Part of the Furniture
Use ssh to get into the router's command line interface (it may still be disabled if you've never used it before, see Administration > System).
 

Uxxer

New Around Here
Ok I activated it lan and wan and port I specified 25 because it said 22 shouldn't I take it and what's next?
 

Attachments

  • Screenshot_20220705-023811_Chrome.jpg
    Screenshot_20220705-023811_Chrome.jpg
    59.1 KB · Views: 24
  • Screenshot_20220705-023811_Chrome.jpg
    Screenshot_20220705-023811_Chrome.jpg
    59.1 KB · Views: 24

eibgrad

Part of the Furniture
You should NOT expose the SSH server to the WAN (that's why it's recommending you change the port from the default of 22, to obscure it). Instead, expose it only to the LAN and use the default port (22).

You can access the router's ssh server using an ssh client (e.g., for Windows, powershell or the PuTTY client).

Code:

It will prompt for your password (same as when logging into the GUI).

P.S. I don't use Windows, but it's possible the ssh client is already part of the normal command line interface (cmd), I just don't recall. But worst case, powershell should work too.
 
Last edited:

eibgrad

Part of the Furniture
Try to ping router.asus.com and make sure it's replying w/ YOUR router's LAN ip (e.g., 192.168.1.1 or 192.168.50.1). Or just substitute your router's LAN ip (if you know it) in the ssh command. For example ...

Code:

I'm assuming you didn't change the Router Login Name on the Administration > System page.
 

Uxxer

New Around Here
I made the setting to lan only and then putty opened port 22 on the Windows pc which I connected to the router via LAN cable and then entered the command
 

Uxxer

New Around Here
I also tried that, the same thing, the only thing that worked was if I had http:// and the io address, then I could log in with admin and the password and was root, but I don't know if that would fit
 

eibgrad

Part of the Furniture
If you use putty, then you just provide the router's IP address, hit Open, and it should prompt for username followed by password.

If it still doesn't work, reboot the router and try again.
 

Uxxer

New Around Here
this is not working ? ok i write tomorrow i must go sleeping i wish you a good night and thank you for all
 

Attachments

  • Screenshot (9).png
    Screenshot (9).png
    46.4 KB · Views: 35

eibgrad

Part of the Furniture
this is not working ? ok i write tomorrow i must go sleeping i wish you a good night and thank you for all

That last image you posted appears to show you successfully logged in! It's waiting for you to submit commands.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top