Let's encrypt issue on latest 386.1 beta 2 (RT-AX86U)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

dr_lucas

Regular Contributor
When trying to get a let's encrypt certificate, it keeps showing "Authorizing".

[EDITED: Let's encrypt issue is already listed as known]

Also, if I disable let's encrypt (set it to none), it generates a local certificate, but showing it was generated by and for 192.168.50.1, while my router is set on 192.168.1.1 and the network is on 192.168.1.x of course.
 
Last edited:

RMerlin

Asuswrt-Merlin dev
When running a beta firmware, it's a good idea to read the info posted in the Beta thread, especially the second post that lists all known issues. There are MANY posts there already about this.
 

L&LD

Part of the Furniture
192.168.50.1 isn't an issue. This is a configurable option.
 

RMerlin

Asuswrt-Merlin dev
Probably means the certificate was issued before you changed the IP, you will have to regenerate it.
 

blake444

Occasional Visitor
I add myself to the conversation because I would like to ask, is it normal that after a factory reset the ddns section still shows the active certificate? and if so, what does its revocation entail?
 

L&LD

Part of the Furniture
Format the JFFS partition on the next boot, make sure you hit 'Apply' at the bottom of the page before you reboot 3 times in the next 10 to 15 minutes (waiting between 5 to 10 minutes between each reboot).
 

RMerlin

Asuswrt-Merlin dev

RMerlin

Asuswrt-Merlin dev
Thanks. Unfortunately it didn't make any change.

Was broken in beta 2, a backup was restored on top of the newly generated certificate. Will be fixed in beta 3.
 

L&LD

Part of the Furniture
On RMerlin 386.1 Beta 4, the new certificate is generated and valid on my RT-AX86U.
 

palint

New Around Here
Is this problem related somehow to a problem I get on my AC86U? I'm currently on 386_2.
I use succesfuly duckdns and I get error while trying to get LE certificate:

Verify error: Fetching [...] Timeout during connect (likely firewall problem)

Also on my RPi I can't get my certificate to work in docker - I get http connection to site which is supposed to have be certified..
 

Nighthawk

New Around Here
It works just fine on my AX86U firmware 386_2

Let's Encrypt.jpg
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top