LG smart tv doesn't connect to internet with RT-AC68U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

degs

New Around Here
I have an LG smart tv and the set says it's connected to the internet the modem says it's connected to the internet but the tv refuses to upload or download anything. If I go through a mobile hotspot the tv works fine. Everything else I have connected PC, kodi box (via ethernet) and other devices connected via wifi all work 100%. I have asked my isp if he has any problems and he says not. I use a smartDNS on my router but even without that the tv still does not connect. I am not into all the intricacies of the workings of the router as I basically use it as a tool to connect my system to the world. I have Merlin 385.15 on my router but the previous versions were just the same. Does anyone have any ideas?
 

OzarkEdge

Part of the Furniture
I have an LG smart tv and the set says it's connected to the internet the modem says it's connected to the internet but the tv refuses to upload or download anything. If I go through a mobile hotspot the tv works fine. Everything else I have connected PC, kodi box (via ethernet) and other devices connected via wifi all work 100%. I have asked my isp if he has any problems and he says not. I use a smartDNS on my router but even without that the tv still does not connect. I am not into all the intricacies of the workings of the router as I basically use it as a tool to connect my system to the world. I have Merlin 385.15 on my router but the previous versions were just the same. Does anyone have any ideas?
It sounds like a singular client compatibility issue. If you can wire it, it might work and work better overall. Are Airtime Fairness and Universal Beamforming disabled for the band the TV connects to? These are under Wireless\Professional.

OE
 

degs

New Around Here
It sounds like a singular client compatibility issue. If you can wire it, it might work and work better overall. Are Airtime Fairness and Universal Beamforming disabled for the band the TV connects to? These are under Wireless\Professional.

OE
Thanks for your response, I do have it wired via TP-link on my home network. I have tried different adaptors in case one was faulty but the results the same. The two items you mention are both enabled but the only wifi items that are in use in the house are phones and Kindles.
 

OzarkEdge

Part of the Furniture
Thanks for your response, I do have it wired via TP-link on my home network. I have tried different adaptors in case one was faulty but the results the same. The two items you mention are both enabled but the only wifi items that are in use in the house are phones and Kindles.
Do you have a separate cable modem that you can briefly wire the TV to directly to test it? Have you tried a different Ethernet cable and port on the TP Link 'system'?

OE
 

jtjbt20x

Occasional Visitor
Does your SmartDNS block any specific countries like South Korea or Taiwan? Maybe even when you turn off the smartDNS you need to flush the DNS cache?

I had those problem with my TV a few years back and had to change the DNS server, reboot the router, and reboot the TV.
 

Zirescu

Very Senior Member
Should make sure the LG tv is getting an IP on the network and isn't overlapping with another device on the network. Double-check it's getting it's DNS from the router as well. If that checks out you can try setting DNS manually on the TV to either google's 8.8.8.8 or cloud flares 1.1.1.1. Any error messages in the system log on the router?
 

degs

New Around Here
Do you have a separate cable modem that you can briefly wire the TV to directly to test it? Have you tried a different Ethernet cable and port on the TP Link 'system'?

OE
Sadly, I don't have a another modem but I have changed both the cable and also the TP device to no avail.
Does your SmartDNS block any specific countries like South Korea or Taiwan? Maybe even when you turn off the smartDNS you need to flush the DNS cache?

I had those problem with my TV a few years back and had to change the DNS server, reboot the router, and reboot the TV.
Not as far as I know, I am in Spain and everything else works exactly how it should. I've tried switching the DNS server but the supplier only gave me 2 numbers to use and both work with all my other stuff but the TV remains the same.
Should make sure the LG tv is getting an IP on the network and isn't overlapping with another device on the network. Double-check it's getting it's DNS from the router as well. If that checks out you can try setting DNS manually on the TV to either google's 8.8.8.8 or cloud flares 1.1.1.1. Any error messages in the system log on the router?
yes it's getting an IP address and does not overlap with anything else. I have tried the DNS setting to both Googles and also OpenDNS and also used the DNS from my SmartDNS provider all do not work. When I use the hotspot off my phone I used the SmartDNS to ensure I could access the correct country and that worked no problem. It certainly appears to be some setting on the router but what I just don't know.
 

ColinTaylor

Part of the Furniture
You say you are using Merlin's firmware. Why is that? Are there any specific features of that firmware that you are using that means you can't use the stock Asus firmware?

Random thought: Try disabling AiProtection.
 

OzarkEdge

Part of the Furniture
Sadly, I don't have a another modem but I have changed both the cable and also the TP device to no avail.
I meant to wire the TV directly to your existing modem to bypass your router, if that is possible with your equipment.

OE
 

degs

New Around Here
You say you are using Merlin's firmware. Why is that? Are there any specific features of that firmware that you are using that means you can't use the stock Asus firmware?

Random thought: Try disabling AiProtection.
I use Merlin because my ISP uses transparent DNS and I was unable to use SmartDNS with that. It was either switch to Merlin or change routers to something like DD-WRT which I just did not want to do. The reason I use SmartDNS is the speed versus VPN and it allows me to watch TV from my home country.
 

degs

New Around Here
Did you get any solution to this issue?
I have a similar problem and it's driving me nuts.
Sorry but I have had no luck so far. I even emailed the creator of Merlin to see if he had any ideas, (a long shot I know as he is obviously a very busy guy) but have not had any response. We are in total lockdown here (5 weeks!!) and I cannot afford to upset my better half by turning off our only source of TV, phone (whatsapp) etc and risk losing it so I'll have to wait a few more weeks and hope they ease it off.
 

terribell

Regular Contributor
Sorry but I have had no luck so far. I even emailed the creator of Merlin to see if he had any ideas, (a long shot I know as he is obviously a very busy guy) but have not had any response. We are in total lockdown here (5 weeks!!) and I cannot afford to upset my better half by turning off our only source of TV, phone (whatsapp) etc and risk losing it so I'll have to wait a few more weeks and hope they ease it off.
I'm also trying all the suggestions without any luck and we are also in lockdown here.
Today I had an LG engineer replace the main board but the problem was not resolved, so I kept to old main board.

I didn't see your post at first and opened a new one in https://www.snbforums.com/threads/lg-oled-c8-and-rt-ac68u.63543/

Good luck!

PS: If you find some solution let the rest of us know please.
 

terribell

Regular Contributor
@degs on my case the issue was DNS Filtering, are you using this?
After I disabled it the TV started working without itches.
 

degs

New Around Here
@degs on my case the issue was DNS Filtering, are you using this?
After I disabled it the TV started working without itches.
Good for you, sadly I already had it disabled so I guess I'll have to continue trying. Thanks for letting me know anyway.
 

degs

New Around Here
I have finally gotten my TV to work now. I had the following script in my jffs partition
#!/bin/sh

chmod a+rx /jffs/scripts/*
iptables -t nat -A PREROUTING -i br0 -p udp --dport 53 -j DNAT --to 83.170.84.75:1512
iptables -t nat -A PREROUTING -i br0 -p tcp --dport 53 -j DNAT --to 83.170.84.75:1512

and I have now removed it and just put the ip number into the WAN DNS setting in WAN DNS server1. I selected NO on Connect to DNS Server automatically and then tried all my devices. The TV, Kodi Box and SKY box all work as required but strangely my PC doesn't. I am not able to access the UK TV channels that I was able to before on the PC yet I am able on all my other devices. I use SmartDNS as it is so much faster than with a VPN.
I was given the script by someone on here last year when I purchased my router and was looking to set it up, it worked fine until I then switched TV's and have had problems ever since. I would appreciate anyone with knowledge letting me know exactly what this script does. I was told I needed it as my ISP uses a Transparent DNS and it was used to bypass that and allow me to access UKTV on my systems.
I only thought about it as one of the things I did while looking to solve my problem was switching off my SmartDNS and it was only then that I realised even after I had set Connect to DNS Server automatically to YES the SmartDNS was still operational.
I really appreciate the time people have taken with me on this site and it's been really good learning as much as I have.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top