Limited Internet Zccess RT-AC88U with USB Modem

Datashuttle

Occasional Visitor
Router: Asus RT-AC88U
Firmware: 386.7_2

The RT-AC88U router allows internet access via a USB modem, and a guest WiFi connection, but not a regular 2.4 or 5 GHz WiFi connection, or a direct Ethernet connection. All connections have worked in the past, but not for the last few firmware updates.

I hard to believe it has anything to do with the firmware, but I have tried every network configuration I can for a number of days and no luck. As it stands now, it's fine that I can get the guest WiFi to work, but that doesn't allow network access.

Anyone seen anything like this?

Thanks
 

ColinTaylor

Part of the Furniture
The IP subnet pushed by your USB modem might be conflicting with that of your router's LAN. 192.168.1.x is fairly commonly used. As an experiment try changing the router's LAN subnet to 192.168.50.x.
 

Datashuttle

Occasional Visitor
Thanks Colin for the response. Changing the subnet didn't help. A different subnet is what I had already.

I can ping the USB modem, and internet IPs and return data. So at least my shell is getting through, just none of my browsers, they don't resolve the host which leads me to believe it is some kind of DNS issue, but what??? I've tried every setting I can think of with no luck.

Thanks for the attempt at helping anyway.
 

ColinTaylor

Part of the Furniture
Check the DNS servers that the client is using.

Try doing an nslookup directly to an external server address:
Code:
nslookup google.com 8.8.8.8
nslookup google.com 1.1.1.1
 

Datashuttle

Occasional Visitor
Ok, thanks again.

The USB modem is not just a modem, but a hotspot with it's own limited router OS. I don't believe that is a problem as the asus router is connecting fine with it. So it remains a DNS problem. I'll try some different name servers.

Directly connected to the hotspot router, nslookup cannot get to 8.8.8.8, or 8.8.4.4, or 1.1.1.1, It can, however, get to google.com. Ping returns the same result.
 

ColinTaylor

Part of the Furniture
Can you post the complete output of the nslookup commands as that can sometimes provide additional clues.

It is unclear to me whether you're testing from a client connected to the Asus or the hostspot, or from the Asus router itself.
 

Datashuttle

Occasional Visitor
nslookup 8.8.8.8
8.8.8.8.in-addr.arpa name = dns.google.

The above is the result of the nslookup. As you can see, it now returns dns.google. I changed to dns settings to the recommended openDNS IPs, and the above is what it returned.

I've been testing all of this from both the Asus router connected to the host router via USB, and directly to the host router via WiFi. I get throughput via direct connection to the hot spot host router, but not through the asus router even though asus shows connected on the wan config.

My guess is that now the hotspot and associated SIM is no longer allowing USB tethering to a router.

I'm not through messing with this but this is where I'm at at this point.
 

ColinTaylor

Part of the Furniture
Can you enter the nslookup commands exactly as I posted and then post all the output please.

nslookup google.com 8.8.8.8
and
nslookup google.com 1.1.1.1
and also
nslookup google.com
 

Datashuttle

Occasional Visitor
Sure, here are the results:
$ nslookup google.com 8.8.8.8
;; connection timed out; no servers could be reached


$ nslookup google.com 1.1.1.1
;; connection timed out; no servers could be reached


$ nslookup google.com
Non-authoritative answer:
Name: google.com
Address: 172.217.14.206
Name: google.com
Address: 2607:f8b0:400a:801::200e
 

Datashuttle

Occasional Visitor
Here's another interesting thing:

When connected to the asus router, which is connected via USB to an internet hotspot, and I issue the following nslookup command from my Ubuntu shell:

nslookup 8.8.8.8
;; connection timed out; no servers could be reached

Then without changing anything, I go into the asus router's Network Tools>Network Analysis tabs and run the same nslookup command, I get:

nslookup 8.8.8.8
Server: 208.67.222.222
Address 1: 208.67.222.222 dns.opendns.com

Name: 8.8.8.8
Address 1: 8.8.8.8 dns.google
 

ColinTaylor

Part of the Furniture
nslookup 8.8.8.8 is a nonsense command. It's trying to lookup a domain name called "8.8.8.8".

It looks like your Asus router is using a hard-coded DNS address of 208.67.222.222. I can't guess how you've configured your Ubuntu PC as there are many ways to do it.
 

Datashuttle

Occasional Visitor
I understand, but that was the option inside the asus network tools.

Okay, so now I've booted to Windows 10, and everything is working as it should. Now, I'm wondering if my network stack within Ubuntu is hosed up. I'm going to boot to a fresh Ubuntu install and see what happens.
 

ColinTaylor

Part of the Furniture
Sure, here are the results:
$ nslookup google.com 8.8.8.8
;; connection timed out; no servers could be reached


$ nslookup google.com 1.1.1.1
;; connection timed out; no servers could be reached


$ nslookup google.com
Non-authoritative answer:
Name: google.com
Address: 172.217.14.206
Name: google.com
Address: 2607:f8b0:400a:801::200e
What is the client you're using here and what is it directly connected to?
 

Datashuttle

Occasional Visitor
I beg to differ:
asusNetworkTools.png
 

Datashuttle

Occasional Visitor
Apart from all the rest, everything is working fine booted to Windows. But I hate Windows, so I have to figure out the problem with Ubuntu.
 

ColinTaylor

Part of the Furniture
As I said, that's trying to lookup a domain called "8.8.8.8". You are not specifying the IP address of the DNS server doing the lookup. That's why the query is being answered by opendns (208.67.222.222) and not google (8.8.8.8).
 
Last edited:

Datashuttle

Occasional Visitor
Okay. I'm good with that.

Here's the latest: I manually set all my device IP connections rather than relying on DHCP servers and everything is working.

Thanks Colin for your help.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top