1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Linksys EA9300 5GHz-2 Rejects connection

Discussion in 'General Wireless Discussion' started by SteelSteve, Jan 25, 2020.

  1. SteelSteve

    SteelSteve New Around Here

    Joined:
    Jan 24, 2020
    Messages:
    5
    As some may have seen in a previous post I have been looking or a new router because my EA9300 is rejecting connections on the 5GHz-2 band which I have set up for AC only. Unfortunately I really haven't found a router that really jumps out at me as being better than my current router, most seem to have issues with dropping Wifi or WAN connections periodically, or other stability related issues which I'm fortunate enough not to have to deal with before. So based on this I'm looking to see if anyone here might be able to help solve the problem I'm having with my existing router.

    I have a collection of older equipment, and IoT devices and though some can connect to the lower 5GHz band I'm assuming most of them are only 802.11N. For this reason I configured the 5GHz-2 band for AC only at 80MHZ. When I initially set it up it worked great and those devices that supported AC saw a speed improvement. Unfortunately after a few hour - days the band all of a sudden stops allowing anything to connect. I can still see the SSID, and the Signal strength looks good but I get some kind of authentication error, and the devices can no longer talk. A factory reset of the device seems to work most of the time, but again only for a short period.

    Since I can still see the SSID and Signal strength I'm assuming the hardware is working. Unfortunately Linksys interface both web gui and phone app is limited so I'm not seeing anything in there which could be causing this issue. Even more unfortunate is that Linksys hasn't released a FW update or this router since 2017, and based on the responses I and others have received from their tech support I don't think they will be anytime soon if at all.

    I did find the SNBForums review of the EA9300 and went to the hidden menu mentioned in that review. turning those settings off and on seemed to have no effect on this issue. I have tried setting different options, and even set everything include connection type to auto (mixed Mode). The only thing that seems to work once this happens is if I turn off all security on the band and make it open . Then all of a sudden my devices can connect to it again. Obviously this is not acceptable.

    Sorry for the long post.