Local DNS names

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

calzor suzay

Regular Contributor
I have an RT-AC86U and a RT-AC68U in a mesh on 384.19
Am I right in assuming anything you set in the GUI at the 'network map' part as in 'Clients name' has absolutely no effect for local DNS purposes?

Is there anyway to make it so it does?
I searched about and the other way is creating and setting up dnsmasq.conf.add but seems a manual process.
 

ColinTaylor

Part of the Furniture
Am I right in assuming anything you set in the GUI at the 'network map' part as in 'Clients name' has absolutely no effect for local DNS purposes?
Correct.

Is there anyway to make it so it does?
No, but you can set host names for clients by creating a reservation for them at LAN > DHCP Server > Manually Assigned IP...
 

calzor suzay

Regular Contributor
No, but you can set host names for clients by creating a reservation for them at LAN > DHCP Server > Manually Assigned IP...

Is there anything I need to do to make this work effectively?
I thought this should work but out of 7 devices with reserved IPs 2 work, 1 is the box I'm on and pinging so it's probably just resolving itself, all the others bar a NAS fail to resolve.
 

calzor suzay

Regular Contributor
actually after running nslookup of the 1 that did work (nas) it says

Server: RT-AC86U
Address: 192.168.1.1

*** No internal type for both IPv4 and IPv6 Addresses (A+AAAA) records available for nasx

when I ping it adds .local to the end so not 100% sure who, what or how that works, there's nothing in my win10 hosts file
 

ColinTaylor

Part of the Furniture
No, this should work without issue provided the clients are configured to use DHCP. You often need to reboot the clients after making any changes on the router so that they pick up those changes.
 

ColinTaylor

Part of the Furniture
when I ping it adds .local to the end so not 100% sure who, what or how that works, there's nothing in my win10 hosts file
Make sure you have specified a domain name for your LAN at LAN > LAN IP. Something like home.lan, and then reboot all your devices.
 

calzor suzay

Regular Contributor
Can you make it .lan?
I'm trying to make the FQDN as short as possible so mydevice.lan would work.
Or could I just use mydevice and the DNS request will lookup in .lan or would I need to specify the "DNS suffix for this connection" option as .lan in my Win10 network settings?
 

ColinTaylor

Part of the Furniture
Can you make it .lan?
I'm trying to make the FQDN as short as possible so mydevice.lan would work.
You could use .lan but whatever you choose remember not to put the leading dot in the router's Domain Name field. So that would be just lan

Or could I just use mydevice and the DNS request will lookup in .lan or would I need to specify the "DNS suffix for this connection" option as .lan in my Win10 network settings?
If you setup your clients to use DHCP properly (i.e. use the defaults) there is no need to manually specify the "DNS suffix for this connection" as that information is obtained from the router. Then you can use nslookup mydevice.lan or nslookup mydevice, both will work.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top