What's new

Logitech Squeezebox Radio disconnecting from Asus ZenWifi XT8 router

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Not sure if this is the best place to post this, but...

I have a ZenWifi XT8 router, HW ver 1, with one XT8 node, connected via AiMesh. I got the XT8's about 10 months ago, ran it with the stock Asus 388_22525 FW it came with (mostly, or maybe completely, set to defaults, since I don't know anything about networking).

We have a Logitech Squeezebox Radio (SBR), and had no problems with it for the next 9 months (though I see there are quite a few threads here about people who did have trouble with the SBR and the XT8s.)

About a 3 wks ago, I updated the XT8 FW (on main and node) to Asus 388_23285. The SBR continued to work just fine.

About a week ago, I flashed the XT8 FW (on main and node) to GNUton's Merlin 388.4, doing WPS resets on both main and node, both before and after the change, and not reloading the config file.

Since then, the SBR will not stay connected to the network. It works fine for about 10 minutes, then disconnects (message on its screen says, "problem connecting to mysqueezebox.com"; somewhere, it also says DNS failure). If I reboot the SBR, it will connect again, but only for about 10-15 min, then disconnects.

Comparing a screenshot of the Advanced Settings>Wireless>General tab from when the XT8s were on Asus FW 388_22525 to my current settings under GNUton's Merlin 388.4, I can see that wifi 6 mode was enabled both then and now.

Smart Connect used to be off, but now it is on. However, I don't think that this is the problem, because I have tried creating a 2.4-band guest network with a separate SSID and password, and putting the SBR on that network, and it still does the same thing - connects initially, then loses the connection in 10-15 min. Will reconnect temporarily if rebooted.

There may be additional differences between my settings on Asus stock FW and my settings in GNUton's Merlin - I have not finished going through all my screenshots, to make comparisons. I was hoping someone might suggest which settings to focus on or change. (I don't know enough about networking to have a clue, except that it does not seem to be a wifi 6 problem. Also, in some threads, it's been suggested that Aimesh is the problem, but the SBR stayed connected while Aimesh was enabled for the first 9 months.)

I posted about this on the Logitech Squeezebox Radio forum, and was told that I could fix the problem by "ssh-ing into the radio", and editing some file. It doesn't look impossibly difficult, but I am reluctant to go that route, because if I brick the SBR, it cannot be replaced. Since the radio worked initially (for 9 months) with this XT8 router, I think I should be able to adjust a networking setting in the router to fix the problem.

Thanks in advance for any suggestions! I'll just add that all our other devices, including 2 Como Audio internet radios are working fine. And my computer is a Mac, running Monterey 12.7.1. I do not have any Logitech Media Server software on my computer.
Last edited:
I just noticed something - in my screenshot of my previous settings under stock Asus FW 388_22525, under Advanced Settings>Wireless>General tab>Wireless mode was set to Auto - AND right next to that, there was a checkbox for b/g Protection, which was checked!

Under my current FW, GNUton's Merlin 388.4, under Advanced Settings>Wireless>General tab>Wireless mode is set to Auto. (I think this may be (not sure) because I have Enable Smart Connect set to ON, and under that, Smart Connect is set to "Tri-Band Smart Connect". ) But the main thing I am getting at is that there is no longer a checkbox for b/g Protection - I wonder if this is where the problem lies. (Maybe I am way off-base here - I don't really know anything about this stuff.)
We were having some trouble with stability under stock firmware 388_22525. Not with the Squeezebox Radio, but cell phone calls depending on wifi calling would sometimes drop, Netflix or Amazon would sometimes drop. I updated to _23285, but didn't stay on that long enough to know if it was an improvement - I may go back to that, and try. I had read that the Merlin FW was usually more stable that stock, and also, I want to add a VPN to the router, and I thought that it was supposed to be easier to do that with Merlin FW.
In Asus FW 388_22525, under Advanced Settings>Wireless>General tab>Wireless mode, there is a checkbox for enabling "b/g protection". (This seen in a screenshot I took - when Wireless mode was set to Auto; Smart Connect was Off, if that matters.) Is there a setting in GNUton-Merlin 388_4 that is comparable to that? I'm wondering if enabling that would help.
The problem will be with any router with Universal Plug and Play (upnp) enabled. The easy solution is to disable if you can but that could cause a problem for gamers. SET A PORT FORWARD FOR UDP 1900 ON YOUR ROUTER WITH THE SQUEEZEBOX IP.

I had to wireshark this to figure it out.
Hi, Steveo49! I'm not a gamer - so can I just disable Universal Plug and Play? Will it affect anything else (eg, my printer)?

Or you're saying the alternative is to "SET A PORT FORWARD FOR UDP 1900 ON YOUR ROUTER WITH THE SQUEEZEBOX IP"? Maybe I can figure out how to do that (not good at this stuff).

Also, I've been working with people at the Logitech Squeezebox forum. I've implemented a fix they suggested (ssh'd into the radio, and edited a file slightly to modify wifi settings), and that has helped considerably, although not completely.

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!