Mac connect to weaker Aimesh node

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

BatKing

Occasional Visitor
Hi,

I have recently setup Aimesh with 2 AC68U. the Router is running merlin 384.19 and the node is running official 3.0.0.4.385.20633 firmware. I have ethernet backhaul. My problem is my 2019 MBP will connect to weaker node over time. I have the router with my mbp in the same room which RSSI is -38 to -40. The node is one floor down and the mbp gets about -62 RSSI to -64 RSSI. The node placement may not be ideal as it seems too close to the router (almost directly one floor below), but that's the only ethernet port I have for that floor otherwise I will have to use wireless backhaul.

Strange thing is most of my smart devices, windows laptops and my iOS devices are all smartly roam between the node and router. but the main mbp I am using in the router room will connect to the weaker node under floor. when start, the mbp is connect to the router. but within 20 mins, it will roam to the weaker node and stay there forever. Unless I turn wireless off and on again, then the mbp will connect to the router, but after a while it roam to the weaker node again.

I don't have roaming assistance on as both router and node give me signal strength over -70 so not sure if that makes any difference. According to Apples's doc MacOS only roam when RSSI below -70 so it seems roaming assistance default setting won't help or I will have to set it to -62? will that affect other devices as I have a laptop in a location only gets about -75 RSSI but is very stable (never got disconnected for months), if setting -62 for roaming assistance, will that bounce that weak signal laptop around all the time and unstablize its wifi?

Thanks.
 

OzarkEdge

Part of the Furniture
Hi,

I have recently setup Aimesh with 2 AC68U. the Router is running merlin 384.19 and the node is running official 3.0.0.4.385.20633 firmware. I have ethernet backhaul. My problem is my 2019 MBP will connect to weaker node over time. I have the router with my mbp in the same room which RSSI is -38 to -40. The node is one floor down and the mbp gets about -62 RSSI to -64 RSSI. The node placement may not be ideal as it seems too close to the router (almost directly one floor below), but that's the only ethernet port I have for that floor otherwise I will have to use wireless backhaul.

Strange thing is most of my smart devices, windows laptops and my iOS devices are all smartly roam between the node and router. but the main mbp I am using in the router room will connect to the weaker node under floor. when start, the mbp is connect to the router. but within 20 mins, it will roam to the weaker node and stay there forever. Unless I turn wireless off and on again, then the mbp will connect to the router, but after a while it roam to the weaker node again.

I don't have roaming assistance on as both router and node give me signal strength over -70 so not sure if that makes any difference. According to Apples's doc MacOS only roam when RSSI below -70 so it seems roaming assistance default setting won't help or I will have to set it to -62? will that affect other devices as I have a laptop in a location only gets about -75 RSSI but is very stable (never got disconnected for months), if setting -62 for roaming assistance, will that bounce that weak signal laptop around all the time and unstablize its wifi?

Thanks.

I would spread the nodes/signals apart to better differentiate them for your wireless clients.

I would enable Roaming Assistant node steering and raise (less negative) the band RSSI threshold to help better differentiate the node/signals for your wireless clients.

Make one change at a time and live with it long enough to make some useful observations of client behavior.

OE
 

L&LD

Part of the Furniture
I would also try 'forgetting' (and removing from the keychain) the network SSID from the MBP, rebooting it, and then re-associating it again.
 

BatKing

Occasional Visitor
I just leave it ping to google.com for last 4 hours and it stick to the same room router. after that reboot my mbp since i setup AiMesh 2 days ago. next will try to forget the SSID if this doesn't help. Thanks everyone.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top