Solved Media Bridge vs AiMesh Node (GT-AC5300 and-GT-AC2900) Clients Limitation

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

bnevis

New Around Here
These forums have so much useful content in them, that I want to share something I learned that will perhaps help others. As far as I know, this is the first post on this particular issue.

I had an existing setup where I had an AC2900 connected to an AC5300 via a wireless media bridge (work from home setup), where I had a laptop and a couple of maker boards hard-wired into the AC2900 and the whole thing set up via a wireless bridge to my primary router (because there was no easy way to run a wire). This has been working well for over a year. I chose media bridge because I wanted to force everyone else to connect up to the main router.

Recently, I recently I added a KVM server and started setting up VM's using MACVLan/MACVTap in bridge mode, so that each VM shared the physical network cable with its own IP address. (The host was also set up using systemd-networkd for macvlan mode so that it could also talk to the VMs sharing the port as well.) This went fine for the first one or two VM's, and then it got bad.

I would start a VM and it would not get an IP address, or I could configure a static IP address but it could not ping the AC5300. On-box connectivity was unimpacted, so it wasn't a software bug. If I rebooted the VM enough times, 1/10 times it would have network connectivity, but if I had connectivity and rebooted, I would lose it the next boot. Viewing the logs on the AC2900 showed that it was getting, for example, DHCP packets from the VM, but they would never be responded to. Exhausted and tired, I went to bed and decided to sleep on it. In the morning, on a whim I decided to configure the AC2900 for AiMesh operation. Wouldn't you know, but everything started working perfectly!

It is still not clear to me whether the problem was with the parent access point or the wireless bridge (should have tried pinging the laptop but too late now).

However, my conclusion from the above exercise is that Media Bridge mode has some undocumented limitations with the number of clients that can share the upstream link that are not present when running in AiMesh node.

My advice is that if you are running Media Bridge just so that you don't have another radio broadcasting, to just go with AiMesh operation and save yourself the headaches later.

I was running the 3.0.0.4.384_82037 on the AC5300 and 3.0.0.4.384_82072 firmware which was up-to-date as of the time of this post.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top