Merlin 384_19 Problem with Block Routed Clients if Tunnel goes down

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

pusb87

Regular Contributor
Since updating to Merlin 384_19 on my RT86U I have issues with the Block Routed Clients if Tunnel goes down option.

1601811972915.png

It seems that if this box is enabled in any OpenVPN client, whether the client is active or not , that all access to the internet is disabled.

I have found that i need to set all clients to NO and reboot the router to regain internet access.

The VPN client will work if the option is set to NO, but ideally I would like to have the Policy Rules working correctly so that if the VPN clients tunnel does go down then internet access is then stopped.

Has anyone else experienced this or have a resolution.

thanks in advance
 

L&LD

Part of the Furniture
This is working as intended. It can't discern if the tunnel is down or if the tunnel is just stopped.
 

octopus

Very Senior Member
Since updating to Merlin 384_19 on my RT86U I have issues with the Block Routed Clients if Tunnel goes down option.

View attachment 26674
It seems that if this box is enabled in any OpenVPN client, whether the client is active or not , that all access to the internet is disabled.

I have found that i need to set all clients to NO and reboot the router to regain internet access.

The VPN client will work if the option is set to NO, but ideally I would like to have the Policy Rules working correctly so that if the VPN clients tunnel does go down then internet access is then stopped.

Has anyone else experienced this or have a resolution.

thanks in advance
Use "Routed Clients if Tunnel goes down" on only last vpnclient.
 

pusb87

Regular Contributor
This is working as intended. It can't discern if the tunnel is down or if the tunnel is just stopped.
Is this is a change then from 384_17 ? . If im correct it never worked like that on that firmware , or many previous ones, only started to happen when i moved to 384_19.

So how would I enable that option and be able to have internet access ?
 

MysticGold04

Regular Contributor
You could set a rule to apply the VPN killswitch only to your intended clients- unless that is your whole LAN. For instance, I've applied a rule that only one client gets blocked if the VPN goes down...
 

pusb87

Regular Contributor
You could set a rule to apply the VPN killswitch only to your intended clients- unless that is your whole LAN. For instance, I've applied a rule that only one client gets blocked if the VPN goes down...
Oh good but I dont know how to do that ...can you show me how, perhaps with a screenshot or two ??
 

MysticGold04

Regular Contributor
on your VPN Tab, go to VPN Client tab and at the bottom, set the following. Then, add whatever client, for example and then set the routing policy, then apply.
Screenshot from 2020-12-16 09-59-56.png
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top