1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

merlin 384_6 Internet Status Disconnected

Discussion in 'Asuswrt-Merlin' started by dgs2001, Aug 18, 2018.

  1. dgs2001

    dgs2001 New Around Here

    Joined:
    Oct 18, 2016
    Messages:
    5
    Good Afternoon,

    I have been using Merlin for a while now. I have a draytek vigor 130 modem coupled with a asus AC68U router.

    Up until yesterday I was on firmware 384_5 which worked great.

    Today I have made many attempts to upgrade to 384_6 but am unable to establish a connection to the net.

    I have tried doing a complete reset and still the same outcome, looking at the Network Map, I get "Internet Status DISCONNECTED" at the top, whenever I use firmware 384_6

    Roll back to firmware 384_5 and all is ok again.

    I've been through the settings and all appears correct, has anyone else had trouble with 384_6 ??

    It would be most appreciated if somebody could point me in the right direction.

    Thanks
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. skeal

    skeal Very Senior Member

    Joined:
    Apr 30, 2016
    Messages:
    1,764
    Location:
    Canada
    Try flashing to the alpha build of 384.7. You can find it in the "Test Builds" folder. Try this link it should land in the "Test Builds" folder. https://onedrive.live.com/?authkey=!AGY2taGX02nVmWA&id=CCE5625ED3599CE0!1427&cid=CCE5625ED3599CE0
     
    scjr likes this.
  4. joe scian

    joe scian Regular Contributor

    Joined:
    Apr 22, 2018
    Messages:
    68
    Do you have DNSSEC selected - try deselecting this,
     
  5. DaveTheDogMan

    DaveTheDogMan New Around Here

    Joined:
    Aug 19, 2018
    Messages:
    1
    Try disabling DNS Rebind Protection. This worked for me after upgrade to 384.6 from legacy formware.
     
  6. dgs2001

    dgs2001 New Around Here

    Joined:
    Oct 18, 2016
    Messages:
    5
    Thanks all. Tried the alpha but same result.

    Just going to do a full reset and start again from scratch.

    My next question is do I need dnssec or rebound protection?

    Thanks
     
  7. dgs2001

    dgs2001 New Around Here

    Joined:
    Oct 18, 2016
    Messages:
    5
    Ok Thanks to the above posters who pointed me in the right direction.

    I had/have DNS issues!

    Its a bit above my head but I seem now to be only able to connect if I manually add DNS serves to the wan page.

    In order to understand why can somebody please explain the following settings. Also please note I'm trying to use vpn dns on two devices, while the others benefit from using BT dns and the content filtering it has built in.

    So in Advanced WAN settings if I leave "Connect to DNS Server Automatically" set to yes I cannot connect to the internet. If I set this to no and add the vpn dns then I connect, but all devices are using the VPN DNS which is not the desired behaviour.

    Currently in the LAN "DNS and WINS Server Setting" page I have no DNS servers entered, with advertise routers IP set to NO, Forward local domain queries set to NO, Enable DNSSEC support set to YES, Enable DNS rebind protection set to YES.

    I then have two devices which run through a vpn, according to IPLEAK they are set up correctly with DNS routing to the same VPN server address.

    Hope that makes sense and somebody can help teach me!
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!