Merlin 386.1 Beta 4 - AiMesh 2x AX86U, Node constantly disconnecting clients

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

AndrewJacob

Regular Contributor
Hi everyone,

Just recently connected 2 AX86U via 2.5GBE backhaul as AiMesh, and the connection quality appears as "Great" according to the firmware.
However, when I am near the node, I get a lot of drops, very often.
Can someone help with this? Single router performance was good before connecting the second router.

1610740512612.png


1610740754494.png

My goal with this setup was to blanket the entire 2 stories in 5ghz 450mbit speeds, as well as the outdoor patio.
I have wired as many devices as possible and am not experiencing issues with the wired devices. Connection issues are only on Wi-Fi and in the living room as well as the outdoor patio areas.

Thanks,

Andrew
 

AndrewJacob

Regular Contributor
Thanks @Sky1111 , did you experience the same issue on yours? I've noticed you have the same setup as me.
Also, should I rollback just on the node, or on the router and the node?
@RMerlin @L&LD would appreciate your advice please:)
 

L&LD

Part of the Furniture
How close are you and with what device(s) when you say, 'when I am near a node', does it disconnect? I'm assuming the 5GHz band is the one that is having issues, correct? Have you tried different (manual) control channels?

386.1 Beta 4 is very stable. You may want to try the suggestions below to see if they help too.
  • Disable the Ethernet Backhaul Mode in AiMesh, System Settings.
  • Remove the node from the AiMesh router (via the GUI from the main router).
  • Remove the Ethernet cable from the node's 2.5GbE port and from the main routers 2.5GbE port.
  • Fully reset the node (via the WPS method) and leave it alone (do not touch it at all, via ssh, it's GUI, or any other method).
  • On the main router, select another control channel, reboot the router and the device you're testing with, wait for the router to stabilize and test for network responsiveness and throughput (keep notes).
  • With the control chosen (and not left on Auto), add the AiMesh node again to the network via the main router's GUI.
  • After it has connected and is running for 15 minutes or so, reboot the AiMesh node (via the main router's GUI).
    • Find that command in AiMesh, select the node, Management, Reboot Node.
  • After it has reconnected, connect the AiMesh' node 2.5GbE port to the main router's 2.5GbE port again.
  • After the system has been running 15 more minutes...
    • Enable the Ethernet Backhaul Mode in the AiMesh, System Settings.
    • Let the system settle for an additional 15 minutes to an hour.
  • At least 15 minutes later (or ideally an hour), initiate a System Reboot from the AiMesh, System Settings page from the main router.
The above steps have proven effective to get an AiMesh system stable for myself and a few of my customers too.
 

AndrewJacob

Regular Contributor
Thanks @L&LD , I'll try that now.
To answer your questions:
- Disconnects happen anywhere within a radius of 20 feet around the node. Right now, even after a reset, it will say that the password is wrong and boot us, then sometime it'll connect and that will last maybe 1 minute before we get disconnected again
- 2.4Ghz is working fine, and so is wired. The issue is indeed with the 5Ghz as you suspected
- 5Ghz is on channel 161 which isn't taken up by other signals (i've checked with Wifi Analyzer) and works flawlessly throughout the second floor where the main router is located. I haven't thought about trying different channels because of this and because I never had this issue when I was on single router setups.

I followed all your setup steps from the other post, but I will try again what you've suggested above and report back.
 

L&LD

Part of the Furniture
Perhaps just try doing a System Reboot first then? If you haven't started on the other steps. :)


Edit: A System Reboot from the AiMesh, System Settings page is doing something different than if we reboot each router individually or if we reboot by powering off the routers too. They seem to be 'syncing' better with a System Reboot. :)
 

Sky1111

Senior Member
Man my setup is gone crazy again... one day of stability and it is all down crazy connect-disconnect.. As I type this post, I had to shutdown my node because it is so unstable that my kids could not do their zoom classes (not school-related). So all wireless clients are now from the router in the basement and finally everybody's wifi is stable.
- Theory #1: 2.5G backhaul connection over my existing ~9 CAT5e cables is not stable. Switched to 1GB ports, but no improvement
- Theory #2 even 1G ethernet backhaul connection is not stable (less likely, but not impossible)
- Theory #3: my node AX86u got possessed by evil spirits. On serious note, I did reset few times and re-added to AImesh. Still unstable

Note that I am running Merlin Beta3 on both; and the node one - which does very little - feels warmer than I expected

I am now considering - next after L&LD full reset of the main router - is to use the second router as access point. I do not like that idea as I will have to introduce 2 additional AP (one for each band), and while it will work very well for non-mobile clients (where I can chose the best access point), for mobile clients it will be a hassle (going from 2nd floor to basement will require to switch the AP, not very convenient if you are doing it few times a day)

Beta4 - may be better for AImesh, but performance sucked so bad that I am really not willing to go there.

I need to research on how to test my wire from basement to 2nd floor
 

AndrewJacob

Regular Contributor
Hmmm sorry to hear about the problems @Sky1111 !
I've tried the AiMesh reboot as suggested by @L&LD , but it only works on and off, but it works more often now.
Not really sure what to do. Wired and 2.4Ghz are working fine though.
 

Sky1111

Senior Member
So I used Intel network Pro tools (part of Intel NIC driver) to run cable tests, and it all comes clean. Connected the cable from the basement to the desktop upstairs and copied a large file (cable directly connected to the desktop), copy goes steady at 98% utilization of 1Gbps, with no hesitation (~40GB file took about 5 min to copy).
So at least for gigabit speeds, my ethernet backhaul seems to be good. (the experts will laugh at such low bar, but I do not have access to real high end tools to verify my LAN)
Meantime, since the node was off, everything is working STABLE... so it seems like AImesh is the evil spirit wrecking the network? Like looping 5G and ethernet together?

Switching the second AX86u into simple access point starts to look more and more appealing... (until this mesh madness gets sorted out)

P.S. Folks who are happy with Merlin Beta4:
- do you run VPN client on your router?
- do you have Mesh setup?
 

AndrewJacob

Regular Contributor
Hi @L&LD , I am trying to follow your steps but the Node won't allow AiMesh to connect wirelessly. The routers are 2 feet apart in the same room. The node only has power connected to it and i did the full reset as per your article (holding the WPS button...). Any advice on how to fix this?

1610844825039.png
 

hancox

Occasional Visitor
Hi @L&LD , I am trying to follow your steps but the Node won't allow AiMesh to connect wirelessly. The routers are 2 feet apart in the same room. The node only has power connected to it and i did the full reset as per your article (holding the WPS button...). Any advice on how to fix this?

View attachment 29606

Try via the "network map" screen, and not the AIMesh one. I would bet WPS is off on your main router, and this "new" AIMesh screen doesn't prompt to turn it on.
 

AndrewJacob

Regular Contributor
Thanks @hancox , I didn't know that it could be done that way, and I didn't know that having WPS on or off on either the router or the node could make a difference.
All that to say, I used @L&LD 's method of connecting the node from it's WAN port to the main router's LAN port and i was able to add it. I then followed all the other steps and guess what?
Same issue. AiMesh says it's working "great" in the firmware but it's pretty much not working at all.
For the first time ever, I saw Zoom telling us we have an "unstable connection" which never even happened once on my weak ISP AC routers.
Devices keep getting dropped when near the node... It's pretty bad.
2.4ghz and wired work flawlessly, but the 5ghz band (my main goal) is useless on the ground floor.
Any ideas? @RMerlin , should I be downgrading to Beta 3 to fix the issue and wait for the Beta 5?
 

L&LD

Part of the Furniture
I think two feet apart is too close. Are you able to verify that they are truly reset after using the WPS method you used?

Did you find a better Control Channel to use than what the router chose?
 

AndrewJacob

Regular Contributor
Thanks for your response @L&LD . Well according to the firmware, it's connected. Should I be redoing certain steps?
- Control channel: there was never any issue with the control channel I was on (161) but I did change it to 52. When I am on the second floor (this is where 5ghz works), the performance of channel 161 vs 52 is very similar. Also, I never had it on Auto. As per your instructions, I manually chose channel 161 right from the start.
- Reset method: I followed the instructions you gave. How do I verify if the router was completely reset or not? Although we are talking about the node, I have used this exact reset method for the main router and it worked perfectly.
What do you suggest as next steps?
 

L&LD

Part of the Furniture
Apologies, I am not able to answer fully right now. I am heading out for work.

I do not think I state anywhere to choose a specific control channel. Test each one available with multiple devices and while using the network normally, not just speed tests. From the same test spots in the areas, you want coverage in, for each channel. This is why notes are important.

I would start from the beginning as the routers/networks do not sound stable to me at all.

Power off the entire network, including client devices (wired, for wireless a new (test) SSID is sufficient, but I would still reboot each one at least a couple of times while you're resetting the routers). Flash the firmware and reset the router with all the methods available, including formatting the JFFS partition too, in between the firmware resets and flashes.

Fully Reset Router and Network

The fact that the network is acting similarly to how it was before your resets are indicative to me that it was not reset fully and/or configured properly afterward.

There may be an external environmental issue too that we're not able to account for right now. But if the steps suggested are followed fully, the hardware should be as stable as it can be. Try one more time to get the hardware to a good/known state along with making sure the firmware that is being used is fully reset and allowing the router to used its expected defaults.

When you're at that point, re-introduce your client devices one by one, slowly, and test your network fully. Including rebooting it to see if it stays stable afterward.

Maybe also re-read the suggestions without actually doing them. You may see/notice something that you assumed or presumed, previously.
 

Make WiFi Great Again

Regular Contributor
Dont know if it applies to all Intel wireless cards or just mine but Intel has a bulletin sort of thing stating to disable APSD in router and client because of technical issues.


 

AndrewJacob

Regular Contributor
Thank you, great article but not sure if it's applicable here. Will disabling APSD potentially solve my problem?
@L&LD , before I added the second router, everything was functioning buttery smooth. In fact, the single AX86U router was doing a good job at covering all of my place, albeit not as strongly as the AX11000.
I only started to have problems when adding the node, only on the ground floor, and only with the 5Ghz band. Should I be enabling WPS on the main router when adding the noded one as suggested by @hancox ? I had disabled WPS as per your instructions.
I'll wait to hear back from you before trying the full reset.
 
Last edited:

Sky1111

Senior Member
Hey folks, quick update here: I set my second AX86u as AP, no more that buggy "AI mesh", and all the instability is GONE!
- 2 of my wireless security cameras doubled the speed. The one that was saying "poor", now it is "excellent" (-53.20 dBm, was like worse than -70)
- for the first time ever, my AX laptop showed full 2400 Mbps speed
- no more crazy connect/disconnect issues!

Of course it is all good as long as you are not moving around, so need to switch the band as change the floor, etc.

So that means AImesh is very buggy. I thought the whole point of AImesh is to steer clients to the strongest wifi signal, but now I have evidence that it does not do that properly.

With the second router in AP mode, I also have more control over the second router. I was able to enable jumbo frames, and check the temperature (it is running a bit high >70 degrees
 

AndrewJacob

Regular Contributor
Hi @Sky1111 , that's good to know, thank you! However in my case, I do not like the idea of having 2 SSIDs, in which case I'm just better off using both my old ISP routers (Zyxel 2926).
So far the solution that has worked the best was the single AX11000 followed by the single AX86U. The AX86 was more responsive and snappy, but the AX11000 had a stronger signal at the farthest reaches of my home.
I'm really hoping to get the 2 AX86U's working, as they would probably be the best solution with a stable AiMesh. I wonder if I got a lemon hardware-wise with one of my routers and that is maybe the problem.
The only thing unique about my environment is that I am in an extremely highly wi-fi dense area (10+ strong wi-fi networks/signals appearing anytime I check my phone or laptop), but it's nothing that the single routers or the 2 Zyxels couldn't handle. So not sure why the 2 AX86U are struggling nor how to solve this. Looking forward to what @L&LD will suggest as I haven't heard anything from @RMerlin yet.
 

L&LD

Part of the Furniture
@AndrewJacob, yes, you need to enable WPS before trying to add an AiMesh node. (I then immediately disable it again afterward).

To test for new control channels, you do not need to reset the whole network. You may need to though, depending on what other settings and options you were testing on/off with beforehand.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top