Mesh Node not releasing clients

Eric Lieb

Regular Contributor
I am running on the latest merlinwrt on a ax58u as the primary router and an ac86u as a node (hardwired). Recently all my wifi devices seem to migrate to the node and never back to the main router (to the point that I had 0 wifi clients connected to the router). I have roam assistance set to -70 dB but can't figure out how to see the signal strength to devices on the node.
 

Morris

Senior Member
AP selection is the job of the client. The roaming assistant is a fudge that disconnects the client hopping it will chose another AP. Sometimes it works, sometimes it dose not. Turn off the node and the sticky clients will have no place to go except the router. Then turn on the node and cross your fingers.
 

Tech9

Part of the Furniture
to the point that I had 0 wifi clients connected to the router

You perhaps don't need 2x routers at all. This is happening because single router signal strength is good enough.

By the way, your AC86U router is the faster hardware device, except AX Wi-Fi. It may work better as primary router.
 

Eric Lieb

Regular Contributor
You perhaps don't need 2x routers at all. This is happening because single router signal strength is good enough.

By the way, your AC86U router is the faster hardware device, except AX Wi-Fi. It may work better as primary router.
The ax58 has more cpu cores and has better OpenVPN stability in my experience
 

Tech9

Part of the Furniture
No. AX58U has more weaker CPU cores and the same amount of RAM. ARMv7 vs ARMv8 + AES. AC86U is >2x faster on OpenVPN.
 

Eric Lieb

Regular Contributor
No. AX58U has more weaker CPU cores and the same amount of RAM. ARMv7 vs ARMv8 + AES. AC86U is >2x faster on OpenVPN.
Idk... On my cell phone I could only get 200 Mbps at fast.com on the ac86.. when I switched to the ax58 I am getting over 400 Mbps at the same distance and everything. I have gigabit fiber and everything has been more stable since switching the primary router from the ac86 to the ax58. Same 5ghz channel and everything in the setup.
 

Eric Lieb

Regular Contributor
Remove the node and test with one router only. May be enough to cover your place.
It isn't. Reason I had to put a mesh Node downstairs and with the primary router upstairs was because I was having issues with stuff like the wireless doorbell camera and blink sync module that are downstairs. Also need a switch downstairs (put my qnap and some other stuff downstairs) so the node is also acting as a switch. I hardwired the router and node.

I am just going to run the OpenVPN server on the qnap which is faster than the routers (quad core Celeron with 16gb of ram)
 

L&LD

Part of the Furniture
Not a good idea to run a direct connection to the QNAP to the outside world. You're asking for major trouble for your data, security, identity, etc.
 

capncybo

Regular Contributor
Here's my 2bits... IMO much of the hype about Mesh is over-rated. I've found the performance to be somewhat disappointing.
In reality, most people will never be "Networking Experts" nor will they typically be "Network Enthusiast" or inclined to learn a ton about all the complexities.
They just want connectivity & decent performance.
MESH is super easy to setup but just as anything with automatic configuration... it doesn't give much feedback or information as to what is really going on.
It sounds like your usage case is... much like my own.
There may be a few dead spots or an end-location completely out of range of one single router.
However in our cases there are likely dead-zones causes by physical structures of our houses & even appliances etc which block & impede radio waves.
Yet if you step to the side... you are still well within range of the first/main WiFi router.
Why I think AiMESH is somewhat flawed is... you can't set the individual signal strength of the nodes.
Logically you would just want the nodes to cover the small dead-zone, & not transmit WiFi all through-out much of the house.
Visualize minimizing WiFi radio-signal over-lap.
And... when you have WiFi radio overlap, any client devices will hang on to the WiFi for as long as possible (Well as long as it's connection algorithm dictates).
I'm not sure if your mobile devices are Apple or Android but for Android...
I've always found WiFi Analyzer does a decent enough job of letting me see the dB signal strength of 2.4G & 5G on my mobile client device.
You described using the default -70 dB
But if you want clients to be forcibly disconnected via the router adjust it to a less Negative value... try -60 (If that's too much try maybe -65)
Anyways my point with MESH is too much WiFi Radio is never great for performance nor reliability.
Probably should turn down the TX power (Under: Wireless>Professional Tab [@Bottom]) to Minimize the Radio Overlap.
But the Big Problem is the Mesh Nodes want to copy the main router's TX power setting & the same goes for the Roaming assistant value Arrrg!!!
Anyways I'm not sure if your house can somehow allow you to implement it but...
If you can connect the nodes to the main router via Ethernet.
You may find it's actually better to change your node to an access-point.
By doing this you can set the TX power & Roaming assistant values SEPARATELY.
You should be able to pick a suitable Roaming assist value that works with the varying signal strengths on your mobile devices.

Sorry for the novel but, not everything is easy.
Automatic Configs such as AiMesh are rarely optimized or always Best.
 

Eric Lieb

Regular Contributor
So I disabled Roaming Assistant and now all my devices aren't migrating to the AC86U mesh node and staying there... I think something may be broken in the latest firmware and Roaming Assistant.
 

capncybo

Regular Contributor
So I disabled Roaming Assistant and now all my devices aren't migrating to the AC86U mesh node and staying there... I think something may be broken in the latest firmware and Roaming Assistant.
I'm trying my best to follow this... But if you (Disable/turn-off) the Router/Node Roam Assist...
The Wifi Connection is exclusively managed/maintained by each individual client.
Did you try moving closer to the Node... Disconnecting & Then Reconnecting the client WiFi?
Depending on the Client's Wifi Algorithm... It should "typically" reconnect to the SSID with the HIGHEST signal strength.
But depending on the software & if you have too strong of a radio signal (from the router) perhaps the clients keep connecting to that.
IMO all these variable factors start to prove my earlier points about automatic modes & mesh systems not working as expected.
Ideally if you are using Mesh systems... They should be used at the minimum TX power possible. To minimize radio overlap.
However... here's the catch.
If you turn down the power (too much) you can potentially slow down the wireless (router<->node-backhaul) and negatively affect your network.
Have you already tried turning down the TX Power under (Wireless>Professional Tab)?
It may seem counter intuitive but, in my experience turning down the WiFi power has often improved performance.
+ It will also minimize heat & likely increase stability & runtime.
Note: you also have to remember that (depending on you configuration)
There are separate settings for Power & Roam assist for Both 2.4 & 5G radios.
(You may know all of this already... But perhaps this knowledge will help someone else)

Good Luck
 

Morris

Senior Member
I'm trying my best to follow this... But if you (Disable/turn-off) the Router/Node Roam Assist...
The Wifi Connection is exclusively managed/maintained by each individual client.
Did you try moving closer to the Node... Disconnecting & Then Reconnecting the client WiFi?
Depending on the Client's Wifi Algorithm... It should "typically" reconnect to the SSID with the HIGHEST signal strength.
But depending on the software & if you have too strong of a radio signal (from the router) perhaps the clients keep connecting to that.
IMO all these variable factors start to prove my earlier points about automatic modes & mesh systems not working as expected.
Ideally if you are using Mesh systems... They should be used at the minimum TX power possible. To minimize radio overlap.
However... here's the catch.
If you turn down the power (too much) you can potentially slow down the wireless (router<->node-backhaul) and negatively affect your network.
Have you already tried turning down the TX Power under (Wireless>Professional Tab)?
It may seem counter intuitive but, in my experience turning down the WiFi power has often improved performance.
+ It will also minimize heat & likely increase stability & runtime.
Note: you also have to remember that (depending on you configuration)
There are separate settings for Power & Roam assist for Both 2.4 & 5G radios.
(You may know all of this already... But perhaps this knowledge will help someone else)

Good Luck
Sticky nodes (clients) is a well know and very old problem. It is caused by driver and/or firmware issues with the client. First off, just because we think one AP is a better choice, the algorithm that the client uses may not agree. Then there are the various features that APs utilize to convince a client to move to another AP. They include the Cisco extensions which basically say "disconnect and connect to this AP" and the likes of the Asus roaming assistant that send a disconnect to the client and hope it will then find a better signal. This feature is a great way to have your uses compline about drops. Most clients will attempt to connect to the same AP they were last connected to. This is because it is fast and maintains service in the case of a loss of signal. After this they run there assessment of where is the best place for me to connect. Now we are back to "just because we think one AP is a better choice, the algorithm that the client uses may not agree." They may not agree with our assessment because they know better, there algorithm is defective or possibly there designers favor one WiFi standard over another, for example AX over AC.

One thing that seems to help with many clients when they stick to an AP is to tell the client to forget it's connection. Then it starts by evaluating all APs for the best choice instead of connecting where it was last connected. It's the client's choice where to connect. Having designed and managed a network with thousands of APs and 10's of thousands of clients for nearly 20 years, I can early say that this problem is not easy to solve. The person with a sticky client will blame the network and tell you it works great everywhere else. When you interview them you learn that everywhere else is a single AP network. The reality is the problem is in the person's hand and the cause is wide spread.

If you can, use a single AP. If there are dead spots, fill them with APs that have there transmit power as low as possible and place them where there least likely to be heard by clients that are better served by other APs.

Morris
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top