What's new

MOCA 2.5 Help Needed - Why Are my Speeds Slow in 1 Direction?

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

kelllogg9

Occasional Visitor
I have the ScreenBeam (ActionTec) ECB7500 (moca 2.5)

I have two PCs (both Win11 Pro). Both have the same specs. When i transfer from PC1 to PC2 across the 2.5Gbps network i get 285MB/s. However, when transferring the same file (after clearing the system file cache via RAMMap) from PC2 to PC1 i only get 112MB/s. iperf3 tests are the same (ie. one direction is full, the other direction is half). My guess is the "bonded" feature is working only in one direction since you can see its roughly half the speed. Can't figure out why though. Maybe one of the moca devices is defective??

It used to work fine (speed was 285MB/s in both directions). Nothing has changed on the network.

I hooked both Moca devices directly to each other using a tiny coax adapter so its only inch apart from each other -- eliminating any concerns of distance or a corrupt cable. The same problem persists. I have moca filters but obv in this test they were not needed.

I swapped both devices and the speed and direction loss remains the same and in the same directions, despite using the other moca for a pc. You would think the direction would reverse. Wrong!

I connected my ethernet cable directly to both pcs and the speed returns to 280MB/s in both directions. So its not a Windows config issue.

ScreenBeam sent me their latest (soon to be released)firmware (v. 1.18.7.5) to upgrade to recently to see if it would resolve the issue. It did not. My org version was 1.18.2.0.

Their tech thinks i need to increase my TCP Window on both PCs to resolve the issue. I told him that using my ethernet cable with no moca devices shows the tcp window is not the issue cuz my speeds return to 285 MB/s in both directions. His response:

"Because of the nature of the MoCA connection, it has higher latency than an Ethernet connection. Even if the maximum UDP throughput is the same as Ethernet, high-speed TCP throughput requires more buffer (TCP window size) to reach the same throughput as Ethernet."

If that were true then the speed in both directions would be 112MB/s, which it is not. So latency isnt the issue. But nonetheless, i set on both pcs:

netsh int tcp set global autotuninglevel=experimental
Registry: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters!Tcp1323Opts (DWORD) set to "3"

Unsurprisingly, it made no difference.

Any ideas? I'm all out.
 
Last edited:
get into the diagnostic pages for the moca modems to check power levels and sync rates.
The only other thing to look at is the power wall warts. Swap them only and see if the problem moves with the power wart.
 
Registered here just to post this. Having the EXACT same issue in my case with GoCoax adapters. 2 windows machines with Realtek 8125b cards. All POE filters in place (outside and on cable modem). Web UI shows inter-node link is at full MOCA 2.5 speed. Both machines saturate the 2.5G connection over ethernet.

Speed in one direction about 215MB/s. Speed in the other direction is capped at 50MB/s

@kelllogg9 did you ever find a solution?
 
I'm seeing something similar with a pair of ScreenBeam ECB7250's, but worse: one direction achieves full-rate 2.35Gbps per iperf3, but the other direction can only manage a couple hundred Mbps. I've not yet tried the swap-the-adapters idea. Anyone have a clue what's causing this?
 
I'm seeing something similar with a pair of ScreenBeam ECB7250's, but worse: one direction achieves full-rate 2.35Gbps per iperf3, but the other direction can only manage a couple hundred Mbps. I've not yet tried the swap-the-adapters idea. Anyone have a clue what's causing this?
Hi there. Yea i recall having this very similar problem with my ECB7250s. Another person i spoke to recently in DM on this site has/had the same problem as yours. So you most definitely are not alone. I first discovered it over a year ago. Frustrated the hell out of me. At the time i spoke with tech support each day for a few week straight but they were pretty useless. So i ended up going back to goofing around with Windows settings and doing more experiments. At the time i wrote my problem i think i was using Windows 7 (??). I am now using Windows 11. The problem STILL persists at times. Its random it seems. And its always in one direction that has the issue. The other is always full speed 2.x Gbps.

However, i noticed something interesting. I notice that my speeds WILL spike back up to max speeds (280MB/s) both ways at times and other times only one way will always be 280+ while the other way will drop to a max of 180MB/s. But no matter what, at least one direction will be 280+ MB/s.

I get a sense, at least for my case, it is Windows that is throttling my moca max speeds because i notice if say i am streaming a live video say from Twitch and then i transfer say a 10GB movie file in either direction on my LAN the speeds will be 280MB/s both ways (and that is me clearing the file cache to keep it fair -- using RAMMap app). The same with iperf tests. But if i dont stream from the internet and wait a while then the speed may (and usually does) drop back down to 180MB/s in the one direction. I can't be fully sure if this is a consistent pattern. For example, just now i am on Twitch watching an ethot being an ethot and as i watch i am now testing a transfer on the lan and the speeds are 280+ in both directions.

For the fun of it, give this simple test a try on your side, assuming ur using Windows, and see if your max speeds return. And to be clear, my nic cards on both machines are set to their defaults and they are the same 2.5g branded cards. So it isnt an incorrect setting on my nics. I shared all my settings with their tech support but he saw nothing special that was worth changing. And both pcs are windows 11.

I also swapped both moca devices locations. Made no difference. Interestingly, you would think the slow speed in the one direction would reverse. Nope. It remained slow in the same direction. Also hinting it could be a Windows thing on my specific PC.

I also did a format/reinstall of Windows on the PC. Problem still persisted. I also tried a laptop Windows 11. Same problem.

The only thing i haven't done was get another ECB7250 to swap out to test it, which i was planning to do but lost interest :p

The tech support did give me an upgraded firmware though. So my firmware is a tad newer. I think because one of my moca devices had a newer version than the other and he was confused what my newer version was since he was never informed of a newer version. Took him days to track it down on his end and then send me the newer firmware so i could upgrade my other moca device. Obviously this did not solve my slow speed in 1 direction problem but at least my firmwares were finally the latest (at the time).

I also changed ethernet cables and coax cables and even used a 1 inch coax coupler to really reduce the length. And i also attached both moca devices directly to each other (no coax cables.)...Didn't make a difference.

Regards
 
Last edited:
FWIW, I've done more testing since my last post. Some notes:
  • It's not a Windows issue for me: there is no Windows in this house.
  • Swapping the two adapters doesn't change anything: the slow direction remains the same.
  • Replacing the ScreenBeam adapters with ASUS MA-25 adapters doesn't change anything.
  • I don't really notice any problem with 1Gbps equipment connected to the MoCA adapters. It takes 2.5G ports on both sides before it becomes apparent that the MoCA gear isn't performing at advertised speed.
  • I do see that tests involving parallel data streams perform better than single-stream tests in the slow direction. It's easy to reproduce this with iperf3 by using "-P5" or so. In my case I could get close to the theoretical 2.3G-ish limit with -P6.
  • What does change the results is swapping out the directly-connected equipment. What I've found is that a Ugreen 2.5G USB-to-Ethernet adapter is slow to receive when connected directly to the MoCA adapter, and so is a Zyxel XGS1250-12 switch. A Cisco CBS350-8MGP-2X switch is fine though, and I've also had successful full-rate-single-stream results with a late-model Intel NUC machine with a 2.5G port using an i226-V ethernet controller. I don't presently own any other gear with better-than-1G ethernet ports, so beyond this deponent sayeth not.
The conclusion seems to be that there's an ethernet-level performance incompatibility with certain equipment. I suspect that getting similar results from ScreenBeam and ASUS adapters means that they're using the same ethernet interface chips, but I'm not planning to open them up to try to prove that.
 
I noticed my TP link switches would not always negotiate 2500 and needed to be replugged multiple times. My neighbor used trendnet and it worked fine…
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!

Members online

Top