N66R wired internet bottleneck when parental controls is turned on

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

figuring_it_out

New Around Here
I have 100Mbits/sec service with a Sb6183 cable modem. Xfinity gave me a taste of 400Mbits/sec as a demo (on for 1 day before reducing it) and the modem handles it well when connected directly to the PC.
Afterwards it dropped to 130Mbits/sec (speedof.me). still very nice.

When connected through the N66R (latest stock FW, 1Gbit ethernet wired to the switch output both to the computer and modem. Cables are new 1gbit rated) and the parental controls are off. still get 130Mbit/sec. However when I turn on parental controls for about 12 wifi devices (kids smart TVs, computers and phones) my internet test results on the wired connection (not parental controlled) is reduced to 40Mbits/sec. Its very consistent with the parental controls switch in the wifi software.

I previously encountered this problem with the QoS when I tried to throttle the download speed to the kids devices and got a similar hit across the board, this made somewhat since, due to QoS being a bandwidth throttling service that no one output would be allow full bandwidth. However the combination of all of them was limited to as well. I gave up on that.

now I'm seeing the same with the parental controls. Is the processor in the N66R too slow to handle parental controls and high speed (>50Mbits/sec) internet? Would changing FW to one of the others help (tomato, DD, etc)
 

ColinTaylor

Part of the Furniture
I suspect this is indeed a limitation of the slow CPU in the N66U.

What "parental controls" specifically are you using? As an experiment remove all but one of them and and see if your speed increases at all.
 

figuring_it_out

New Around Here
These parental controls only limit the times when the internet is available to that device,

as mentioned in the original post. it follows the on/off button for parental controls 100%. off i get 130mbits/sec. on i get 40.... :(.

i was hoping a new firmware or some setting would fix this.
 

Zetto

Regular Contributor
yeah, no firmware will fix that, you need to upgrade the router, it's just too old and not designed for modern fiber network speeds lol It's more of DSL kind of router :) There's a setting that can allow high speed - NAT acceleration, but it's incompatible with anything like QOS or parental controls. It's either-or situation with n66, you either have full control or you have speed, you can't have both. Trust me, I tried everything with my n66, there's not much you can do except upgrade to a new, modern router.
 
Last edited:

Zetto

Regular Contributor
Yeah, I grabbed RT-AX55, cheap but good enough for my small apartment :) Quad-core CPU so I feel like it can handle anything I throw at it compared to the one core in n66 :)
 
Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top