Native IPv6 - no LAN IP's populating

Gary_Dexter

Senior Member
Did you reboot the router after setting it to Native IPv6 mode?

Did you fully power down the router and the ISP's equipment for a few minutes before powering everything up again?

Yes - rebooted the router.

The only "ISP Equipment" is the ONT on the wall, which isn't tied to any one particular ISP, but yes that was also powered off and on again.
There's no Modem or anything - ONT straight to the ASUS WAN via ethernet cable.
 

dave14305

Part of the Furniture
If you can install tcpdump from Entware, you might be able to capture some useful traffic that shows what the ISP is doing.
Code:
opkg update
opkg install tcpdump
nvram set ipv6_debug=1
nvram commit
tcpdump -i eth0 -n -v '( icmp6 or ( udp and port 547 ) )'
Then update the IPv6 page to force it to restart. You might lose your SSH session, but you will get some extra odhcp6c logging in syslog.

Run the tcpdump anytime to see what the ISP is advertising in its RAs. Capturing the DHCPv6 traffic on ports 546/547 might be harder.
 

ColinTaylor

Part of the Furniture
If you can install tcpdump from Entware, you might be able to capture some useful traffic that shows what the ISP is doing.
Code:
opkg update
opkg install tcpdump
nvram set ipv6_debug=1
nvram commit
tcpdump -i eth0 -n -v '( icmp6 or ( udp and port 547 ) )'
Then update the IPv6 page to force it to restart. You might lose your SSH session, but you will get some extra odhcp6c logging in syslog.

Run the tcpdump anytime to see what the ISP is advertising in its RAs. Capturing the DHCPv6 traffic on ports 546/547 might be harder.
Just a thought.... If the tcpdump command doesn't produce any useful results you might need to use ppp0 or vlan911 instead of eth0.
 

dave14305

Part of the Furniture
And maybe just as useful would be to see what the router is emitting toward the LAN devices.
Code:
tcpdump -v -n -i br0 icmp6 and 'ip6[40] = 134'
 

Gary_Dexter

Senior Member
Somewhat of an update here..

My ISP (Giganet) are still looking into this and have reports from other users using ASUS and UniFi devices that they cannot get Native IPv6 working, but the likes of TP-Link, Draytek, Microtic etc. all work fine with no issues.

They believe it may be something to do with the fact they advertise a /64 for WAN and /48 for LAN, and ASUS does not like using a /48 for LAN for some reason…

Thoughts?
 

5stringdeath

Regular Contributor
Somewhat of an update here..

My ISP (Giganet) are still looking into this and have reports from other users using ASUS and UniFi devices that they cannot get Native IPv6 working, but the likes of TP-Link, Draytek, Microtic etc. all work fine with no issues.

They believe it may be something to do with the fact they advertise a /64 for WAN and /48 for LAN, and ASUS does not like using a /48 for LAN for some reason…

Thoughts?
I read some similar threads on the Verizon/FiOS/IPV6 boards but those guys get pretty technical .... I use to have working native IPV6 for years here in MA and I haven't had it for the past few months. So something changed.
 

heysoundude

Part of the Furniture
Somewhat of an update here..

My ISP (Giganet) are still looking into this and have reports from other users using ASUS and UniFi devices that they cannot get Native IPv6 working, but the likes of TP-Link, Draytek, Microtic etc. all work fine with no issues.

They believe it may be something to do with the fact they advertise a /64 for WAN and /48 for LAN, and ASUS does not like using a /48 for LAN for some reason…

Thoughts?
it should be the other way around, a /48 for WAN and a /64 for LAN...right? a 48bit prefix for your connection to them rather than a 64bit one...
 

dave14305

Part of the Furniture
it should be the other way around, a /48 for WAN and a /64 for LAN...right? a 48bit prefix for your connection to them rather than a 64bit one...
A /48 for WAN would do you no good. My ISP (Xfinity) gives a /128 for the WAN interface and will delegate up to a /60 prefix delegation for using on the LAN side. The firmware will only assign a /64 to the br0 LAN interface from that delegation now.
 

heysoundude

Part of the Furniture
A /48 for WAN would do you no good. My ISP (Xfinity) gives a /128 for the WAN interface and will delegate up to a /60 prefix delegation for using on the LAN side. The firmware will only assign a /64 to the br0 LAN interface from that delegation now.
Gah! this makes sense...thanks for blowing cobwebs out and shining a light into a dark corner of my memory banks
 

Tvlz

Occasional Visitor
That ISP is using PPP so the setup is different than ISPs using DHCP.

It looks to me that you need to it up with "Static IPv6", set the /48 prefix as "WAN", the /64 prefix as "WAN GATEWAY" and set your own "LAN Address" from one of the subnets that you get from the /48 delegation. I would disable the "Release Prefix on Exit" too, no need for that with static ipv6.
 

Gary_Dexter

Senior Member
That ISP is using PPP so the setup is different than ISPs using DHCP.

It looks to me that you need to it up with "Static IPv6", set the /48 prefix as "WAN", the /64 prefix as "WAN GATEWAY" and set your own "LAN Address" from one of the subnets that you get from the /48 delegation. I would disable the "Release Prefix on Exit" too, no need for that with static ipv6.
That doesn’t work.

IPv6 tests fail.
 

Tvlz

Occasional Visitor
I re-read your posts and looked up some more about PPP & IPv6 setup.

It is normal for ISPs that use PPP to assign /64 for WAN and /48 for LAN,
and require you to set your own "LAN Address" from
one of the /64 subnets that you get from the /48 delegation.

Lets try this based upon what your ISP said:
"Having spoken with our network team, they advise you run IPv6
in native mode on your router in order to obtain an IPv6 address."

Connection Type: Native IPv6
DHCP-PD: Disable
Release prefix on exit: Disable
LAN Address: xxxx:xxxx:824:1::1
LAN Prefix Length: /64

If that doesn't work try

Connection Type: Static IPv6
Release prefix on exit: Disable
WAN Address: XXXX:XXXX:XXXX:822::
WAN Prefix Length: /64
LAN Address: xxxx:xxxx:824:1::1
LAN Prefix Length: /64

They don't make it easy do they?
 
Last edited:

Gary_Dexter

Senior Member
I re-read your posts and looked up some more about PPP & IPv6 setup.

It is normal for ISPs that use PPP to assign /64 for WAN and /48 for LAN,
and require you to set your own "LAN Address" from
one of the /64 subnets that you get from the /48 delegation.

Lets try this based upon what your ISP said:
"Having spoken with our network team, they advise you run IPv6
in native mode on your router in order to obtain an IPv6 address."

Connection Type: Native IPv6
DHCP-PD: Disable
Release prefix on exit: Disable
LAN Address: xxxx:xxxx:824:1::1
LAN Prefix Length: /64

If that doesn't work try

Connection Type: Static IPv6
Release prefix on exit: Disable
WAN Address: XXXX:XXXX:XXXX:822::
WAN Prefix Length: /64
LAN Address: xxxx:xxxx:824:1::1 /64
LAN Prefix Length: /64

They don't make it easy do they?
HI Tviz,

Neither of those options work either.
 

Tvlz

Occasional Visitor
I changed it a little.

Connection Type: Native IPv6
DHCP-PD: Disable
Release prefix on exit: Disable
LAN Address: xxxx:xxxx:824::
LAN Prefix Length: /48

If that doesn't work try

Connection Type: Static IPv6
Release prefix on exit: Disable
WAN Address: XXXX:XXXX:XXXX:822::
WAN Prefix Length: /64
LAN Address: xxxx:xxxx:824::
LAN Prefix Length: /48

Running out of ideas, is there any other GUI settings specific to PPP that could be changed.

You would think that somebody using your ISP would have IPv6 working. It would be nice if your ISP would just get an Asus router and figure out the needed setup.
 

Gary_Dexter

Senior Member
I changed it a little.

Connection Type: Native IPv6
DHCP-PD: Disable
Release prefix on exit: Disable
LAN Address: xxxx:xxxx:824::
LAN Prefix Length: /48

If that doesn't work try

Connection Type: Static IPv6
Release prefix on exit: Disable
WAN Address: XXXX:XXXX:XXXX:822::
WAN Prefix Length: /64
LAN Address: xxxx:xxxx:824::
LAN Prefix Length: /48

Running out of ideas, is there any other GUI settings specific to PPP that could be changed.

You would think that somebody using your ISP would have IPv6 working. It would be nice if your ISP would just get an Asus router and figure out the needed setup.
No luck with those either.

ISP has confirmed that users with ASUS and Ubiquiti/Unifi products cannot get IPv6 working. Other manufacturers are fine though.
 

small_law

Occasional Visitor
I'm very much a novice, but IPv6 was working fine on my AX88U with 386.7 (and previous versions) until a few days ago. Same thing, suddenly no LAN IP's will populate for native IPv6.

Tried troubleshooting to no avail, including disabling DNSSEC and DNS-over-TLS. No dice. Only weird thing I saw was that the "Preset servers" menu under WAN DNS Setting only populates IPv6 DNS addresses.

Called Spectrum and had them re-provision my modem (CM1100). They say it isn't on their end.

Next step is a factory reset. I'm overdue anyway; too many dirty flashes.
 

Gary_Dexter

Senior Member
Another update - my ISP managed to get it working on their test router using Stock Firmware, Native, and disabling the option Accept Default Route.

I rolled my router back to Stock and tried the above, but no luck - is this an issue known/unique to the GT-AC2900?

I do however notice these messages in the System Log, that weren't showing previously when running Merlin:

May 5 06:05:05 kernel: ^[[0;33;41m[ERROR pktrunner] runnerUcast_inet6addr_event,202: Could not rdpa_ucast_ipv6_host_address_table_find^[[0m

Jul 16 10:09:22 rc_service: ipv6-up 2907:notify_rc start_rdisc6

Jul 16 10:09:22 modprobe: module ip6t_REJECT not found in modules.dep
Jul 16 10:09:22 modprobe: module ip6t_ROUTE not found in modules.dep
Jul 16 10:09:22 modprobe: module ip6t_LOG not found in modules.dep
 

Tvlz

Occasional Visitor
Another update - my ISP managed to get it working on their test router using Stock Firmware, Native, and disabling the option Accept Default Route.
Good to here they are trying too, did they say what version of stock firmware?

One other thing I can think of is to manually start IPv6 from a ssh session, you will need to flash back to a 386.7 version of rmerlin.

From the gui set
Connection Type: Native IPv6
DHCP-PD: Enable
Accept Default Route: Disable
Release prefix on exit: Disable

Leave the rest blank after it restarts, start ssh session run ps |grep odhcp6c to get the odhcp6c settings, then killall odhcp6c to stop IPv6 and restart it with the settings you got from the above command except change the -N try with -N none that will force odhcp6c to only request a IPv6 Prefix(IA-PD).

It may not work, but I think it is worth a try.
 
Last edited:

small_law

Occasional Visitor
It was my modem. I factory reset my AX88U, added back settings manually, and still couldn't get IPv6 up and running. Today, I swapped out my CM1100 for a Moto MB8611, had Spectrum provision it, and bang, native IPv6 support was back.

No idea why Spectrum suddenly decided to block IPv6 on that particular modem model, but that's what it seems like they did.

I'll update if I lose IPv6 support again.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top