Native IPv6 - no LAN IP's populating

Gary_Dexter

Senior Member
It was my modem. I factory reset my AX88U, added back settings manually, and still couldn't get IPv6 up and running. Today, I swapped out my CM1100 for a Moto MB8611, had Spectrum provision it, and bang, native IPv6 support was back.

No idea why Spectrum suddenly decided to block IPv6 on that particular modem model, but that's what it seems like they did.

I'll update if I lose IPv6 support again.
For me, there is no modem - just an ONT on the wall
 

Gary_Dexter

Senior Member
Good to here they are trying too, did they say what version of stock firmware?

One other thing I can think of is to manually start IPv6 from a ssh session, you will need to flash back to a 386.7 version of rmerlin.

From the gui set
Connection Type: Native IPv6
DHCP-PD: Enable
Accept Default Route: Disable
Release prefix on exit: Disable

Leave the rest blank after it restarts, start ssh session run ps |grep odhcp6c to get the odhcp settings, then killall odhcp6c to stop IPv6 and restart it with the settings you got except change the -N try with -N none that will force odhcp6c to only request a IPv6 Prefix(IA-PD).

It may not work, but I think it is worth a try.
Thanks I’ll give that a try tomorrow when the house isn’t using the internet!!

Can you confirm the exact commands to run?

Where does -N try and -N none come from?
 

Gary_Dexter

Senior Member
Also no they didn’t say what version of stock they were running - but it’s on an AX86U.

This is the screenshot they provided of it working on their router:

1658004034985.png
 

small_law

Occasional Visitor
For me, there is no modem - just an ONT on the wall
Point is it was definitely the ISPs doing. Again, I'm kind of a novice, but they denied my CM1100 IPv6 access for some reason. Everything was fine until maybe two weeks ago, so whatever they changed was pretty recent.
 

Tvlz

Occasional Visitor
Point is it was definitely the ISPs doing. Again, I'm kind of a novice, but they denied my CM1100 IPv6 access for some reason. Everything was fine until maybe two weeks ago, so whatever they changed was pretty recent.
You could check dslreports.com they have a spectrum forum that may have the answer.
 

Gary_Dexter

Senior Member
When you run ps |grep odhcp6c you will get a string of configure options, when restarting odhcp6c use those options but change the -N try to -N none.

See line 2038 in the Rmerlin source code and line 605 in the odhcp6c source
That doesn't seem to work.

The line - odhcp6c -df -R -s /tmp/dhcp6c -N none -c 0003000104d4

Does not work and just brings up a list of commands/switches to use

1658013638994.png
 

dave14305

Part of the Furniture
It would be helpful to run the tcpdump in post 22 and 23 to observe what happens during the odhcp6c startup. But you need to be back on Merlin firmware. Or see what’s in the /tmp/*bound6.env file after it runs. Also add the -v parameter if you run odhcp6c manually.
 

Gary_Dexter

Senior Member
There’s a lot of answers here.
If someone can tell me exactly that I need to run, it would make things much easier.
 

ColinTaylor

Part of the Furniture
Ok so there's your missing information.

I haven't been following this thread but the last posts seem to be asking you to do the following:
Code:
killall odhcp6c
odhcp6c -df -R -s /tmp/dhcp6c -N none -c 0003000104d4c4bb3040 -P 64:b3040 -r23 -r24 -k ppp0
 

Gary_Dexter

Senior Member
Ok so there's your missing information.

I haven't been following this thread but the last posts seem to be asking you to do the following:
Code:
killall odhcp6c
odhcp6c -df -R -s /tmp/dhcp6c -N none -c 0003000104d4c4bb3040 -P 64:b3040 -r23 -r24 -k ppp0
OK done that - no change in the GUI though and still no IPv6 LAN addresses being issued.

1658075915067.png


1658075856863.png
 

Tvlz

Occasional Visitor
On the command line change "-P 64:b3040" to "-P 48:b3040" that change is what the "WAN Prefix Length" option it the gui sets.
Code:
killall odhcp6c
odhcp6c -df -R -s /tmp/dhcp6c -N none -c 0003000104d4c4bb3040 -P 48:b3040 -r23 -r24 -k ppp0
 

Gary_Dexter

Senior Member
On the command line change "-P 64:b3040" to "-P 48:b3040" that change is what the "WAN Prefix Length" option it the gui sets.
Code:
killall odhcp6c
odhcp6c -df -R -s /tmp/dhcp6c -N none -c 0003000104d4c4bb3040 -P 48:b3040 -r23 -r24 -k ppp0
But my WAN prefix provided by my ISP is a /64
 

Tvlz

Occasional Visitor
The "WAN Prefix Length" option is about requesting the number of subnets for your use on the LAN not WAN
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top