What's new

Need help on troubleshooting wireless network

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


New Around Here
ok, have not been here for awhile. My net was up and running well the couple of years since I set it up. I just upgraded to an X79 platform and my wireless is acting up again.

1.) high latency
2.) Random drop of my PC from the network
3.) Adapter disappearing after being connected, but it won't reconnect after it detected the adapter again (signal with a yellow *)
4.) Adapter constantly being detected and not detected.

In that order.

What I did after I got the new platform:
I performed a full reinstall, did all the windows update and general settings setup. Everything is working well at this point. Then I installed the drivers that came with my mobo. Drivers include, INF Drivers, Rapid Storage technology both from Intel, marvell drivers, Texas Instrument drivers (for the USB3), ME Technology (don't know what this is), Broadcom LAN drivers, Asrock stuffs (Xfast USB, Xfast LAN, instant boot, AXTU). A day after I installed the drivers (yes it did not happen at once), my wireless speed starts to drop then the symptons appeared.

After #4 happened, I could no longer use the net because I can't connect. I tried to uninstall stuffs 1 at a time starting with the Asrock stuffs, as I realized I don't need them. Still same issue, uninstalled ME technology, marvell drovers and the TI drivers (After I uninstalled the TI drivers, my other gripe with my PC, 20sec black screen after logging into windows disappeared so I thought this was the culprit). All of this and nothing. Decided to reformat and reinstall windows.

Reinstalled, but this time I only installed the INF drivers as soon as I got into windows. It was ok for a day, but now, it's starting to show symptom #1. I'm thinking it's the INF drivers this time, since everything was reinstalled from my previous PC running the same win7. But before I do another reinstall, can someone do a second look, maybe there are a few things I can still try.

Right now my gut feel is on either the INF drivers or windows update. If it's windows update, I'm not sure which update it is, I just select all windows update and install them and not installing an update does not sit well with me from a security stand point.

- Asrock X79 Extreme 9
- Intel i7 3820 (OCed to 4.6ghz stable with Intel Burn test on High)
- Corsair Vengeance low profile (4x4gb)
- WUSB600N
- Intel 330 SSD as primary boot partition
- 500gb HDD as windows storage
- another 4 HDD of variosu sizes as storage (To NAS or not is a question for another time)
- Asus Xonar Essensce STX
- Power Color 6950 PCS++
- A BD RW and a DVD RW
- Seasonic P860 for my PSU
- DF-85 for the case

Old System that was replaced
- EP35-DS4
- Q6600
- 4x2gb RAM (2x transcend and 2xCorsair XMS)

Router is WRT600N.

The rest are the same as the new except for the SSD and HDD for the SSD, those are new.

I'm quite sure that it's not signal strength since I'm on the same place as the previous system. The only thing added between the 2 is the old mobo in 1 of the cabinets before my room. It's not my net either since my brother is able to play with low latency directly connected to the router and I can use it before symptoms happen. It's not a specific day or time problem so I don't think it's the neighbors (although it will be very hard to ensure this since I live in an apartment complex)

Do you think going PCIe will help? There is only 1 card I can buy DWA-525, old version I think and looks like a downgrade compared to my WUSB600N, but if this will alleviate my problem, I have a spare PCIe port to put it into. The only repeater I can buy is the RE1000 which your review says is bad. So repeater+RJ45 is out too. I have my old WRT54G v7 somewhere I can change into a repeater if that will help.

Any help with my problem is appreciated.
Are you using a usb extension cable for your WUSB600N? I'm pretty sure they came with one, so you must be.. stop using the supplied cables! The cables lack a very important feature to regulate voltage and mitigate interference called a ferrite choke. Are you using the latest driver? Are you using 40MHz mode on the router?
Opinion: USB extension cables.. I have some that have small-gauge wire others with larger gauge. The small gauge wire cables have more "I*R" (Ohm's law) voltage drop for moderate/high current USB devices. Generally, the less flexible cables have larger gauge (less drop). Indeed, some cables I have will NOT power a 2.5 in. disk in an enclosure. Won't spin-up. I just change cable and it's OK. I mark those cheapie cables thusly.

The ferrite core filters in some cables are there to meet FCC regulations for radiated emissions. There's a good chance that USB works better without them as they may tend to act as a low pass filter.

An alternative to USB WiFi is a WiFi to Ethernet bridge, a.k.a. game adapter. Either the USB dongle or the bridge are better choices than a PCI/PCIe WiFi card due to antenna placement and coax length.
Irregardless of your opinion, everyone is entitled to their own, companies keep supplying cables with USB wireless and other such powered devices that are completely worthless for their intended application.

On the ferrite core theory, are you speaking from experience or...

All of my powered usb devices(none are hard drives and besides, you should be using cables designed for a hard drive, not any-ol-cable) now work after upgrading their supplied cables with a ferrite core.

A ferrite core would be a solution for the existing usb cable supplied by the usb wifi vender, but a shielded usb cable would be a replacement(likely more expensive).
Last edited:
On the ferrite core theory, are you speaking from experience or....
These ferrites were added to cables long ago after the FCC passed the regulations on radiated and conducted emissions- these being elements of the Regulations called Part 15. These regulations came about because too many products were interfering excessively with TV/Radio, etc. There are two levels of compliance: one for consumer/residential and another for commercial/industrial settings. The latter is less stringent.

Other countries have similar regulations imposed by their FCC-equivalents.

The filing of test reports on compliance are a happy byproduct as we technophiles can read these public documents and get a good hint as to what the next-generation products are to be, esp. in WiFi.
Are there any other ethernet adapter other than the asus EA-N66? I checked the stores and they do not have that model. I bought another usb adapter(tp link TL-WN727N) its a cheap adapter just to test. but no go. it still has the same problem. so its not the adapter. looks like its the usb stack or my mobo.

I tried another reformat and no windows update this time and its good for a night of d3 then it went back to the problem. Im currently uninstalling stuffa 1 at a time. Im down to just d3 and amd drivers but still nothing.

I dont think its the mobo since it worked for a day after fresh install.

I also tried removing it from the cable dock and plugged it directly to the usb port and still no go.

just to add, it should not be signal strength since im typing this reply on my sgn note connected to my home router and Im beside my usb adapter.
cable dock....told ya

Did you update the wireless drivers and stop using the cable dock? Try the Ralink drivers, I don't trust Linksys that much, use the top link RT3572 http://www.ralinktech.com/en/04_support/support.php?sn=500. STOP USING THE CABLE DOCK!!!! and throw it away or try a ferrite choke.

You never answered my question about the 40MHz mode(aka 300Mbps) setting on the router, with 2.4GHz you need to use 20MHz only for stability, but you can use 5GHz @ 40MHz, less range though. STOP USING 2.4GHz @ 40MHz MODE!!!!

My wireless would have problems because of a failing power supply, might look at that.
Last edited:
i cant check at the moment. i made some mistake and the router would not allow me to access it. but last i remember its 2.4ghz 20mhz(mix mode) and 5ghz 40mhz (N only).

Ill try the drivers you linked. Im using whatever ms installs for now since the latest linksys driver does not work. Edit: I checked the site, and isn't that supposed to be for RALINK products? Anyway, should not be a problem, I don't have much stake right now since this is a fresh install, and I did google for alternative drivers and I found the same driver on a separate site...

btw, removing it from the cable dock does nothing. but ill keep it removed so i have less failure points until i have it up and running.

My power supply is a brand new Seasonic P860, so it should not be that.

Edit: I tried another reinstall of windows and this time, did not keep the Adapter plugged in the USB port and have windows detect it from the start. This time my USB does not want to work after it got installed after plugging. But I'm able to use my Galaxy Note connected to my wifi to tether my PC on the same USB slot the USB Adapter failed to connect on go figure...

sigh. I have this much headache setting up my first wireless 6years ago, thought it was just a bumpy setup for new networks, but a platform change where the whole network is intact? -_- Do I expect this much trouble when I switch to haswell or any other platform after?

Ah well, will try this driver as soon as it finishes downloading first. If it does not work, I might just keep my USB tethering until I can get enough money to buy a different form of wireless adapter or I might just lay down 50ft worth of RJ45 cable and call it a day -_-

Anyone has some experience with the Asus built in wifi on the mobo (P9X79 Deluxe)? If they are less trouble, I can just save up and swap mobos...

Edit2: The RALINK drivers did not work for both the WUSB600N and the TL-WN727N. Ah well it's USB tethering for me for the forseeable future. Tired of reinstalling and debugging specially when I already have only the MAD drivers installed at still won't work.

Any other suggestions welcomed. I would prefer to use a dedicated adapter than use my phone.
Last edited:
My power supply is a brand new Seasonic P860, so it should not be that.

The power cube on the router, not the PC - RF dropouts are a good sign that the power cube is going soft...
The power cube on the router, not the PC - RF dropouts are a good sign that the power cube is going soft...

Then it should not be that either since my phone wss able to connect to it and even tether to my pc. The laptop my brother uses can also connect to the wifi without problens. He also games on the wifi so there should be no dropouts.

Ahwell. I forgot I also updated the bios on my mobo and just noticed it has updates to the usb. I tried to downgrade but the problem persists.
Then it should not be that either since my phone wss able to connect to it and even tether to my pc. The laptop my brother uses can also connect to the wifi without problens. He also games on the wifi so there should be no dropouts.

Ahwell. I forgot I also updated the bios on my mobo and just noticed it has updates to the usb. I tried to downgrade but the problem persists.

Trust me, your router is old enough that the power cube/wall wart is likely getting soft... handhelds don't push the radio much at all, but laptops and desktops push things much harder...

It's a 75 cent part at the HW level... better to spend a couple of bucks on a new PS cube... they'll stay steady at the voltage, but they start getting weak on current (AMPS)... you don't know how many folks I've helped out on this very issue, and saved them some money... (new router, new PS, problem solved at first glance, really it was the cube, not the router)
Got it working now.

Not sure where I can find a power cube compatible with my router for future references. But I got it working now. What I mean by my phone was not I was browsing using the phone, I was tethering the phone to the PC so I think the stress level should be the same since I'm using the PC normally. But I'll check the cube next time my wifi goes out, without any other huge changes.

Anyway, I got it working now. It's basically the motherboard. When I returned it, I asked for an exchange and got an Asus P9X79 Deluxe (it's almost the same price and it has wifi. Figured if asus is half as good as I read them to be, they should have tested their wifi built into the mobo and I can't downgrade anyway since they won't refund the excess). It worked as soon as I got the PC up and is working ok since yesterday.

Kinda disappointed with how manufacturers can fail on implementing standards.

Had a bit of trouble with D3 on latency, at first with the built in wifi, tried my WUSB600N and place it atop my monitor with the extension cable and latency was down to normal after.

Not sure what's between me and the adapter. I had the adapter on level with my lap facing a door and walls on other ends with a desk fan blowing through it to me. No desk fan and no me on top of the monitor. Router is 2 walls away and the door is perpendicular to the router.

Thanks for the help all. Clicked the thanks for each of you =)

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!