Netgear DGN2200v4 Airplay/Wifi woes

mincedsalad

New Around Here
Hi,

I'm hoping someone smart might be able to shed light on this problem. My Netgear DGN2200v4 has major problems with Airplay, ONLY when the iphone/ipad/ Macbook is sending the audio on the DGN2200v4 wifi (it will work fine on the two other Wifi access points on the same LAN, even with the sound passing through the DGN2200's ethernet).

The setup:

Netgear DGN2200 as main router (with DHCP, NAT, and connected to Cisco cable modem for internet). Wired ethernet connections go from DGN2220 to a TP-Link switch and on to two other routers being used only as wireless access points - a Netcomm NF5 and and D-Link.

The airplay devices - one is a Yamaha RX-V573 Receiver, wired directly to the main DGN2200v4 router. The other is a jailbroken ipod touch on Wifi to the Netcomm access point.

The problem:
- Airplay will often not even start. Phone will start counting seconds on the song, then stop, with no audio emerging. Mac will try to connect, and fail to do so (WMM on or off)
- Or it will start playing, with stutters, and receiver not knowing the name of the song, before failing after something like 20 seconds (with WMM on)
- Airplay icon will always show on my idevices, unless I turn on wireless isolation on the DGN2200.

Things I have already tried:

-I have updated firmware on the Receiver, the DGN2200, the other routers, and tried resetting and restarting all of them, AND all my idevices.
-Turning QoS on and off on the DGN2200
-Turning WMM on and off on the DGN2200 (when on, it works intermittently, and it doesn't seem to work at all when off).
-Checking for wifi congestion - There are no other AP's anywhere near channel 8 on which the DGN2200 is set - we are not in a congested area. Problem occurs even with only one device on that Wifi.
- Changing the wifi speed mode from 300 down to 150 and 54
- Changing the region from Australia to Europe (I'm in New Zealand)
- Changing the Wifi fragmentation length to 2304 and CTS/RTS Threshold to 2307 as recommended in another forum I found (I've since changed them back to default)
- Trying Wifi long/short preamble.
- Unchecking the WPS settings
- Turning uPNP on and off

Nothing has worked so far, except turning WMM off makes things worse. Airplay works really, really well over wifi on the other Netcomm NF5 and D-Link access points, to either the receiver or the jailbroken ipod, but has never worked reliably over Wifi on the DGN2200 since I installed this router. (Again, it works fine if say I connect the laptop via ethernet to the DGN2200 or WiFi to the other AP's).

I'm sure Apple's protocols are not without their flaws, but that doesn't stop it working perfectly fine with two other WiFi access points, one newer and one older.

Any help is much appreciated.
 

mincedsalad

New Around Here
Bump! Any help or top tips on this would be appreciated.
I know the router isn't a brand new one but it was fairly expensive when we purchased it in 2013!
 

sfx2000

Part of the Furniture
Hmm... Airplay is fairly dependent on multicast support, so check and see if your router has a switch in the UI to filter - if so, change it from current state (if off, then turn on, if on, turn off)...

There's also issues with Apple's Bonjour on certain builds - Mac OS X 10.10 and iOS8 were very problematic with the mDSN daemon - discoveryd vs. mDNSResponder, this is since resolved on IOS9 and Mac OS X 10.10.4 and later (including El Cap, which includes the fixes).

AirPlay/AirPrint with discoveryd can get very confused, and best thing actually is to turn off/shutdown everything, and then bring them back up - end points first, and then finally the Mac..

HTH...
 

mincedsalad

New Around Here
Hi sfx2000 and thanks for your reply!

I did some digging on multicast - the DGN2200v4 manual
http://www.downloads.netgear.com/files/GDC/DGN2200V4/DGN2200v4_UM_26Mar13.pdf
only mentions the word once in relation to disabling/enabling IGMP proxying on the LAN. Toggling this setting doesn't seem to change anything unfortunately, and it does seem to be for internet traffic rather than local.

Some of the above settings I've already tried may be related to multicast too? (QoS, WMM). One of the keys here may be that that Airplay only fails on the Netgear wifi, not Netgear ethernet nor any other wifi access point where it works really well.

The Mac is on the latest El Capitan 10.11.3 and iOS devices are on the latest iOS 9 so hopefully that is a good thing!

I have tried the shutdown method you suggested before, but perhaps with the wrong settings it makes no difference (or perhaps Airplay will just never work on the DGN2200v4 wifi!).
 

Trikein

Guest
The setup:

Netgear DGN2200 as main router (with DHCP, NAT, and connected to Cisco cable modem for internet).
Why are you using a DSL gateway as a router with cable modem? I think a lot of your problems would be fixed if you got a stand alone router instead of using a DSL gateway for something it really wasn't designed to do. Considering your audio receiver is 500$ it might help to upgrade the 25-40$ router. Not sure what your price point is but even 100-150$ could buy you some very nice hardware.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top