1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Netgear X4s with Voxel FW: How to set DNS for the DHCP server?

Discussion in 'NETGEAR AC Wireless' started by Afterlife, Oct 10, 2019.

  1. Afterlife

    Afterlife Occasional Visitor

    Joined:
    Mar 28, 2019
    Messages:
    21
    I have a Netgear X4S router with Voxels v.1.0.2.70SF installed. I recently got AT&T gigabit fiber internet so I upgraded my home network. I will try my best to explain my setup : I have the AT&T internet plugged into my WAN port on my Netgear X4s with Voxels latest FW (Wifi is disabled on my X4S). From the LAN port on my X4S a CAT7 cable goes to a Netgear 16 port POE switch. There are 5 TP-Link EAP245 APs , one TP-Link Omada cloud controller and one Raspberry Pi with Pihole installed connected to the Netgear POE switch. Everything is running flawlessly.

    Now my issue is that when I try to set the DNS server on my X4s under Advanced -> internet settings to the Pihole IP address my internet stops working. To over come this I have to set the DNS server(pi hole IP) manually on all my devices which is like 40+ devices. Is there anyway to set the DNS for the DHCP server rather than configuring it under Internet settings? I know my old asus router has this option and I believe the ubiquitti edge routers have this option too.
     
  2. Bill K

    Bill K New Around Here

    Joined:
    May 27, 2018
    Messages:
    2
    Turn off dhcp on the x4s and use the Pihole dhcp server.


    Sent from my iPhone using Tapatalk
     
    Voxel likes this.
  3. Afterlife

    Afterlife Occasional Visitor

    Joined:
    Mar 28, 2019
    Messages:
    21
    Looks like my Raspberry Pi 3 is a bottle neck, I do have Pihole, Kodi and a few other things running on it and when I enable the Pihole DHCP server my CPU usage spikes to 88%-100% and some of my devices do not get IP addresses assigned to them. If there is no other way to assign a DNS server for the DHCP server on my X4S I will just go ahead and buy the Edge Router 4.