New Asus RT-AX88U Slow Upload speeds on Wifi only

  • SNBForums will be unavailable for about 2 hours TOMORROW 23 January starting around 2PM EDT for a server changeover.

    All accounts and posts will be preserved.
  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

vii

Occasional Visitor
Hi everyone, first post. I just picked up this router and flashed it with merlins wrt 384.17. I reset the router afterwards to factory settings and checked the initialize box to get the cleanest wipe, and set it up. Problem i'm having is i'm seeing less than 1/2 of my upstream bandwidth during speed tests on my iphone 11 pro. Prior router I was using and had was the AC68U which would regularly see speeds of 420/425, 471/459, 355/439 (down/up). Now i'm getting 695/213, 647/213, and 684/224 during three tests I did right after switching them out.

I set up the AX88U from scratch, did not restore any settings at all, used different ssid names as well. The issue isn't unique to the iphone 11 pro, but seems unique to wireless connectivity. 2 different ipads, and another iphone xr all have less than half of their upstream speeds prior. My PC, hardwired with cat7 is seeing full bandwidth of my verizon fios, 885/940. so i know it's not an ISP limit.

I ran some iperf3 tests as well which showed about 500-550 for both up and down speeds from the iphone 11 pro, so I know the device can achieve those speeds wirelessly, though it still seems slow for being 6 inches from the router for a wifi 6 enabled device. But how is it i can't see that upload when testing from multiple site locations on speedtest.net. Connect the old router up, even as an access point, i'll get my 400/400 (ballpark) but connected wirelessly to the AX88U, speeds cut in half.

Other things i've checked are in the wireless logs area, while speed testing I can verify the iphone 11 pro is connected to (ax), that it's connected to 2 streams at 80Mhz, that the Rx/Tx & RSSI are 1200 / 1200 Mbps at -56 dBm during the speed test, and this is with the following 5ghz settings:



Let me know if there's anything else I can try to get this working better. Thank you guys!
 

indark

Senior Member
few things i will play around are
1. try to disable wifi6, and see what speed you get w/o it
2. enable wifi 6 but disable 160Mhz, and see what you get
3. w/ wifi6 on, manually select control channel, go thru them and see which one give you the best result (let your iPhone connect to 160Mhz and give you best performance, assuming iPhone is actually capable of 160Mhz)

then you can compare each result and see which works better for you

a side note, I dont know if wpa2/wpa3 has impact on performance, but it might be something worth tinkering with as well.
 

vii

Occasional Visitor
wifi 6 disabled/ 160mhz disabled/ auto select channels inc DFS disabled
speed test: 551/209 Mbps - (ac) 2 streams, 80mhz -47dBm rx/tx 866/866 Mpbs

wifi 6 enabled/ 160mhz disabled/ auto select channels inc DFS disabled
speed test: 678/219 Mbps - (ax) 2 streams, 80mhz, -51 dBm rx/tx 1200/1200 Mpbs

wifi 6 enabled/ 160mhz enabled/ auto select channels inc DFS disabled
speed test: 679/195 Mbps - (ax) 2 streams, 80mhz, -48 dBm rx/tx 1200/1200 Mpbs

wifi 6 enabled/ 160mhz enabled/ auto select channels inc DFS enabled
speed test: 663/202 Mbps - (ax) 2 streams, 80mhz, -49 dBm rx/tx 1200/1200 Mpbs

All tests were done with authentication back to WPA2 Personal only, protected frames disabled, and wi-fi agile multiband disabled. all were done to the same speedtest.net node for consistency, and from the same distance to the router, about 6 feet. router is in clear view, elevated on a desk the same distance off the ground as where i'm sitting with the phone on the desk, no interference from environment. a wifi site survey scan places the channels 36 and 48 as least congested and while 160mhz is enabled the router selects to be at that band. the phone wouldn't connect with 160mhz at all though. I wonder if the radio doesn't support 160mhz in the iphone 11 pro. but in any regard I should still be seeing over 400 Mpbs at this range while in wifi 6 to the router no? so strange that the ac68u does it no problem

I can't seem to break 250 Mbps upload speeds on any wi-fi device. Tried iphone 11 pro (ax), ipad pro 3rd gen (ax), iphone xr (ac), ipad 7th gen (ac), intel wireless ac 9560 network adapter on a 2nd pc (ac), ibm thinkpad laptop (ac), apple tv (ac). only times i've had over 400 Mbits upload are with my 6 year old ac68U on the same version of MerlinWrt, and wired ethernet. which are about 450 and 950 Mbps respectively.

Edit 5/15/2020 00:55 - I reconnected the AC68U in AP mode to the AX88U and noticed the same thing. However, stand alone in router mode the AC68U connects the wireless devices at over 400 upload when speed testing, while using 802.11ac, at a rx/tx link speed of 866/866 Mpbs.

What are some upload speeds other AX88U owners are seeing, provided your ISP bandwidth is over 300. I'm wondering if it's just me.
 
Last edited:

indark

Senior Member
that seems odd, I have 200/200 Verizon, but the actual speed I am getting is 300/300.
speed test with desktop connected with ethernet.
upload_2020-5-15_2-13-3.png upload_2020-5-15_2-15-59.png upload_2020-5-15_2-16-27.png

I test both wifi product (sorry, non-apple product for me) available to me on dslreport, fast.com, also speedtest.net

laptop with intel ax200 card: (wifi 6)
-48dBm, ax 2 stream, 160mhz, 2268.5M/2401.9M
tested on my laptop with intel wifi 6 card, I am getting 300/300 ish regardless of the wifi setting.

Pixel 3: (wifi 5)
-59dBm, ac 2 stream, 80mhz, 866.7M/866.7M
on my pixel 3, only test with wifi6 enabled, 160Mhz enabled and auto channel (40 was selected automatically)
also getting 300/300 ish w/ speedtest.net app.

I assume you do not have any sort of QoS on, but does not hurt to double-check.
 
Last edited:

vii

Occasional Visitor
Yeah, made sure QoS was off. Haven't added those settings and factory defaults don't include them on at all either. But I did triple check that. You're not using merlin on your main router I noticed? AsusWRT? Maybe I can try that, but i'm sure someone using AX88U and the same merlin build isn't seeing the same issue. Would be way more posts about it otherwise.
 

FTC

Senior Member
Hi, make sure airtime fairness is DISABLED in the professional tab. This one has been reported in the past as reducing the throughput. Disable also universal beanforming since it is also known as a potential for problems.
 

vii

Occasional Visitor
Hi, make sure airtime fairness is DISABLED in the professional tab. This one has been reported in the past as reducing the throughput. Disable also universal beanforming since it is also known as a potential for problems.
thank you FTC, looks like Merlin disables "Airtime Fairness" by default and I confirmed it off. I turned off universal beamforming though, though the speed tests remain the same.
 

indark

Senior Member
Yeah, made sure QoS was off. Haven't added those settings and factory defaults don't include them on at all either. But I did triple check that. You're not using merlin on your main router I noticed? AsusWRT? Maybe I can try that, but i'm sure someone using AX88U and the same merlin build isn't seeing the same issue. Would be way more posts about it otherwise.
shouldn't have any difference, I just did a quick dirty flash to merlin and a quick test with my pixel 3 while it's charging wirelessly.
307 / 290 @ speedtest.net, with merlin @ 384.17

laptop with ax200 is 300/300ish as well.

However, I normally will power cycle and use the WPS method to fully reset the router though, especially after swap between Asuswrt and Asuswrt-Merlin or when I encounter any weird issue.

here are the steps that I normally do if you wanna try:
power off the router for 30 sec,
hold the WPS button while booting up the router till the power led turn off
now power off the router again, for another 10-15 sec.
boot up the router, and reconfigure everything manually.
normally I will just go with minimal configure to test what I wanna test.
 

FTC

Senior Member
thank you FTC, looks like Merlin disables "Airtime Fairness" by default and I confirmed it off. I turned off universal beamforming though, though the speed tests remain the same.
Well at least you can eliminate the airtime fairness thing.. other than that, have you tried different channels ? just in case there are interferences at the one you are using.. I'd fix the channel anyways and not set control channel to 'auto'. And for last make sure the antennas are well screwed and making good contact..
 

vii

Occasional Visitor
Channel spectrum is something I admit I know little about. Save knowing not to use a saturated channel. I can scan my location again using a site survey app and find a channel that isn't in use, however should I land a fixed channel on a DFS channel? Or use the something in the UNII-1/2 area of the 5ghz? Should I also fix my 2.4ghz as well or leave that auto? There's only 1 of 16 clients using 2.4ghz though.

Also, @indark I noticed you posted yesterday about new firmware Asus released for the AX88U, does this mean Merlin is going to release something new for this soon? Should I try this and see if something is changed? How different are stock firmware to merlins? I've only ever used merlin with asus routers, it's why I bought my first asus hehe.
 

indark

Senior Member
Also, @indark I noticed you posted yesterday about new firmware Asus released for the AX88U, does this mean Merlin is going to release something new for this soon? Should I try this and see if something is changed? How different are stock firmware to merlins? I've only ever used merlin with asus routers, it's why I bought my first asus hehe.
it depends on how fast Asus provide the source code to merlin, and the time available to merlin.
normally won't be too far off from each other, and merlin is normally better.
I swap between both the official and merlin here and there. I just become lazy lately and just stick to whatever I was using at the time.
anything closed source should be the same, but merlin provides additional features, security updates, and sometimes fixes.
i.e. the wifi driver should be the same unless Asus updated recently, but merlin will let us know for such changes.

right now I only notice some differences in the closed source part between official firmware and merlin
QoS category, that's a close source, but then ... I just turn off QoS as I no longer need it with 300/300
Game page, just a flashy and easy configure page for QoS and port opening. It's a gimmick to me, but it might be useful for some people.
 
Last edited:

New2This

Regular Contributor
Just try putting the 5Ghz channel on 40, and see what you get, with just WPA2
 

vii

Occasional Visitor
Looks like the router auto selected channel 40/ 160mhz

iPhone speed tested at 620/212 Mbps
1200/1200 link speed with router at 80Mhz
connected using ax

Would turning off auto-and manually selecting 40 give a different result, or should this serve the purpose of the test since it had it auto selected to 40 already?

I set wireless mode to just N/AC/AX mixed and cut out legacy since really only AC or newer devices connect to my 5ghz.

Edit 12:52pm: I've come to terms with having around 200 Mpbs on upstream, which is still mighty fast for mobile devices, my hardwired devices still hit the Gbit upstream which is what's important. Just wanted to make sure there are no hardware issues with this guy since it was near $400 and still in the return window. I have a feeling it will be improved as firmware releases mature. But if many here who use 300/300Mbit or faster connections are seeing much higher upload speeds than I, it just leaves me a little concerned.

I appreciate all the help so fast with troubleshooting, thank you guys. Anything else I could try?
 

Attachments

Last edited:

L&LD

Part of the Furniture
Disable Auto Control Channel. Use either 80 or 160MHz bandwidth. Disable Capable for the Protected Management Frames. (For starters). :)
 

vii

Occasional Visitor
@L&LD hi, thanks for reaching out. would manually setting a channel bandwidth of 160mhz prevent devices incapable of that band to connect to the 5ghz? Also the 'capable' for protected management frames is tied to wi-fi agile multiband option being enabled. is it okay to disable this as well?
 

FTC

Senior Member
@L&LD hi, thanks for reaching out. would manually setting a channel bandwidth of 160mhz prevent devices incapable of that band to connect to the 5ghz? Also the 'capable' for protected management frames is tied to wi-fi agile multiband option being enabled. is it okay to disable this as well?
I would add.. Once you diseble auto setting, experiment with different channels. If channel 40 gives you the problem and there is interference at that frequency, other channels may give better results.
 

L&LD

Part of the Furniture
Yes, disable both ('capable' and 'agile' options. :)

In my experience, I could see an ancient laptop connect to a 160MHz wide channel with no issues (with WiFi 'G' maximum rates) at 54Mbps.

YMMV. :)

As @FTC points out, test each Control Channel possible for best performance with your devices and your WiFi environment too (on the 2.4GHz band, only use 1, 6, or 11). :)
 

vii

Occasional Visitor
Here's a quick channel survey after scanning a couple of minutes. Looks like 11 would be best 2.4ghz channel, and I supposed I could try 36 and 40. I was on 40 at the time of this test, so those 2 are very low usage for 5ghz. I live in an apartment building in New York City, but for purposes of testing I'm about 6 feet, in clear view of the router (elevated).

@L&LD should I also set my 2.4ghz to manual channel/band? in this case, channel 11, with 40hz?

Edit 13:24: same results in speed tests with aforementioned options enabled on 40, I'll try 36
Edit 13:33: same results on channel 36 too, the 2 least used channels
 

Attachments

Last edited:

L&LD

Part of the Furniture
40MHz bandwidth on 2.4GHz in an apartment building in NY? N0. :D

Test each (1, 6, or 11) fully, regardless of what any spy app says. :)

It doesn't matter what the handheld device's app sees, it only matters what the router sees. Use it's scanner (if you must). :)

It also doesn't' matter how many devices are on a particular channel (in itself). What matters is which is the least utilized. And, most easily seen too. Your WiFi router doesn't just 'talk' with your devices, it has to co-ordinate its broadcasts with all neighboring routers too.

Test each control channel for an extended period for the least latency and throughput being the secondary consideration. That will give you a more satisfying network experience. :)
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top