What's new

New Router DHCP Troubles

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

Soulless Daedra

New Around Here
Recently I had purchased an asus
RT-AC51U Router to upgrade from my current Sky Hub 2 router/modem. It was all going great for a while, my set up was to plug in a cat 7 RJ 45 from a LAN port of the Sky Hub into the Asus Routers WAN port, as not to break the TAC of Sky.

Also giving the Asus router a reserved IP and making it the DMZ server and opening the ports 67 and 68. All in the Sky Hub.

The 5G does not work well at all though but this is not my issue.

My issue stemmed quite recently, the log of the Asus router has started to flood with this error:
_rules: apply the nat_rules(/tmp/nat_rules_vlan2_vlan2)!
Feb 8 22:04:40 WAN Connection: ISP's DHCP did not function properly.
Feb 8 22:04:40 stop_nat_rules: apply the redirect_rules!
Feb 8 22:04:46 WAN Connection: WAN was restored.
Feb 8 22:04:46 start_nat_rules: apply the nat_rules(/tmp/nat_rules_vlan2_vlan2)!
Feb 8 22:08:38 WAN Connection: ISP's DHCP did not function properly.
Feb 8 22:08:38 stop_nat_rules: apply the redirect_rules!
Feb 8 22:08:42 WAN Connection: WAN was restored.
Feb 8 22:08:42 start_nat_rules: apply the nat_rules(/tmp/nat_rules_vlan2_vlan2)!
Feb 8 22:08:59 kernel: rt2860v2:ASSOC - Assign AID=9 to STA dc:41:5f:39:64:50
Feb 8 22:09:43 WAN Connection: ISP's DHCP did not function properly.
Feb 8 22:09:43 stop_nat_rules: apply the redirect_rules!
Feb 8 22:09:46 WAN Connection: WAN was restored.
Feb 8 22:09:46 start_nat_rules: apply the nat_rules(/tmp/nat_rules_vlan2_vlan2)!

I have tried restarting the modem and the router with no luck! Please could someone attempt to help me if you can. Thank you :)
 
Last edited:
Recently I had purchased an asus
RT-AC51U Router to upgrade from my current Sky Hub 2 router/modem. It was all going great for a while, my set up was to plug in a cat 7 RJ 45 from a LAN port of the Sky Hub into the Asus Routers WAN port, as not to break the TAC of Sky.

Also giving the Asus router a reserved IP and making it the DMZ server and opening the ports 67 and 68. All in the Sky Hub.

The 5G does not work well at all though but this is not my issue.

My issue stemmed quite recently, the log of the Asus router has started to flood with this error:
_rules: apply the nat_rules(/tmp/nat_rules_vlan2_vlan2)!
Feb 8 22:04:40 WAN Connection: ISP's DHCP did not function properly.
Feb 8 22:04:40 stop_nat_rules: apply the redirect_rules!
Feb 8 22:04:46 WAN Connection: WAN was restored.
Feb 8 22:04:46 start_nat_rules: apply the nat_rules(/tmp/nat_rules_vlan2_vlan2)!
Feb 8 22:08:38 WAN Connection: ISP's DHCP did not function properly.
Feb 8 22:08:38 stop_nat_rules: apply the redirect_rules!
Feb 8 22:08:42 WAN Connection: WAN was restored.
Feb 8 22:08:42 start_nat_rules: apply the nat_rules(/tmp/nat_rules_vlan2_vlan2)!
Feb 8 22:08:59 kernel: rt2860v2:ASSOC - Assign AID=9 to STA dc:41:5f:39:64:50
Feb 8 22:09:43 WAN Connection: ISP's DHCP did not function properly.
Feb 8 22:09:43 stop_nat_rules: apply the redirect_rules!
Feb 8 22:09:46 WAN Connection: WAN was restored.
Feb 8 22:09:46 start_nat_rules: apply the nat_rules(/tmp/nat_rules_vlan2_vlan2)!

I have tried restarting the modem and the router with no luck! Please could someone attempt to help me if you can. Thank you :)

You are in a double NAT situation. The DHCP range on the ASUS needs to be in a different subnet than the Sky.

Either that or put the SKY into a bridged mode.
 
You are in a double NAT situation. The DHCP range on the ASUS needs to be in a different subnet than the Sky.

Either that or put the SKY into a bridged mode.

Sadly there is no option on the Sky hub to put it into bridge mode, I disabled its wifi capabilities but that is all I can do there, what do I change the DHCP to?
 
Sadly there is no option on the Sky hub to put it into bridge mode, I disabled its wifi capabilities but that is all I can do there, what do I change the DHCP to?

On the ASUS I would put the WAN into automatic so it will pull an IP from the SKY.

I would then set the the LAN IP of the ASUS to something such as 192.168.220.1 and the DHCP server range to 192.168.220.100 - 192.168.220.150. Many options on what subnets you could use but my guess is if you use the numbers I am suggesting it is 99.99% certain that they will work.
 
On the ASUS I would put the WAN into automatic so it will pull an IP from the SKY.

I would then set the the LAN IP of the ASUS to something such as 192.168.220.1 and the DHCP server range to 192.168.220.100 - 192.168.220.150. Many options on what subnets you could use but my guess is if you use the numbers I am suggesting it is 99.99% certain that they will work.

My current setup only has the Sky Hub handing out one IP which is to the router so the routers static IP is 192.168.1.2 then I have that router assigning all the other IPs however both the Sky Hub and the Asus router have 255.255.255.0 as there Subnet mask I do not know if this is a problem. However, does my current setup resemble what you suggested? Thank you for reply by the way ^_^
 
My current setup only has the Sky Hub handing out one IP which is to the router so the routers static IP is 192.168.1.2
As CaptainSTX pointed out, this WAN address is in conflict with your LAN addresses (assuming you are using the defaults).

You need to go to LAN > LAN IP and change the IP Address to something different than 192.168.1.1. CaptainSTX suggested 192.168.220.1. When you apply the change you will loose connectivity to the router as it reboots.

I suggest you close and reopen your browser and log back in using the new IP address 192.168.220.1. Go to LAN > DHCP Server and confirm that the router is now giving out addresses in the 192.168.220.x range. You will need to power off/on any other clients to pick up the changes.

Hopefully that will solve your problem.
 
As CaptainSTX pointed out, this WAN address is in conflict with your LAN addresses (assuming you are using the defaults).

You need to go to LAN > LAN IP and change the IP Address to something different than 192.168.1.1. CaptainSTX suggested 192.168.220.1. When you apply the change you will loose connectivity to the router as it reboots.

I suggest you close and reopen your browser and log back in using the new IP address 192.168.220.1. Go to LAN > DHCP Server and confirm that the router is now giving out addresses in the 192.168.220.x range. You will need to power off/on any other clients to pick up the changes.

Hopefully that will solve your problem.

Right I have applied your suggestions, however, before I had the WAN address on 0.1 and the Lan on 1.2 so they were not conflicting as far as I am aware, we shall see what happens now though.
 
Right I have applied your suggestions, however, before I had the WAN address on 0.1 and the Lan on 1.2 so they were not conflicting as far as I am aware, we shall see what happens now though.
OK, I may have misunderstood your post. It sounded like you have given the Asus' WAN port a reserved IP address of 192.168.1.2 while the Asus' LAN range was 192.168.1.x, which is a conflict.

Either way I have just re-read your original post and spotted something else. You say you are "opening the ports 67 and 68" on the Sky hub. If by that you mean you are forwarding those ports from the Sky to the Asus, don't. That could very well be why the Asus is complaining about DHCP.
 
OK, I may have misunderstood your post. It sounded like you have given the Asus' WAN port a reserved IP address of 192.168.1.2 while the Asus' LAN range was 192.168.1.x, which is a conflict.

Either way I have just re-read your original post and spotted something else. You say you are "opening the ports 67 and 68" on the Sky hub. If by that you mean you are forwarding those ports from the Sky to the Asus, don't. That could very well be why the Asus is complaining about DHCP.
I have closed the ports and it has made no difference I still get the error occasionally, however now another error has popped up. It says "a network cable is unplugged" on the status page, however the internet still works. And again the same ISP error. Why won't these errors go away D;
 
It says "a network cable is unplugged" on the status page, however the internet still works. And again the same ISP error. Why won't these errors go away D;
Can you check that your RJ45 cable (from the Sky hub) is plugged into the Asus' WAN port and that you haven't put it in the Asus' LAN port by mistake.
 

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top