1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

New TM-AC1900 no wi-fi signal

Discussion in 'ASUS Wireless' started by cowsarecool5, Sep 14, 2018.

  1. cowsarecool5

    cowsarecool5 New Around Here

    Joined:
    Sep 14, 2018
    Messages:
    2
    After missing one of T-mobile's sales of the pre-owned TM-AC1900s I found one on Amazon for $60 listed as new. I was a little skeptical about the price but I thought maybe it was a refurb or something and I'd be happy to have one in any working condition. That was apparently too much to ask.

    The web interface is speedy and responsive and works as expected. The problem I am facing is the wireless radios simply will not produce a signal. I have flashed a couple different versions of firmware and it doesn't make a difference, the result is always the same.

    In the same room with direct line of sight to the router multiple devices lose the signal entirely after roughly 6 feet, and even inches away from the router do not get full signal strength. It is currently only functional as a rather expensive 5-port switch.

    Before I send it back I wanted to see if any of you have any comments or suggestions, as these things are impossible to get for what I paid for it....apparently there's a reason for that.
     
  2. Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!
  3. Grisu

    Grisu Very Senior Member

    Joined:
    Aug 28, 2014
    Messages:
    1,293
    broken HW, return it.
    Used units like this (only TM got them new) have been sold in fully working condition much chaeper!

    NOBODY NEVER refurbished a router, maybe remove little dust, but what do you think could be refurbished, they all look like new after years in a halfway clean household ...
     
  4. cowsarecool5

    cowsarecool5 New Around Here

    Joined:
    Sep 14, 2018
    Messages:
    2
    Yeah I agree with you, I suppose I am just in mild denial and wanted to make sure I wasn't missing something. It definitely feels like bad hardware. Hopefully t-mo will sell another batch of the used ones soon.
     
  5. Pierino

    Pierino Very Senior Member

    Joined:
    Jul 13, 2012
    Messages:
    855
    Location:
    Columbus Ohio
    Where we you located? I have one that works that I can sell.
     
  6. follower

    follower Regular Contributor

    Joined:
    Dec 1, 2014
    Messages:
    73
    1. A defective adapter: replace the adapter.
    2. An anttena cable has been separated: open the router and connect it.
    3. A defective router: return it.

    I think your adapter is a defect. So many TM-AC1900 come with defective adapters.
     
    Last edited: Sep 16, 2018
  7. Pierino

    Pierino Very Senior Member

    Joined:
    Jul 13, 2012
    Messages:
    855
    Location:
    Columbus Ohio
    I seriously doubt it’s the power adapter.
     
  8. sfx2000

    sfx2000 Part of the Furniture

    Joined:
    Aug 11, 2011
    Messages:
    13,456
    Location:
    San Diego, CA
    Probably wasn't new - sounds like someone may have tried to convert it from TMO to a mainline device, and somehow messed up the calibration tables..
     
  9. AndreiV

    AndreiV Very Senior Member

    Joined:
    Aug 25, 2015
    Messages:
    539
    Location:
    UK
    The TM-AC1900 is on the end of life list , I would return it and buy a router that will get some support.
     
  10. Grisu

    Grisu Very Senior Member

    Joined:
    Aug 28, 2014
    Messages:
    1,293
    Hehe, they NEVER supported them, to say EOL is nothing more than a joke!

    Others running as 68U will have support as long as they are supported and probably some more time as 66U_B1 has been published not long ago.
     
Please support SNBForums! Just click on this link before you buy something from Amazon and we'll get a small commission on anything you buy. Thanks!