NFS Mount options

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Jeffrey Young

Senior Member
If this is something that can be added to the exports configuration file, then you can make use of the file /jffs/configs/exports.add and add the appropriate entry there.

Here is a man page on the exports file


EDIT: Note that you can not edit the exports file on router itself as that file is generated at run time each time the router is restarted. The most you can do is use the /jffs/configs/exports.add script to add entries to the end of the router's exports file.
 

ColinTaylor

Part of the Furniture
You don't need to edit the exports file directly, the same options can be set in the GUI.

I doubt that the OP's problem is actually the option he linked to (that option is already not enabled) but a simple permissions problem. Try setting the options like this:

Untitled.png
 
Last edited:

danyhoron

New Around Here
On a Linux box, that setting is found in /etc/default/nfs-kernel-server
Details are in the github link in my first post.
 

ColinTaylor

Part of the Furniture
On a Linux box, that setting is found in /etc/default/nfs-kernel-server
Details are in the github link in my first post.
This isn't a Linux box and that option is not enabled.
Code:
# ps w | grep mountd
1333 admin      904 S    /usr/sbin/mountd -N 2

# /usr/sbin/mountd -?
Usage: /usr/sbin/mountd [-F|--foreground] [-h|--help] [-v|--version] [-d kind|--debug kind]
        [-o num|--descriptors num] [-f exports-file|--exports-file=file]
        [-p|--port port] [-V version|--nfs-version version]
        [-N version|--no-nfs-version version] [-n|--no-tcp]
        [-H ha-callout-prog] [-s|--state-directory-path path]
        [-g|--manage-gids] [-t num|--num-threads=num]
 
Last edited:

danyhoron

New Around Here
Thank you, that's what I'm looking for: /usr/sbin/mountd


Bash:
# ps w | grep mountd
 3707 dani       848 S    /usr/sbin/mountd -V 2
13471 dani       844 S    mountd

Do you know who starts the mountd service?
Where could I set or change parameters ?
 

L&LD

Part of the Furniture
That's from 2017. I don't think it is enabled/available in the current firmware.

Edit: just like @ColinTaylor also stated above.
 

ColinTaylor

Part of the Furniture
@danyhoron The router doesn't use systemd because it isn't a Linux distro it's an embedded system. The mountd startup is hard-coded here.

You said you wanted to disable --manage-gids option but you can see from your output that the router doesn't enable that so there's nothing that needs to be changed.
 

danyhoron

New Around Here
Here's my setup.

I have a raspberry pis kubernetes cluster and I wanted to install PI Hole w/ persistent storage on the router's NFS export.
The installation fails because it first locks one of the files, and after that it can't access it anymore.

I followed the instructions in the github issue I posted in my 1st post and did setup a test linux box w/ NFS share and --manage-gids disabled.
I was able to install pi hole on the k8s cluster using the linux box NFS share.

This lead me to the conclusion that mountd is started by default w/ --manage-gids turned on.
 

ColinTaylor

Part of the Furniture
I don't know anything about the Pi side of things. But as you have seen --manage-gids is not turned on on the router.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top