Not Able to Install Merlin 386.3_2 on RT-AX86U

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Mr. Tea

New Around Here
I have tried to install Asuswrt-Merlin version 386.3_2 on my RT-AX86U over WLAN through the webgui. However, when I choose the file "RT-AX86U_386.3_2_cferom_pureubi.w" under manual firmware upload, I get an indefinite "Please wait, Applying Settings...". I have tried Firefox, Chrome, and Edge, with no luck. I've also tried restarting the router. Is there something else I should try, or something I am missing?

Any help would be greatly appreciated! Thanks in advance.
 

ZenitH-AT

Occasional Visitor
I was able to solve this problem by turning off the router and disconnecting the attached USB drive, then turning the router back on and performing the upgrade. Then I powered off the routter, reattached the USB drive and turned it on again. Addons like skynet that rely on the USB device seem to still be working.

---------

After encountering your same issue, I reloaded the web UI and noticed in the network map that my USB drive said it was unmounted. Upon checking logs, I saw a repeating message like:

Code:
syslog: USB partition unmounted from /tmp/mnt/ASUS fail. (return -1, No such file or directory)

Though the drive said it was unmounted in the network map, it seems it actually was not. So, I restarted the router and tried unmounting it from the network map. To little surprise, it showed the same neverending "please wait" that I experienced when trying to upgrade the firmware.

So, it seems to be an issue with unmounting USB devices. If the solution works you too, please let me know what addons you use, if any.
 
Last edited:

L&LD

Part of the Furniture
You need a new/different USB drive.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top