Not hanging up PPPoE connection when rebooting for firmware updates

rotareneg

Occasional Visitor
A bit of a minor thing, but when updating the firmware on my RT-AC66U B1 the router doesn't hang up the PPPoE connection before rebooting, causing a delay of a minute or so after the router is back up before the ISP side will let it reconnect. When performing a regular reboot it does hang up before rebooting, so that it immediately reconnects after starting up.

I'm running Merlin 386.7 alpha1 currently, but this also happens on older Merlin versions and the stock AsusWRT firmware.
 

tommyv2

Regular Contributor
A bit of a minor thing, but when updating the firmware on my RT-AC66U B1 the router doesn't hang up the PPPoE connection before rebooting, causing a delay of a minute or so after the router is back up before the ISP side will let it reconnect. When performing a regular reboot it does hang up before rebooting, so that it immediately reconnects after starting up.

I'm running Merlin 386.7 alpha1 currently, but this also happens on older Merlin versions and the stock AsusWRT firmware.

What’s your ISP? Fiber?

Are you getting PADO packet timeouts in the log?
 

rotareneg

Occasional Visitor
ISP is Nex-Tech, it's FTTH, and yes, there are PADO timeouts in the log, I think it takes about 5 minutes for their end to close the previous connection if it's not properly terminated and allow a new one. You can avoid the wait by manually disconnecting before running the firmware update, but that's easy to forget and it's not like it's a huge issue anyway... Oh no, I have to wait an extra couple of minutes! ;)

I just thought it was a bit odd as the regular reboot does hang up first, but I suppose the firmware update process works differently.
 

tommyv2

Regular Contributor
Try this setting at "No" to see if it helps you overall. I helped me on my Bell Fibe FTTH connection.

1653916173221.png
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top