ntp doesn't work with AC86u and merlin 384.19

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

tschi

New Around Here
Hello
I just have change of ISP and I have a issue with ntp on my asus 86u:
- The previous ISP was with ISP modem (+bridge mode) and asus 86u routeur with static ip and I didn't have ntp issue
- The new ISP is with dynamic ip and fiber connection :)
- Using latest stock asus firmware, I can have the router synchronized with the ntp server => the ISP doesn't seem to be in cause
- if I connect to the routeur and I try ntp command I get a timeout
Code:
ntp -w -p pool.ntp.org
ntp: timed out waiting for 37.187.104.44, reach 0x00, next query in 2s
the DNS doesn't seem to be in cause.
Code:
nvram show | grep ntp
size: 66363 bytes (64709 left)
ntp_ready=0
ntp_server0=pool.ntp.org
ntp_server1=
ntp_server_tried=pool.ntp.org
ntpd_enable=0
ntpd_server_redir=0
rc_support=mssid 2.4G 5G usbX2 update switchctrl manual_stb pwrctrl WIFI_LOGO nandflash smart_connect movistarTriple wifi2017 meoVoda gameMode app reboot_schedule ipv6 ipv6pt PARENTAL2 dnsfilter am_addons ntpd dnspriv dualwan pptpd openvpnd utf8_ssid printer modem webdav rrsut cloudsync media appbase timemachine hdspindown diskutility nfsd dnssec dblog bwdpi wrs_wbl tor HTTPS letsencrypt ssh vpnc repeater psta wl6 optimize_xbox wifi_tog_btn user_low_rssi tcode usericon stainfo cloudcheck realip wtfast ipsec_srv mumimo netool cfg_sync no_finiwl amas bcmwifi dfs bcmhnd eula proxysta
I have try to change ntp_ready=1 and
Code:
service restart_ntp
service restart_ntpd
service start_ntp
service start_ntpd
but it doesn't help.
Any idea is very welcome
 

Xentrk

Part of the Furniture
Hello
I just have change of ISP and I have a issue with ntp on my asus 86u:
- The previous ISP was with ISP modem (+bridge mode) and asus 86u routeur with static ip and I didn't have ntp issue
- The new ISP is with dynamic ip and fiber connection :)
- Using latest stock asus firmware, I can have the router synchronized with the ntp server => the ISP doesn't seem to be in cause
- if I connect to the routeur and I try ntp command I get a timeout
Code:
ntp -w -p pool.ntp.org
ntp: timed out waiting for 37.187.104.44, reach 0x00, next query in 2s
the DNS doesn't seem to be in cause.
Code:
nvram show | grep ntp
size: 66363 bytes (64709 left)
ntp_ready=0
ntp_server0=pool.ntp.org
ntp_server1=
ntp_server_tried=pool.ntp.org
ntpd_enable=0
ntpd_server_redir=0
rc_support=mssid 2.4G 5G usbX2 update switchctrl manual_stb pwrctrl WIFI_LOGO nandflash smart_connect movistarTriple wifi2017 meoVoda gameMode app reboot_schedule ipv6 ipv6pt PARENTAL2 dnsfilter am_addons ntpd dnspriv dualwan pptpd openvpnd utf8_ssid printer modem webdav rrsut cloudsync media appbase timemachine hdspindown diskutility nfsd dnssec dblog bwdpi wrs_wbl tor HTTPS letsencrypt ssh vpnc repeater psta wl6 optimize_xbox wifi_tog_btn user_low_rssi tcode usericon stainfo cloudcheck realip wtfast ipsec_srv mumimo netool cfg_sync no_finiwl amas bcmwifi dfs bcmhnd eula proxysta
I have try to change ntp_ready=1 and
Code:
service restart_ntp
service restart_ntpd
service start_ntp
service start_ntpd
but it doesn't help.
Any idea is very welcome
This work around has been used for past NTP issues. Try adding the line below to /jffs/configs/dnsmasq.conf.add. Then, reboot. 1.1.1.1 is Cloudflare DNS. You can change to another DNS if you prefer.
Code:
server=/pool.ntp.org/1.1.1.1
 

tschi

New Around Here
Thanks for reply.
I have try to add into dnsmasq.conf and set Wan: Use local caching DNS server as system resolver Yes or No
But it doesn't help
Code:
nslookup pool.ntp.org
Server:    127.0.0.1
Address 1: 127.0.0.1 localhost.localdomain

Name:      pool.ntp.org
Address 1: 37.187.104.44 herbrand.noumicek.cz
Address 2: 37.187.205.149 ntp19.kashra-server.com
Address 3: 51.159.6.183 51-159-6-183.rev.poneytelecom.eu
Address 4: 95.81.173.8 ntp-1.arkena.net

 ntp -w -p pool.ntp.org
ntp: timed out waiting for 51.158.147.92, reach 0x00, next query in 1s
 

tschi

New Around Here
As a countermeasure I have install ntp server on a raspberry pi and set the raspberry IP as "ntp server" in asus router, and it's working ...
It's not a perfect solution but at least it solves the issue.
 

lokester

Occasional Visitor
I have searched the web and this thread is the closest thing to my issue. I have an ASUS RT-AC66U running John's Fork of Merlin firmware. The router is at a remote site with NO INTERNET access. There is nothing connected to the WAN port on the router. I too am using a Raspberry PI with RTC as my NTP Server. I have several IOT devices configured to access the Raspberry PI IP address as their NTP server and they all time synch with the Pi. On the ASUS router, I have the Pi's IP address entered in the NTP server field (both primary and secondary) yet the ASUS never synchs with the Pi and therefore, the router never shows the correct date/time. Per @tschi's post above, it should synch, so I must be doing something incorrectly on my router config. Any suggestions?
 

ColinTaylor

Part of the Furniture
Teach me to get on when I first wake up.....you are right.:eek:

@lokester
Maybe he can put a service start_ntpc command in one of the user scripts (services-start perhaps)? I guess he'd have to manually set some of the ntp NVRAM variables beforehand?
 

john9527

Part of the Furniture
@ColinTaylor

I'm atoning for my sleepiness :)

Will put up a build in my development folder in about an hour.....

374.43_45EDj9527 (30-November-2020) ARM SDK, MIPS,ARM KRACK
* NEW: ntp: nvram option to attempt ntp sync without internet access

EDIT:
@lokester

New build is up....Update-45ED in the development folder
https://1drv.ms/f/s!Ainhp1nBLzMJiF2l3WjM46lSmxrH

to use the new option, via ssh
Code:
nvram set ntp_force=1
nvram commit
@RMerlin - got off topic from the original thread. If you think it best, you could move from post #5 on to a new thread.
 
Last edited:

lokester

Occasional Visitor
No joy. Installed new FW build and nvram commands. Rebooted router and still will not synch with RPi. Attached is the syslog file showing where NTP times out at 18:01:56.
I set the NTP server 1 as the RPi hostname and NTP server 2 as the RPi IP address.
 

lokester

Occasional Visitor
For some reason, my attachment will not upload. When I attach it, it shows up with a line through it.
 

john9527

Part of the Furniture
No joy. Installed new FW build and nvram commands.
I think I know why it didn't work. I put a refresh to the 45ED build in the development folder. You still need to use the same 'ntp_force' extra nvram setting.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top