What's new

OpenConnect Client Configuration question

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!


Occasional Visitor
Hi EveryOne
i installed Luci OpenConnect to be able to establish a VPN connection .
after setting up the connection and enabling it and connecting to the server , nothing works . i cannot open any webpages or anything . checked the log , seems like the connection is connecting without any issue , getting DNS and all ...
tried assigning the connection interface to different section in firewall , but didn't seem to change the result .
even discconnecting it wont solve the issue , i have to reboot the router to get data send and receive on the connection .
Same config is working just fine on my phone with the CiscoAnyConnect app .
any help would be appreciated
thanks .

PS :


4. Firewall
At this point the VPN is set up and the router can use it, but devices in the LAN of your router won't be able to access the internet anymore.

We need to set the VPN network interface as public by assigning VPN interface to WAN zone.

4.1-a With Openwrt up to 18.06 and 19.07
Click on Network in the top bar and then on Interfaces to open the interfaces configuration page.
Click on button Add new Interface…
Fill the form with the following values: Name = OpenVPN, Protocol = Unmanaged, Interface = tun0. Then click on Create Interface.
Edit the interface.
In panel General Settings: unselect the checkbox Bring up on boot.
In panel Firewall Settings: Assign firewall-zone to wan.
Click on Save and Apply the new configuration.
Reboot the router.


4.1-b With Openwrt 19.07 (alternative to the above step 4.1)
Click on Network in the top bar and then on Firewall to open the firewall configuration page.

Click on the Edit button of the wan (red) zone in the Zones list at the bottom of the page.

Click on the Advanced Settings tab and select the tunX interface (tun0 in the screenshot, which is the most likely if you have a single OpenVPN client/server running)

with no luck

also tried Diagnostic , Ping www.google.com and it didn't work

was fine before establishing the connection .
so should i assume that its not the firewall ?
so what should i check next ?

PING www.Google.com ( 56 data bytes

--- www.Google.com ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss


Part of the Furniture
try adjusting MaxMTU on the WAN interface - the tunnel adds additional bytes to packets, and may exceed things there...

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!