OpenVPN Connect Error(Internet does not work after disconnecting)

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

XIYO

New Around Here
I can't speak English very well, so I used Google Translator.
Please point out words that are difficult to understand. I will make it easier to understand.

Local verification on Mac Catalina.
AC88U merlin(384.19)
I'm using static IP and DNS is using 8.8.8.8, 8.8.4.4.
I also gave the router a domain name. I don't know what role this is...

There are 4 problems.

First, you can't access OpenVPN from your local network to an external domain.
Cannot access openvpn port from local to domain (handshake problem)
You need to change "remote" in client.ovpn to 192.168.1.1 to access it.
Is it a DNS problem?

Second, change the remote setting of client.ovpn to 192.168.1.1 and connect. However, when the internet connection is lost, the internet on ethernet does not work. As a solution, go to System Preferences -> Network -> Devices -> Advanced -> DHCP Lease Renewal.
Another DNS problem? (The first time I connect to OpenVPN, the internet works fine. When I disconnect from OpenVPN, the internet does not work and I cannot access OpenVPN again.)

Third, it is a problem with OpenVPN-Connect and OpenVPN (CLI).
Initially, I used a remotely configured Client.ovpn (created automatically by the router) as the domain. A connection error (udp4/6 handshaking) occurred in OpenVPN-Conect. When I first asked this here I asked to set udp4 here but it still didn't work. So I ran the same Client.ovpn with OpenVPN (CLI). It worked very well. There is no setting change.
There seems to be a problem with OpenVPN-Connect. Or is there something wrong with the configuration file?

Finally, I want to create two ways to connect to a specific client using the router's port forwarding function and the OpenVPN function.
For example
First ssh -p 11111 [email protected] or
Second, after connecting to OpenVPN, ssh -p 22 [email protected]
You need to use these two methods.
Is this possible? When I tried port forwarding it always stopped.
How i tested it.
SSH 11111 port access without running VPN -> port forwarding successful.
Run VPN and access SSH 11111 port -> No response.

Thanks in advance to those who helped me.

OpenVPN (CLI) domain connection success and failure records.
After connecting to OpenVPN for the first time, is it normal when I close the connection?)(same color texts)

Sun Nov 8 19:11:02 2020 /sbin/ifconfig utun2 10.8.0.4 10.8.0.4 netmask 255.255.255.0 mtu 1500 up
add net 10.8.0.0: gateway 10.8.0.4
add net 192.168.1.1: gateway en0
add net 0.0.0.0: gateway 10.8.0.1
add net 128.0.0.0: gateway 10.8.0.1

route: writing to routing socket: File exists
add net 192.168.1.0: gateway 10.8.0.1: File exists
Sun Nov 8 19:11:02 2020 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Sun Nov 8 19:11:02 2020 Initialization Sequence Completed.
Sun Nov 8 19:11:04 2020 event_wait : Interrupted system call (code=4)
delete net 192.168.1.0: gateway 10.8.0.1
delete net 192.168.1.1: gateway en0
delete net 0.0.0.0: gateway 10.8.0.1
delete net 128.0.0.0: gateway 10.8.0.1


1604832899330.png
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top