1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

OpenVPN Connectivity Question

Discussion in 'Asuswrt-Merlin' started by SuperDuke, Feb 22, 2020.

  1. SuperDuke

    SuperDuke Regular Contributor

    Joined:
    Aug 2, 2019
    Messages:
    77
    Location:
    Canada
    Hello all,

    At first I thought it was an OpenVPN and Unbound issue but I don't think so any longer (I mistakenly posted in the Unbound thread...apologies).

    I configured ExpressVPN as Client 1 (with only one device through VPN....this laptop). As is well with the world. I even disabled DNS Config in Client 1 to use Unbound and all worked well.

    Fast forward a few weeks to today and I did a DNS leak check and it showed Express servers. Weird (as it didn't do that previously but....). So for giggles I shut Client 1 down to recheck if Unbound was still operational and then poof no connectivity (although I can ping just fine). I played with many different permutations of setup (block connection if tunnel goes down is always No).

    I even remove the laptop entry from the client use list and nothing brings me back to the internet until I turn Client 1 back on in the VPN Client tab.

    It's almost like the laptop entry into a config file somewhere isn't being overwritten and keeping the laptop set to VPN only even if I shut it down....

    Any thoughts??? (Or files I can look into to see if an entry is still there?)

    Thanks as always!

    Edit1: Client 1 is set to off BUT laptop added to client list allows internet access....but if I remove the laptop from the client list, boom....no go....

    Edit2: Client 1 set to off and laptop client lface set to WAN...all is good.....lface set to VPN....internet not operational....

    Edit3: Now things may change.....but I believe there may be a sequencing issue. As I had the laptop set to VPN it didn't matter if Client 1 was off or on, no connection. If I removed it from the client list when it was LAST set to VPN, still no connection.

    However, once I set to WAN, even with Client 1 off, I could connect but the laptop needed to be part of the client list....now after I have removed the laptop from the list and I can still connect.....this is different then when I removed it from the list when lface was set to VPN and client still OFF.

    Anyone else see this kind of behaviour?
     
    Last edited: Feb 22, 2020