OpenVPN on XT8

jplw

Regular Contributor
I am on my home network with an RT-AX3000 router at 192.168.1.1. When I OpenVPN into my daughter's XT8 OpenVPN server (also at 192.168.1.1), I cannot connect to her router...it is still connecting on my local network even though the VPN is connected. Am I missing something? Shouldn't 192.168.1.1 be HER router after connecting?
 

RMerlin

Asuswrt-Merlin dev
Because 192.168.1.1 is your default gateway, you cannot have it conflict with hers, otherwise your Internet connection would no longer work - your local network needs to be able to talk to your own router at that IP.

You will have to either change the IP range used at one of the two ends, or try accessing her router through the VPN endpoint IP (i.e. something like 10.8.0.1, check what is shown in your OpenVPN connection log).
 

jplw

Regular Contributor
I tried 10.8.0.1, and it did not work. What is odd is that if I try this with OpenVPN on my iphone, it works fine. 192.168.1.1 is the router on the machine with the VPN server. If I try it with my Mac, 192.168.1.1 is the router on my local network. Maybe this is an OpenVPN client issue?
 

jplw

Regular Contributor
Sorry I was not clear. I have never been using a router as the client. Either my iPhone is the client or my Mac ( using the OpenVPN application) is the client. The iPhone works as I wish; the Mac does not.
 

ColinTaylor

Part of the Furniture
I see. Then this must be a client issue. It sounds like the Mac client is using split tunnelling. I don't use a Mac so can't comment on how to configure it to disable split tunnelling. Although in theory changing your LAN subnet as I previously described should also be a workaround.

Is the VPN server configured for "Internet and local network" or "Local network only"? Setting that option to "Internet and local network" might fix the problem with the Mac.
 
Last edited:

jplw

Regular Contributor
It was already set to "Internet and local network". I did get it to work by using Passepartout as the open VPN client. Thanks for your help.
 

RMerlin

Asuswrt-Merlin dev
What is odd is that if I try this with OpenVPN on my iphone, it works fine.
Your phone was probably connecting over cellular data, so it didn't need to route traffic through your local 192.168.1.1 router - it was routing through the cell tower's own gateway.
 

RMerlin

Asuswrt-Merlin dev
Code:
PC (192.168.1.100) ==> Router (192.168.1.1) ===> Internet ===> Router 2 (192.168.1.1)

All your PCs send their Internet traffic by sending traffic it to their default gateway, which in your case is 192.168.1.1. There is no way for a PC to be able to tell your router "I wanna talk to the OTHER 192.168.1.1, not to yourself". You cannot have an IP address that conflicts with your default gateway. Your only solution then will be to change the IP addresses used on one of the two sides of that tunnel.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top