Openvpn server poor throughput -AX88u

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

djrm

Regular Contributor
Hi,

I have been running an openvpn client in the AX88u for some time now and the performance has been really good (more than 200Mb/s average) using 600Mb symetric in both server (server is an ubuntu 20 machine with an i7 8th processor) and client sides.
Now trying to invert the configuration, so AX88u should act as openvpn server and the ubuntu machine as client, with exactly the same WAN speeds, the performance drop to aprox 40Mb/s only

VPN server is set as tun udp, using AES-128-CBC (also tested with AES-128-GCM) , SHA1 and lz4-v2 compression (tested with disabled as well).

Running 386.2

Is there any other configuration I should take into account to improve the openvpn server performance?

Thanks
 

redpaw.rider

Occasional Visitor
Delete all of that since you accidentally tried the wrong thing - go in and for vpn select Ike/2 and problem fixed.

Honestly I have no idea - tried to configure it once and followed the docs for it but didn’t work and said screw it.
 

djrm

Regular Contributor
Thanks @redpaw.rider but for ipsec I have an additional issue. After I see a good performance in the vpn I need to move the configuration to another brand router and ipcsec doesn't have user credentials as it the only option for ipsec is a site to site setup. I have not found any way to set the ipsec in the asus without the user authentication, so is there any way to get the ipsec server up as site to site without the user credentials requirement?
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top