Orbi RBK50 (RBR50 & RBS50) - IPV6 Not Recognized

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

OhThatHurt

New Around Here
I have noticed that IPV6 is no longer functioning on my Orbi. I have tried all Voxel FW versions since .19 without success. Currenly on V9.2.5.2.5SF-HW. IPV6 had been working in the past. I do not think it is directly related to a FW version, but maybe something happened on my router during an update? Is there a way there is a way to force the router to look for incoming IPV6 besides in the Advanced properties? My IPS is Comcast/Xfinity.
 

HELLO_wORLD

Senior Member
What is your setup ?
WAN side: auto config, DHCP?
LAN side?

From the router, from a shell (telnet or ssh), what are commands returning?
Code:
ip -6 route
ip -6 addr
ifconfig
nvram show | grep -F ipv6

I have noticed that IPV6 is no longer functioning on my Orbi. I have tried all Voxel FW versions since .19 without success. Currenly on V9.2.5.2.5SF-HW. IPV6 had been working in the past. I do not think it is directly related to a FW version, but maybe something happened on my router during an update? Is there a way there is a way to force the router to look for incoming IPV6 besides in the Advanced properties? My IPS is Comcast/Xfinity.
 

OhThatHurt

New Around Here
Hi HELLO_wORLD,
Thanks for your assistance.

Setup is RBR50 and RBS50 wired back haul. Router mode. IPv6 WAN side is Auto Config. Router's IPv6 address on WAN displays Not Available. In the past I could click Apply and it would find and IPv6 IP and start working again.
I have tried using Get Automatically from ISP and manually adding Cloudfare IPv6. LAN is set to DHCP. Below is the returns from the commands.

[email protected]:/# ip -6 route
2601:601:9f00:280::/64 dev br0 proto kernel metric 256
fe80::/64 dev eth1 proto kernel metric 256
fe80::/64 dev ath0 proto kernel metric 256
fe80::/64 dev ath1 proto kernel metric 256
fe80::/64 dev ath2 proto kernel metric 256
fe80::/64 dev ath01 proto kernel metric 256
fe80::/64 dev eth0 proto kernel metric 256
fe80::/64 dev brwan proto kernel metric 256
fe80::/64 dev br0 proto kernel metric 256
default via fe80::2a52:61ff:fef0:4c22 dev brwan metric 1
default via fe80::2a52:61ff:fef0:4c22 dev brwan proto ra metric 1024 expires 1797sec hoplimit 64

[email protected]:/# ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
6: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
inet6 fe80::a240:a0ff:fe64:16a1/64 scope link
valid_lft forever preferred_lft forever
7: eth1: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500 qlen 1000
inet6 fe80::a240:a0ff:fe64:16a0/64 scope link
valid_lft forever preferred_lft forever
11: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500
inet6 2601:601:9f00:280:a240:a0ff:fe64:16a0/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::a240:a0ff:fe64:16a0/64 scope link
valid_lft forever preferred_lft forever
12: brwan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500
inet6 fe80::a240:a0ff:fe64:16a1/64 scope link
valid_lft forever preferred_lft forever
16: ath0: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500
inet6 fe80::a440:a0ff:fe64:16a0/64 scope link
valid_lft forever preferred_lft forever
17: ath01: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500
inet6 fe80::a840:a0ff:fe64:16a0/64 scope link
valid_lft forever preferred_lft forever
19: ath1: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500
inet6 fe80::a240:a0ff:fe64:16a2/64 scope link
valid_lft forever preferred_lft forever
21: ath2: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500
inet6 fe80::a240:a0ff:fe64:16a3/64 scope link
valid_lft forever preferred_lft forever

[email protected]:/# nvram show | grep -F ipv6
ipv6_pppoe_reload=1
ipv6_autoConfig_domainName=
old_ipv6_dhcps_enable=0
ipv6_type=autoConfig
ipv6_autoConfig=050829207500297
ipv6_fixed_wan_prefix_len=
ipv6_fixed_gw_ip=
ipv6_dhcps_interface_id=0:0:0:0
ipv6_sameinfo=0
endis_ipv6_logo_test=0
ipv6_rule_premask=FFFF:FFFF:FFFF:FFFF::
ipv6_pppoe_dns1=
ipv6_dhcps_interface_id_enable=0
ipv6_rule_prefix=2601:601:9f00:280::
ipv6_autoConfig_dns_assign=1
dgc_netif_ipv6_ppp_if=ppp2
ipv6_fixed_lan_ip=
ipv6_fixed_wan_ip=
ipv6_autoConfig_dns1=2606:4700:4700:0:0:0:0:1111
ipv6_autoConfig_dns2=2606:4700:4700:0:0:0:0:1001
ipv6_pppoe_dns_assign=0
ipv6_dhcps_enable=0
ipv6_dhcp_dns1=2606:4700:4700:0:0:0:0:1111
ipv6_dhcp_dns2=2606:4700:4700:0:0:0:0:1001
ipv6_autoConfig_userClass=
ipv6_auto_dns_assign=1
ipv6_con_type=82613503
ipv6_6to4_dns_assign=0
ipv6_auto_dns1=2606:4700:4700:0:0:0:0:1111
ipv6_auto_dns2=2606:4700:4700:0:0:0:0:1001
ipv6_dhcp_dns_assign=1
wan_ipv6_cone_fitering=0
ipv6_orange_dns_assign=0
ipv6_6rd_dns1=
ipv6_6rd_dns2=
ipv6_passthrougth=2775062750590
ipv6_dhcp=02744182473161
ipv6_6to4_dns1=
ipv6_6to4_dns2=
ipv6_6to4_relay=0.0.0.0
ipv6_auto=09024131
ipv6_dhcp_userClass=
ipv6_dhcp_domainName=
ipv6_dhcps_interface_id_oldenable=0
ipv6_fixed_lan_prefix_len=
ipv6_6rd_dns_assign=0
ipv6_fixed_dns1=
ipv6_fixed_dns2=
ipv6_6to4_relay_type=0
enable_orange_ipv6=0
 
Last edited:

Chezsmithy

New Around Here
I am seeing the same thing.
Comcast not delivering an IPv6 address.
The same firmware.
It has worked in the past and works if switching back to stock.
 

HELLO_wORLD

Senior Member
Clearly your WAN interface (brwan) was not given global IPv6 (you only have link local scope). You LAN (br0) however was given a global address starting by 2601, so you probably receive some kind of router advertisement from ISP.

1) have you tried DHCP on your WAN side? You are now on auto config.
2) do you have Entware? If so, could you install rdisc6 and run it "rdisc6 brwan" (without brackets)?

Also,you might ask your ISP about their IPv6 connectivity, settings...

one last thing before messing with settings: why not try to revert to previous firmware and see if it works? Just to eliminate this possibility.
 

HELLO_wORLD

Senior Member
I am seeing the same thing.
Comcast not delivering an IPv6 address.
The same firmware.
It has worked in the past and works if switching back to stock.
So it is likely a difference in net6conf scripts

Good news is this can be fixed.

Now, it might be time consuming to pinpoint...

2 ideas:
1) from stock firmware, running the commands I mentioned and save them somewhere.
Then compare with results on Voxel’s. That would help to understand the difference and what to fix.

2) copying /etc/net6conf/ from stock to replace it in Voxel’s. No idea if it would work or not.
 

Chezsmithy

New Around Here
No addional commands were run. Just installed latest vowel firmware over stock. Past voxel firmware versions were working just fine.
 

HELLO_wORLD

Senior Member
I'm sorry. I meant: now that you have a working situation, could you run those commands (to compare):
ip -6 route
ip -6 addr
ifconfig
nvram show | grep -F ipv6
 

OhThatHurt

New Around Here
Rolled back to stock V2.5.1.16. IPv6 now functioning. Here are returns from stock FW.

[email protected]:/# ip -6 route
2001:558:600a:cc::/64 dev brwan proto kernel metric 256
2601:601:9f00:280::/64 dev br0 proto kernel metric 256
fe80::/64 dev eth1 proto kernel metric 256
fe80::/64 dev eth0 proto kernel metric 256
fe80::/64 dev ath0 proto kernel metric 256
fe80::/64 dev ath1 proto kernel metric 256
fe80::/64 dev ath2 proto kernel metric 256
fe80::/64 dev ath01 proto kernel metric 256
fe80::/64 dev brwan proto kernel metric 256
fe80::/64 dev br0 proto kernel metric 256
default via fe80::2a52:61ff:fef0:4c22 dev brwan metric 1

[email protected]:/# ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
6: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
inet6 fe80::a240:a0ff:fe64:16a1/64 scope link
valid_lft forever preferred_lft forever
7: eth1: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500 qlen 1000
inet6 fe80::a240:a0ff:fe64:16a0/64 scope link
valid_lft forever preferred_lft forever
11: br0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500
inet6 2601:601:9f00:280:a240:a0ff:fe64:16a0/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::a240:a0ff:fe64:16a0/64 scope link
valid_lft forever preferred_lft forever
12: brwan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500
inet6 2001:558:600a:cc:bd97:a76e:b950:d1ed/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::a240:a0ff:fe64:16a1/64 scope link
valid_lft forever preferred_lft forever
16: ath0: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500
inet6 fe80::a440:a0ff:fe64:16a0/64 scope link
valid_lft forever preferred_lft forever
17: ath01: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500
inet6 fe80::a840:a0ff:fe64:16a0/64 scope link
valid_lft forever preferred_lft forever
19: ath1: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500
inet6 fe80::a240:a0ff:fe64:16a2/64 scope link
valid_lft forever preferred_lft forever
21: ath2: <BROADCAST,MULTICAST,ALLMULTI,UP,LOWER_UP> mtu 1500
inet6 fe80::a240:a0ff:fe64:16a3/64 scope link
valid_lft forever preferred_lft forever

[email protected]:/# nvram show | grep -F ipv6
ipv6_pppoe_reload=1
ipv6_autoConfig_domainName=
old_ipv6_dhcps_enable=0
ipv6_type=dhcp
ipv6_autoConfig=72377333993
ipv6_fixed_wan_prefix_len=
ipv6_fixed_gw_ip=
ipv6_dhcps_interface_id=0:0:0:0
ipv6_sameinfo=0
endis_ipv6_logo_test=0
ipv6_rule_premask=FFFF:FFFF:FFFF:FFFF::
ipv6_pppoe_dns1=
ipv6_dhcps_interface_id_enable=0
ipv6_rule_prefix=2601:601:9f00:280::
ipv6_autoConfig_dns_assign=1
dgc_netif_ipv6_ppp_if=ppp2
ipv6_fixed_lan_ip=
ipv6_fixed_wan_ip=
ipv6_autoConfig_dns1=2606:4700:4700:0:0:0:0:1111
ipv6_autoConfig_dns2=2606:4700:4700:0:0:0:0:1001
ipv6_pppoe_dns_assign=0
ipv6_dhcps_enable=0
ipv6_dhcp_dns1=2606:4700:4700:0:0:0:0:1111
ipv6_dhcp_dns2=2605:4700:4700:0:0:0:0:1001
ipv6_autoConfig_userClass=
ipv6_auto_dns_assign=0
ipv6_con_type=641194097398408
ipv6_6to4_dns_assign=0
ipv6_auto_dns1=
ipv6_auto_dns2=
ipv6_dhcp_dns_assign=1
wan_ipv6_cone_fitering=0
ipv6_orange_dns_assign=0
ipv6_6rd_dns1=
ipv6_6rd_dns2=
ipv6_dhcp=388750464

ipv6_6to4_dns1=

ipv6_6to4_dns2=

ipv6_6to4_relay=0.0.0.0

ipv6_auto=05515097139392

ipv6_dhcp_userClass=

ipv6_dhcps_interface_id_oldenable=0

ipv6_dhcp_domainName=

ipv6_fixed_lan_prefix_len=

ipv6_6rd_dns_assign=0

ipv6_fixed_dns1=

ipv6_fixed_dns2=

ipv6_6to4_relay_type=0

enable_orange_ipv6=0
 

HELLO_wORLD

Senior Member
Ok, thank you.

The major difference here is in the first case, IPv6 is expected from autoconfig, in the second, DHCPv6.
ipv6_type=autoConfig vs ipv6_type=dhcp

I don’t know about Orbi routers, but on R7800, for WAN IPv6 you can select between "Auto Config" and "DHCP" (among others like Disabled, Manual, etc.) for stock or Voxel’s.

Do you have this choice on Orbi?

If so, by selecting DHCP, it should work.
 

Chezsmithy

New Around Here
Agree. Also tried switching from auto config to DHCP. No change. Also tried turning ipv6 off, rebooting and then reenabling ipv6. No change.
 

HELLO_wORLD

Senior Member
Ok, we were comparing apples to oranges.

Whenever one of you is back to Voxel’s, please set it to DHCP, apply and then run the commands so we can compare what is different.
I also added a few commands.

To recap, run on stock and Voxel’s, with same exact setting (DHCP):
Code:
ip -6 route
ip -6 addr
ifconfig
nvram show | grep -F ipv6
ps | grep dhcp
cat /tmp/dhcp6c.conf
cat /tmp/dhcp6c_script_envs
Again, only do that when you have the time and if you want to. Meanwhile, maybe @Voxel did/will figure that out and fix it for next release.

Out of curiosity, do you have this problem with last version only or all Voxel’s versions?

I tried both "Auto Config" and "DHCP" on Voxel's FW without success. It was on Auto when I grabbed the query.
 

thedeebs

New Around Here
Out of curiosity, do you have this problem with last version only or all Voxel’s versions?
ill chime in here, I have the same issue with IPV6 on Voxel firmware.
From My tests it Seems the issue was introduced in voxel 9.2.5.1.34.
Stock firmware 2.5.1.16 works
Stock firmware 2.5.2.4 works
Voxel 9.2.5.1.33 works
Voxel 9.2.5.1.34 - Doesn't work
Voxel 9.2.5.2.5 - Doesn't work
 

Voxel

Very Senior Member
Thanks for your report. Unfortunately this is most problematic for me to fix because of my ISP does not support IPv6. So I have to trace/debug this in my mind (with your help I hope :)).

This is important info:

Voxel 9.2.5.1.33 works
Voxel 9.2.5.1.34 - Doesn't work
Voxel 9.2.5.2.5 - Doesn't work
because of I've changed the compiler (9.3.0->10.2.0) since 9.2.5.1.34SF-HW. So most probably something like sleeping bug in the codes by DNI/NG and it is waked up when compiler was changed, similar to issue:

https://www.snbforums.com/threads/c...1-0-2-75-1sf-v-1-0-2-75-2sf.62906/post-563539

when I changed the compiler for R7800.

Could you please check that radvd is working (from telnet/ssh), i.e.

Code:
ps | grep radvd
it should display {or not) "/usr/sbin/radvd" is running or not. radvd is one of the most ugly example of changes by NG/DNI for original radvd daemon...

In general IPv6 is changed a bit by NG/DNI in 2.5.2.4 firmware (changes are included into my last build), but your report that 9.2.5.1.34 is not working too with IPv6...

Well. As I said, I have to debug/trace this only by my eyes. So your help is needed. Thanks.

Voxel.
 

Voxel

Very Senior Member

thedeebs

New Around Here

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top