ovpn-server keeps trying to restart

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Centrifuge

Senior Member
In the system log I see repeated ovpn restarts and fails and restart attempts. I have this router in AP mode with custom scripts disabled and it is not being used for VPN. The OVPN options are not available. What is causing this activity and how can I end it?
Oct 24 11:50:00 rc_service: service 13708:notify_rc restart_vpnserver1
Oct 24 11:50:00 custom_script: Found service-event, but custom script execution is disabled!
Oct 24 11:50:00 ovpn-server1[13771]: OpenVPN 2.4.9 arm-buildroot-linux-gnueabi [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [MH/PKTINFO] [AEAD] built on Jun 28 2020
Oct 24 11:50:00 ovpn-server1[13771]: library versions: OpenSSL 1.1.1g 21 Apr 2020, LZO 2.08
Oct 24 11:50:00 ovpn-server1[13773]: NOTE: your local LAN uses the extremely common subnet address 192.168.0.x or 192.168.1.x. Be aware that this might create routing conflicts if you connect to the VPN server from public locations such as internet cafes that use the same subnet.
Oct 24 11:50:00 ovpn-server1[13773]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
Oct 24 11:50:00 ovpn-server1[13773]: PLUGIN_INIT: POST /usr/lib/openvpn-plugin-auth-pam.so '[/usr/lib/openvpn-plugin-auth-pam.so] [openvpn]' intercepted=PLUGIN_AUTH_USER_PASS_VERIFY
Oct 24 11:50:00 ovpn-server1[13773]: Diffie-Hellman initialized with 2048 bit key
Oct 24 11:50:00 ovpn-server1[13773]: TUN/TAP device tun21 opened
Oct 24 11:50:00 ovpn-server1[13773]: TUN/TAP TX queue length set to 1000
Oct 24 11:50:00 ovpn-server1[13773]: /sbin/ifconfig tun21 10.8.0.1 netmask 255.255.255.0 mtu 1500 broadcast 10.8.0.255
Oct 24 11:50:00 ovpn-server1[13773]: updown.sh tun21 1500 1621 10.8.0.1 255.255.255.0 init
Oct 24 11:50:00 ovpn-server1[13773]: Could not determine IPv4/IPv6 protocol. Using AF_INET
Oct 24 11:50:00 ovpn-server1[13773]: Socket Buffers: R=[524288->524288] S=[524288->524288]
Oct 24 11:50:00 ovpn-server1[13773]: TCP/UDP: Socket bind failed on local address [AF_INET]76.173.92.228:1194: Cannot assign requested address (errno=99)
Oct 24 11:50:00 ovpn-server1[13773]: Exiting due to fatal error
Oct 24 11:50:00 ovpn-server1[13773]: Closing TUN/TAP interface
Oct 24 11:50:00 ovpn-server1[13773]: /sbin/ifconfig tun21 0.0.0.0
Oct 24 11:50:00 ovpn-server1[13773]: updown.sh tun21 1500 1621 10.8.0.1 255.255.255.0 init
Oct 24 11:52:00 rc_service: service 13958:notify_rc restart_vpnserver1
 

eibgrad

Very Senior Member
Reset the router to factory defaults, THEN enable AP mode (I'm assuming some prior configuration is the issue). Clear out anything in /jffs/scripts or /jffs/configs prior to the reset as well.
 

Centrifuge

Senior Member
Reset the router to factory defaults
Thank you for that reply!
Uh boy, the fam is going to love that...no way to edit a conf to avoid that?
 

eibgrad

Very Senior Member
I don't know for sure where things went wrong, so best I can offer is to start over. As you stated, the OpenVPN server is not even available in AP mode, so something is amiss. The log suggests there's something in /jffs/scripts, apparently a services-event script, but then it says such scripts are NOT enabled, but seems to execute anyway. If you want to try just deleting anything still in /jffs/scripts and reboot, try it.
 

Centrifuge

Senior Member
just deleting anything still in /jffs/scripts and reboot,
Yeah, that prevented from the ovpn-server actually getting launched and instead skipped it. So restore, update firmware, restore, and no service calls to it. Thnx.
 

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top