OVPN server troubles with certain Android apps?

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Chrisgtl

Regular Contributor
I've spent most of the weekend trying to figure out why my Open VPN server is acting all wierd without any sucess. Troubleshooting VPN has made me realise I know very little about what I am doing.

The story goes like this;

192.168.0.1 = 86U
192.168.0.2 = Asustor NAS running CIFS (ethernet)
192.168.0.3 = Windows 10 running Plex, SabNZB, VNC (ethernet)
192.168.0.5 = Raspberry4 running Raspbian with Pi-Hole (ethernet)

I was away from home recently and wanted to start a NZB download going from my Android phone using mobile/data network. Previously this worked by using the Android Open VPN app and connecting to my VPN server. Then I use an app called NZB360 to upload the .nzb to my Windows 10 machine which is running SabNZB. NZB360 connects fine but when I try upload a .nzb the app hangs and the download never starts. Once I returned home and connected to the wifi I tried again (without the need for VPN now) and it works fine.

I see this was logged in SaBNZB;

-----------------------------------------------------------------------------

2020-01-04 13:38:05,088::ERROR::[_cplogging:219] [04/Jan/2020:13:38:05] HTTP
Traceback (most recent call last):
File "cherrypy\_cprequest.pyo", line 663, in respond
File "cherrypy\_cpreqbody.pyo", line 989, in process
File "cherrypy\_cpreqbody.pyo", line 558, in process
File "cherrypy\_cpreqbody.pyo", line 223, in process_multipart_form_data
File "cherrypy\_cpreqbody.pyo", line 203, in process_multipart
File "cherrypy\_cpreqbody.pyo", line 480, in readline
File "cherrypy\_cpreqbody.pyo", line 860, in readline
File "cherrypy\_cpreqbody.pyo", line 824, in read
File "cherrypy\wsgiserver\__init__.pyo", line 360, in read
File "cherrypy\wsgiserver\__init__.pyo", line 1138, in read
File "cherrypy\wsgiserver\__init__.pyo", line 1070, in recv
timeout: timed out
2020-01-04 13:38:25,183::INFO::[_cplogging:219] [04/Jan/2020:13:38:25] HTTP
Request Headers:
Content-Length: 3423543
REFERER: http://192.168.0.3:8088/
HOST: 192.168.0.3:8088
ORIGIN: http://192.168.0.3:8088
CONNECTION: keep-alive
Remote-Addr: 10.8.0.2
ACCEPT: */*
USER-AGENT: Mozilla/5.0 (Linux; Android 9; SM-G950F) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.93 Mobile Safari/537.36
X-REQUESTED-WITH: XMLHttpRequest
ACCEPT-LANGUAGE: en-GB,en;q=0.9
DNT: 1
Content-Type: multipart/form-data; boundary=----WebKitFormBoundary05CMasAR1u9kWkGL
ACCEPT-ENCODING: gzip, deflate

------------------------------------------------------------------------------------

I then digged further and realised somethings are not working when connected to my OpenVPN server. I can't be 100% sure but I am pretty sure all my android apps worked when connected to my VPN server. Now BBC Sport app won't refresh data, IMDB won't refresh data but other apps like BBC News and BBC Weather will refrsh data.....

So I dug further. When connected to my VPN server I am unable to write data without faults to my Asustor NAS which is running CIFS. When I try copy a file to the NAS I get a network error message and the copy fails.

The problem I have is my Android phone and my NAS have had firmware updates between everything working and not working. To add more headache I've also updated the 86U firmware a couple times since it was working.


Anyone else out there with similar problems all of a sudden?
 

Chrisgtl

Regular Contributor
Is there anything relevant in the log in the Android OpenVPN app on the client device?
Nothing in the log at all.

Try the OpenVPN for Android by Arne Schwabe.
It just works!
Thats the VPN app I already use on my Android.

OK - so I should of tried this before but if I connect to my work VPN the BBC Sports app works. Definately something funky going on with my VPN.
 

elorimer

Very Senior Member
Try the OpenVPN for Android by Arne Schwabe.
It just works!
+1

I had lots of problems with the official android openvpn client, none with the Schwabe client. Also on chromebooks that support android apps.
 

Chrisgtl

Regular Contributor
Think I've got to the bottom of it. Need to test more but as it stands now everything is working again.

I can write to my NAS
I can upload NZB via NZB360
Android apps working again and Pi-Hole blocking ads

Pretty sure it was UDP causing all those problems as TCP is working perfect.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top