1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

PCE-AC88 not working in 5 Ghz mode

Discussion in 'ASUS Wireless' started by Ernesto_rvr, Jan 22, 2020.

  1. Ernesto_rvr

    Ernesto_rvr New Around Here

    Joined:
    Jan 22, 2020
    Messages:
    1
    Hello all:

    I've just bought a PCE-AC88 card, because my powerline adapters are getting 40-50 mbps out of the 120 mbps connection. Sadly I can not get it to run correctly. The following things have happened.

    (I've already went thru the guide that is posted on troubleshooting the wifi)

    1-. It sees a 5 Ghz network as well as the 2.4 Ghz.
    2.- To the 2.4 Ghz it connects without any troubles (gets around 30 mbps).
    3.- I've got all sorts of problems trying to connect to the 5 Ghz net. It ran a couple of times on the 802.11 ac only mode. I was getting the full 120 mbps no problem. At some point it just disconnected and never worked again. After that I've tried going to 802.11 a/n/ac without success. The error I get is " can not connect to network". I've tried turning off the 2.4 Ghz network on router. Repeated everything. No luck.
    4.- Yesterday I tried assigning a fixed ip in the router. The AC88 card only connects when using 802.11 a/n/ac mode. Speed around 40 mbps. If I choose again 802.11 n/ac or 802.11 ac only i get "can not connect to network". I've tried auto channels, as well as fixed channel. I've tried 20, 20/40, 20/40/80 Mhz.
    5.- I tried the actual drivers and the old drivers. Ran all the steps before. No luck. Uninstalled and re-installed, no luck.
    6.- My cellphone Samsung Galaxy 50 connects to the router no problem at all. 2.4 Ghz, 5 Ghz, 802.11 a/n/ac, 802.11 n/ac, or 802.11 ac only.
    7.- I've tried to look for adapter properties in advanced section. There is no property that selects either a/nc/ac, or n/ac or ac only mode.

    Windows 10, v1903. The router is provided by the cable company (CH7465LG-LC)

    My preferred solution would be to run on 802.11 ac only, since with that mode I get 120 mbps on my cellphone. Of course the PCI card as well as the router support ac only, since it ran with it a couple of times before it stopped working out of nowhere.

    I'm getting crazy. Any pointers out there? I've attached the router properties.

    upload_2020-1-22_12-57-25.png
     
  2. OzarkEdge

    OzarkEdge Part of the Furniture

    Joined:
    Feb 14, 2018
    Messages:
    2,586
    Location:
    USA
    It did work and then stopped. You have other equipment connecting ok. Ensure its latest OEM drivers are installed. It's new... assume it's defective and try another one.

    OE