Persistent "Internet status: Disconnected" shown on web UI's General - Network Map

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

MWGlidden

Occasional Visitor
Using wrtmerlin 384.19 on an RT-AC68P with two AImesh nodes also running 384.19. Root node also running...
  • Diversion v4.1.12 with pixelsrv-tls and Medium blocking list and no custom blocked sites or ranges
  • Skynet v7.2.2
  • connmon v2.7.0

While our system can access the Internet most of the time, our web management UI shows two odd symptoms I'm not savvy enough to resolve.
  1. General - Network Map: Internet status shows as Disconnected (again, despite Internet access working in general)
  2. Administration - System: Router can't synchronize to NTP server pool.ntp.org or time.nist.gov. I can't ping either address from the router's shell, so am not surprised by this, just wondering what's blocking something so essential. I _can_ reach time.google.com, so switched to using that for NTP. While this is a workaround, I'd rather use one of the others.

Could Diversion be blocking something needed to show Internet status as connected and allow me to NTP sync? If so, I'm not sure where else to check, since I don't use a custom block list.
 

Attachments

thelonelycoder

Part of the Furniture
Could Diversion be blocking something needed to show Internet status as connected and allow me to NTP sync? If so, I'm not sure where else to check, since I don't use a custom block list.
I would rule Diversion out. Unless it indeed blocks the domain that Asus uses to determine the connectivity status.
Just disable Diversion and reboot, then look at the routers Syslog how soon NTP synced while it booted.
 

muffintastic

Regular Contributor
@MWGlidden
Are you on custom DNS, check under the "Advanced Settings" on the lefthand side, the click WAN. I usually get this if i'm running Non-ISP DNS then it will grab my external IP etc. But since i switched to continous mode in the WAN settings and custom DNS i rarely get this and when i do it resolves itself.
 

MWGlidden

Occasional Visitor
Thanks for the answers!

@muffintastic No custom DNS settings that I can see at the moment. These screenshots show my current settings, other than a cloned MAC that I obscured.

@thelonelycoder I disabled Diversion and rebooted, without a clear change in behavior. That was using Google as my NTP. Will try again later today with the original NTP addresses.
 

Attachments

Calkulin

Occasional Visitor
I had this issue when ATEMODE was set to 1 in the bootloader, changed it to 0 and haven't had that issue in months
 

ColinTaylor

Part of the Furniture
Check that Tools > Other Settings > Wan: Use local caching DNS server as system resolver (default: No) is still set at "No".

You could also try disabling Network Monitoring at Administration > System.
 

thelonelycoder

Part of the Furniture
And post the Google NPT server(s). That may be blocked by Diversion or Skynet.
 

jonasitanga

Occasional Visitor
@MWGlidden

As Mentioned a few post up by Calkuling, I had the same problem for a couple of months ago. It turned out that my router from factory was set to be in developer mode. So I changed a 1 to a 0 and it was all goid after that.

The problem occured when I upgraded my firmware to a new one. I tried both stoch and merlin. The router it happened on is Ac 66u b1.

So, two question' did you just upgrade firmware? If so, what version did you come from?
 
Last edited:

MWGlidden

Occasional Visitor
Thanks all! I made the ATEMODE change to 1 and will be able to factory reset the router later this week as part of the testing. (Three different schedules in our house to work around.)

Also changed the DHCP frequency to "Continuous" per @muffintastic. Something must be better, because the Network Map's Internet Status now _alternates_ between (sometimes) Connected and (most of the time) Disconnected. This implies it's not a Skynet or Diversion issue, since I shouldn't get Connected at all if they're a culprit.

@jonasitanga I first noticed the "Internet Disconnected" status several months ago, perhaps Mar/Apr, and have updated firmware each time a new wrtmerlin comes out. If the ATEMODE change to 1 is a permanent fix, sounds like I'll see that once I can reset the router later this week?

P.S. While my AiMesh has three nodes right now, all three are different Asus hardware. I'm thinking of changing the root node to AC66U_B1 or AC1900 to see if it makes the whole system more reliable. Any opinion if using a particular root node will make a difference?
 

MWGlidden

Occasional Visitor
Tested the Connected / Disconnected frequency by watching the Network Map page. It will show "Connected" for perhaps 20 seconds, as on the screenshot, and then return to "Disconnected" for a minute or more. The timing seems consistent.
 

Attachments

jonasitanga

Occasional Visitor
@MWGlidden

Im not 100% sure what you mean. But have you changed the ATEMODE? If that is the culprit it should show at once, perhaps a reboot away.

I miss typed before.. ATEMODE should be set to a 0.. I just edited it in my original post.

Changing that means it's permanent, regardless of how many times you reset the firmware.
But I may have missunderstod your meaning.

Look here for som more in deapth info:
https://www.snbforums.com/threads/internet-status-disconnected.59830/

Jonas
 
Last edited:

MWGlidden

Occasional Visitor
@MWGlidden

Im not 100% sure what you mean. But have you changed the ATEMODE? If that is the culprit it should show at once, perhaps a reboot away.

I miss typed before.. ATEMODE should be set to a 0.. I just edited it in my original post.

Changing that means it's permanent, regardless of how many times you reset the firmware.
But I may have missunderstod your meaning.

Look here for som more in deapth info:
https://www.snbforums.com/threads/internet-status-disconnected.59830/

Jonas
My mistake on the number, it was ATEMODE 0 (ssh command removed, apologies)

When I web searched for a similar solution, another forum recommended factory resetting the router after making the ATEMODE change to be sure it "took." That might or might not be relevant to my current situation. I'll go and check out the thread you linked now.
 
Last edited:

jonasitanga

Occasional Visitor
My mistake on the number, it was ATEMODE 0. Here's the exact ssh I ran via router shell:

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

When I web searched for a similar solution, another forum recommended factory resetting the router after making the ATEMODE change to be sure it "took." That might or might not be relevant to my current situation. I'll go and check out the thread you linked now.
@MWGlidden

You have to remove those commands immediately. It´s against forum rules to write that info here. I think it´s in some way illegal and against Asus rules.

What was ATEMODE originaly set to before your tinkering?
 
Last edited:

MWGlidden

Occasional Visitor
@MWGlidden

You have to remove those commands immediately. It´s against forum rules to write that info here. I think it´s in some way illegal and against Asus rules.

What was ATEMODE originaly set to before your tinkering?
Got it, just edited the post to remove that ssh.

Not certain of the original ATEMODE setting. It's now 0 when I check it.

I _do_ know that another change appears to have resolved my connection problem. By disabling "DNS" monitoring and just using "ping," as on the screenshot, I'm now reliably "connected" from the Network Map's perspective. While I'm not sure why DNS would be the issue, that change made a difference.
 

Attachments

Last edited:

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top