Solved Pihole DNS Server

macster2075

Very Senior Member
I have Pihole setup on a dedicated computer and it's running great. I have been using the Asus DNSfilter to point devices to the Pihole.
And like I said, it works great, as it should.

DNSFilter.jpg



This is until recently that I wanted to try to have all devices use the pihole, so I added the Pihole DNS address to the WAN section....but..
If I do that, once I reboot the router, I lose all connectivity and I can't access the GUI anymore forcing me to reset the router.

WAN.jpg


Any ideas as why this is happening?
Am I not allowed to add a custom DNS address in that field?
 

Crimliar

Senior Member
There are probably twice as many solutions to this as there are members in this forum, and a quick search will pull up several solutions...

The easy way is to turn off DNS filtering, remove the Pi-Hole address from the WAN page and just add the Pi-hole address to LAN>DHCP Server: DNS Server1

Having done that DHCP will send the Raspberry Pi address to clients rather than the router. You only need to use DNS filtering if you want to hard-force devices to use the raspberry pi. In which case in DNS filtering you set the Pi as the default for all devices, but then create an exception so the PI isn't forced to use the router (or you get a loop).
 

macster2075

Very Senior Member
If I add the pihole DNS address in the WAN section, (and disabling DNSfilter) I lose connectivity and complete access to the router.. forcing a reset.
 

Crimliar

Senior Member
If I add the pihole DNS address in the WAN section, (and disabling DNSfilter) I lose connectivity and complete access to the router.. forcing a reset.
You should still be able to access the router using its IP address (likely 192.168.50.1 or 192.168.1.1), but router.asus.com will not work with that setup. When you use the WAN settings, the router gives local clients its own address, whereas on the equivalent LAN page the router directly provides the address entered in the DNS server settings.
 

bbunge

Part of the Furniture
If I add the pihole DNS address in the WAN section, (and disabling DNSfilter) I lose connectivity and complete access to the router.. forcing a reset.
That is correct. In the WAN you need to have IP addresses of valid upstream DNS resolvers. DO NOT PUT THE PI-HOLE ADDRESS IN THE WAN DNS SERVERS!!!
 

macster2075

Very Senior Member
That is correct. In the WAN you need to have IP addresses of valid upstream DNS resolvers. DO NOT PUT THE PI-HOLE ADDRESS IN THE WAN DNS SERVERS!!!
Oh, I was following instructions on how to add Pihole DNS to Asus router. It shows to add them in both places, WAN and LAN.

Good to know. I know now this is what was happening. It works by adding the DNS address only to the LAN section. Problem solved!
 

FlyByWire

Regular Contributor
I‘d like to hijack this thread with a similar problem. I am running latest Merlin fw on an RT-AC86U. PiHole is running on an RasPi.
I want to move the PiHole to my Proxmox server and installed another PiHole in LXC container. Settings are similar in both installations.
In Router settings I left Wan settings on default. In Lan settings I put the IP of the PiHole for DNS and WINS. As the RasPI (192.168.178.200) has a DHCP address, I added it to manually assigned IP. DNS filter is enabled with custom IP left blank and added the RasPI IP with „no filtering“ (and the Proxmox LXC too)
Everything is working as expected. When I change the router Settings to the PiHole IP of the instance on the Proxmox (192.168.178.143) which is fixed IP, my Router looses the connection to the ISP with the message „ DHCP server of your ISP in not working correct“. I tried adding the IP of the Proxmox‘s PiHole to manually assigned in DHCP settings (which I think is nonsense?!) without success.
I then gave it a try with AdGuard, same problem. no connection to ISP when setting DNS to AdGuard (which is running on the Proxmox too).

Any ideas?
 

macster2075

Very Senior Member
Make sure you are are refreshing the connection every time you switch dns servers. CMD... ipconfig /flushdns - sometimes, depending on the browser, you have to close it and reopen all instances of the browser.
 

FlyByWire

Regular Contributor
Make sure you are are refreshing the connection every time you switch dns servers.
Good point. I'll try this. Strange thing is, switching the settings back to the RasPI IP for DNS settings, the connection starts working again without doing anything. Adding the Proxmox LXC as DNS Server, even a reboot does not resolve the issue.
 

L&LD

Part of the Furniture
Did you also test by rebooting the testing device?
 

FlyByWire

Regular Contributor
Did you also test by rebooting the testing device?
The LXC running PiHole? I did a few times but I'm not sure if I did so right after pointing DNS to it.
I was wondering if it might be a problem with running the LXC unprivileged. But in all documentations, I could find, the LXC is unprivileged?!
 

bennor

Very Senior Member
Oh, I was following instructions on how to add Pihole DNS to Asus router. It shows to add them in both places, WAN and LAN.

Good to know. I know now this is what was happening. It works by adding the DNS address only to the LAN section. Problem solved!
Who's instructions were you following that indicated using the WAN fields? While Asus says to put the Pi Hole IP's in the WAN DNS fields for 3.0.0.4.386.45898 and later firmware. The Pi-Hole documentation does not. Pi-Hole recommends one put the Pi-Hole IP address in the DHCP DNS fields. Per Pi-Hole documentation:
However, we recommend to setup Pi-hole always as DNS server for your LAN! If you do so, Pi-hole's IP is distributed as DNS server via DHCP to your network clients. Each client will directly send their queries to Pi-hole and will be shown individually in Pi-hole's web interface. Additionally, you can use the group management features.
 

L&LD

Part of the Furniture
No, (maybe) not the LXC. The client device(s) you're using to test for this (possibly, including but not limited to the LXC).
 

FlyByWire

Regular Contributor
No, (maybe) not the LXC. The client device(s) you're using to test for this (possibly, including but not limited to the LXC).
When setting up the PiHole instance running on the Proxmox, all clients in my network are loosing WAN connection. the router is showing the error message, that tehre is a problem with the DHCP Server of my ISP. Switching back to the LAN DNS setting my RasPi PiHole WAN starts working again after 3 minutes without me flushing cache or restating the router.
 

L&LD

Part of the Furniture
Okay. Don't test if your logic says you don't need to. But it's a simple reboot.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top