What's new

Ping Latency Issue with Merlin 380.70 on RT-N66U Router- any advice is appreciated

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

suri

New Around Here
Hi there!
Like the title says, I have an N66U with 380.70 currently on it (latest supported version). Everything is working great (connectivity, range, customization is amazing) except for a ping/latency issue.
If I ping google from my PC connected to the router, every 5-10 seconds it spikes to 100-400 ms. It is a constant 40 ms save for these spikes. Pinging the router sees these same issues, spiking to up to 300ms at times (otherwise reads <1ms). Talking on the home phone has been very jittery and cuts out and these ping spikes make online gaming pretty unplayable with frequent lag spikes. These problems go away if I connect directly to the modem, at least with gaming on my PC.
I did some snooping around and I found that Merlin already talked about this issue in this thread (https://www.snbforums.com/threads/excessive-latency-on-all-connections-with-high-spikes.11171/), but the solution beta firmware he offers is from 2013. I wanted to know if anyone has had this problem recently and has fixed it. Should I use the latest firmware from Asus or another custom firmware? Or roll-back Merlin's firmware?
Thank you very much for the help.
 
Ok first we need to sort out ping spikes over LAN, since diagnosing letency related stuff over WiFi is a nightmare due to third-party interference.

So did you check with a different lan port or its happening on every port? Furthermore a different cable can sometimes make wonders so did you try with any other cable?
 
I used 3 different cables and used two computers over LAN and the problem is still there. I tried changing LAN ports on my router as well, but no change.
I came across this thread where Merlin says that the bug isn't present in my router (N66U) and only in the AC66U. Wonder what the problem is then.
I'm going to try flashing the official Asus firmware but I can't tell if it has VLAN support. Gonna flash Tomato Shibby if it doesn't.
 
Do a complete factory reset first ( without restoring your settings from a backup ) and see if that helps.
 
Do a complete factory reset first ( without restoring your settings from a backup ) and see if that helps.
I tried factory resetting and setting up fresh but still haven't found a solution. Thank you for all your help so far.
Here is my data from pinging my router. Every 3-4 pings, it spikes.
 
10.115.116.1 is this your router IP address by default or you changed it yourself?

Try changing it to something like 192.168.1.1 and see if that makes any difference, although they both are private IP range and shouldn't cause any issues but still worth a try.

One more thing your should try is connect another computer to your router via LAN and ping that one from a different LAN connected computer and see if you get ping spikes there too.
 
Yeah that's my router IP address, sorry should have mentioned it earlier. Connected a different ethernet cable to a different LAN port to my laptop and did the same thing, and still got the same results. Did it over WiFi again and still experience the ping spikes.
I'm going to factory reset again and update to the newest firmware on Asus's website and hopefully that will fix it?
 
A clean stock firmware update is worth a try too yup.
 
@Asad Ali Solved my problem! Thank you for all your help, you got me through these 21 hours of headache
So I factory reset my router and then tried to install the latest John's fork of Merlin, using the Asus firmware recovery tool. I also took a backup of the cfg and jffs, and used john's settings saver script to backup all of my settings onto a flashdrive. I hit another snag on the way, after the firmware was uploaded and was "processed" by the router, after hitting 100%, the installation tool would tell me that the file failed to upload. I re-flashed the firmware two more times before I passed out of exhaustion and I awoke to yet another "fail to upload" error, but this time the router had the wireless LEDs lit up.
If you're ever flashing an N66U and you get that error, just be patient.
I then reset the NVRAM by holding the WPS button for 30 seconds before and after turning the router off and on. The router reset, I logged in to the admin panel with user "admin" and password "admin" and I set up everything again.
Set up two guest networks completely and also customized some. Checked the ping both to my router from my PC and to google and saw not a single ping spike. Opened up Fortnite to confirm (lol) and didn't rubber band once. I'm going to sleep a happy man. Thank this awesome community for existing.
 
Perfect, glad you solved your issue.


Sent from my iPhone using Tapatalk
 

Similar threads

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top