1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

pixteltls problem

Discussion in 'Asuswrt-Merlin' started by tweakertje, May 26, 2019.

  1. tweakertje

    tweakertje Occasional Visitor

    Joined:
    Nov 12, 2017
    Messages:
    15
    Hi all,
    Im having an issue with pixteltls, I live in the netherlands an Im using the Rabobank as banking
    with my phone I can not use the app from my bank .
    when I disable wifi and go on 4g it works, I invested some things an came out that when I disable pixteltls the rabobank app works some furthere investment was that when I removed the ca.crt and ca.key file from the pixtelserv folder on the router it works to.

    what is goning on with the certificate and where is it needed for
    can this be solved or configured that the app works?
     
  2. elorimer

    elorimer Very Senior Member

    Joined:
    Dec 16, 2013
    Messages:
    758
    More than likely Rabobank needs to be whitelisted.

    Pixelserv-tls itself just serves up a small blank image when the router is directed to its address. Something else is intercepting the rabobank request and directing it to pixelserv-tls.

    More than likely you also have diversion installed? You can follow the log through diversion to see what address the app is trying to reach. Whitelist that address.
     
  3. tweakertje

    tweakertje Occasional Visitor

    Joined:
    Nov 12, 2017
    Messages:
    15
    I did a log while i was loging in but I can see nothin more than
    log.rabobank.nl and bankieren.rabobank.nl
    they both not in the blacklist and an ping response is not from 192.168.1.2 (pixelsrv)

    can I log pixelserv itself maybe I can see there what is going wrong

    Verstuurd vanaf mijn SM-G965F met Tapatalk
     
  4. tweakertje

    tweakertje Occasional Visitor

    Joined:
    Nov 12, 2017
    Messages:
    15
    is it possible that the app does a arp scan to check if the mac address is already in use ?
    to check can I change the mac address of pixelserver that is not the same as the router

    Verstuurd vanaf mijn SM-G965F met Tapatalk
     
  5. elorimer

    elorimer Very Senior Member

    Joined:
    Dec 16, 2013
    Messages:
    758
    I don't think it does that. I have diversion set at Standard+, and can reach bankieren.rabobank.nl on a pc without anything being blocked. Do you have a more comprehensive blocking file?

    I installed the rabobank app and it is reaching out to sites at jibecloud.net and akadns.net. I am in the US so it may be sending me to US sites and yours might be different. Use diversion to follow the dnsmasq log and it will tell you if pixelserv is blocking something.
     
  6. tweakertje

    tweakertje Occasional Visitor

    Joined:
    Nov 12, 2017
    Messages:
    15
    well it can reach it but I can't login I'm going to try installing pixelserv on my synology using docker and see if it helps.

    Verstuurd vanaf mijn SM-G965F met Tapatalk