What's new

Port Forwarding stops working after adding addional AiMesh node

  • SNBForums Code of Conduct

    SNBForums is a community for everyone, no matter what their level of experience.

    Please be tolerant and patient of others, especially newcomers. We are all here to share and learn!

    The rules are simple: Be patient, be nice, be helpful or be gone!

pietron

New Around Here
Hello,

I have Asus RT-AX88U Pro and I set up port forwarding to PC/linux machine (wired connection directly to RT-AX88U Pro, added a rule in DHCP that this computer has to have the same IP every time 192.168.50.236; Port forwarding details: external port: 1980, internal port: 1980; service running on this linux machine is ssh on this port). Everthing worked fine. Then I saw there wasn't enough wifi coverage in the house => I added 3 AiMesh nodes (3x ZenWifi XD6S, all connected wirelessly) to extend the wifi coverage. Wifi coverage is fine now. But out of the blue I found out I cannot connect to the linux machine from public internet. I digged a lot and tried everything, but no luck. I decided to reset RT-AX88U Pro to factory default.

After the reset (and some very basic setting, including the very same port forwarding I had before) connection to the linux machine worked! Voila!
So I added feature by feature and everytime tried to connect to linux machine from public internet:
  • It worked after I created Guest network
  • It still worked after I set QoS (Bandwidth limit for some of the devices on the network)
  • It still worked after I added first AiMesh node
  • But!... once I added second AiMesh node, it stopped working. I tried adding the last (third) AiMesh node, and obviously, still not working. So I removed the 2nd and 3rd AiMesh nodes and... port forwarding was working again. What's going on?!

Any idea? I'm at the end of my tether.

I'm at the latest versions of the firmware (all RT-AX88U Pro and AiMesh Nodes):
RT-AX88U Pro: 3.0.0.6.102_33308-gfb75e0b_344-g69f33
3x ZenWifi XD6S: 3.0.0.4.388_23773-gad68d0f

Attaching AiMesh configuration picture.
 

Attachments

  • Screenshot_20240508_194936_ASUS Router.jpg
    Screenshot_20240508_194936_ASUS Router.jpg
    48.4 KB · Views: 18
Last edited:
Hello,

I have Asus RT-AX88U Pro and I set up port forwarding to PC/linux machine (wired connection directly to RT-AX88U Pro, added a rule in DHCP that this computer has to have the same IP every time 192.168.50.236; Port forwarding details: external port: 1980, internal port: 1980; service running on this linux machine is ssh on this port). Everthing worked fine. Then I saw there wasn't enough wifi coverage in the house => I added 3 AiMesh nodes (3x ZenWifi XD6S, all connected wirelessly) to extend the wifi coverage. Wifi coverage is fine now. But out of the blue I found out I cannot connect to the linux machine from public internet. I digged a lot and tried everything, but no luck. I decided to reset RT-AX88U Pro to factory default.

After the reset (and some very basic setting, including the very same port forwarding I had before) connection to the linux machine worked! Voila!
So I added feature by feature and everytime tried to connect to linux machine from public internet:
  • It worked after I created Guest network
  • It still worked after I set QoS (Bandwidth limit for some of the devices on the network)
  • It still worked after I added first AiMesh node
  • But!... once I added second AiMesh node, it stopped working. I tried adding the last (third) AiMesh node, and obviously, still not working. So I removed the 2nd and 3rd AiMesh nodes and... port forwarding was working again. What's going on?!

Any idea? I'm at the end of my tether.

I'm at the latest versions of the firmware (all RT-AX88U Pro and AiMesh Nodes):
RT-AX88U Pro: 3.0.0.6.102_33308-gfb75e0b_344-g69f33
3x ZenWifi XD6S: 3.0.0.4.388_23773-gad68d0f

Attaching AiMesh configuration picture.
You really do not have to set the internal port. Just the external port and the IP address of the LAN client.
How are you reserving the IP address of the client? Manually assigned in the router GUI? If so, it should work.
A better way is to reserve a pool of IP addresses in the router DHCP for static IP address clients. I have my beginning DHCP set to 192.168.50.20 which gives me 18 IP addresses I can assign at the client. I then have no chance of conflict with any DHCP assignments. BTW, I suspect your added nodes could be getting the same IP address assigned as your Linux client. Sounds impossible but...
A better way to access your Linux box is over VPN. Port forwarding can be a problem!
 

Similar threads

Latest threads

Support SNBForums w/ Amazon

If you'd like to support SNBForums, just use this link and buy anything on Amazon. Thanks!

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top