• ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Divader

New Around Here
I'm struggling to find the root cause of home network issues that keep plaguing me ever increasingly. Not 100% sure but I think it was roughly around the time I went from stock to Merlin firmware in Jun 2020 that my issues began to arise. Also over this time I've gradually added a few more devices to the network and altered my usage a bit. The router has been in constant use for 4+ years.

My specs:
  • Virgin Media cable internet - 350 Mbps down/30 Mbps Up (speed tests can be up to 380 down/36 up)
  • Virgin Media Hub 3 in modem mode.
  • Asus RT-AC5300 as sole router and wi-fi AP for the network.
  • A minimum of 7 wired and 6 wi-fi devices of assorted types connected 24/7. Up to 10 wired and 13 wi-fi devices connected occasionally.
  • Brick and stone 3 bedroom house.

My typical uses:
  • Since forever ago: surfing, streaming, gaming, heavy torrenting, running the Open VPN server on the Asus router, NAS with large media library and various server plug-ins running - no issues with any of these.
  • Since 2020: also home working - wi-fi in home office seemed to work at first but became so bad that tethering to mobile phone is better.
  • Since 2021: also various types of crypto mining, enabling the guest network for 1 additional home working user + new IoT device.

The problems:
  • About a year ago my wi-fi devices started having a harder time staying connected and maintaining decent fast connections, even right next to the AP. Performance seems OK for a few minutes after a router reboot then suddenly deteriorates again. Wi-fi connectivity has since become more stable but speed and range still doesn't seem as good as before and I was never able to pin down why. I suspected new neighbours enabling additional wi-fi networks - maybe me messing with the channel and band settings helped but can't remember. The router 'Site Survey' tab currently shows 6 SSIDs in range all with sub 25% signal strength.
  • Over the last few weeks now even my wired clients have been experiencing abysmal internet performance e.g. youtube & other streaming constantly buffering when it never did before.
  • Webpages sometimes loading at dial-up like speeds - particularly youtube thumbnails and google streetview.
  • Ookla Speedtest results randomly only 10% as high as they should be on the 1st try, then immediately going full speed on the 2nd try.
  • 1%-15% stale shares for ETH mining which can often be caused by poor connection - wireless rigs have lion's share of the stales although wired not immune.
  • Both wired and wireless clients being unable to see other wireless devices on the local network (same SSID and 2.4 GHz band) - no issues with wired to wired devices. Rebooting the router will fix this for a short time.

Things I've tried:
  • Factory reset after installing Merlin 384.17_0 last Jun
  • Upgraded to Merlin 384.19_0 in December 2020
  • Upgraded to Merlin 386.2_2 in April 2021
  • Upgraded to Merlin 386.2_6 in Jun 2021 (today)
  • Enabling and disabling Smart Connect (currently disabled)
  • Disabling QoS
  • Disabling Traffic Analyzer - Statistic
  • Disabling AiProtection
  • Disabling Apps analysis
  • Disabling UPnP
  • Enabling Jumbo Frame
  • NAT Acceleration set to auto
  • Channel Bandwidth set to 20/40 MHz
  • Control and Extension Channel set to Auto
  • Possibly some other things I'm forgetting right now.

Things I'm thinking of trying:
  • Re-installing the stock firmware - seemingly the evidence points to doing this but everyone else seems to agree that Merlin is the superior firmware. Plus it's such a hassle re-configuring everything again.
  • Purchasing additional superior wi-fi routers and give Asus mesh a try or just replace the Asus device entirely. Not really in the budget at the moment though.
  • Checking to see if my ISP has problems on their end. I'd rather try other things 1st since dealing with their customer service is such a pain in the arse!
  • Checking to see if my ISP maybe changed something which requires me to edit settings on the 'WAN>Internet Connection' Asus router settings page. It's currently default because that always worked fine before.

Additional misc info:
  • Router temps seem to stay at a fairly constant 2.4GHz: 49 °C, 5GHz: 53 °C, CPU: 72 °C. Not sure how big a deal that is.
  • Router CPU usage seems to stay under 10% most of the time with 1 core hovering around 20% for sustained periods.
  • Router RAM usage seems to stay under 50%


I'm wondering if anyone has had a similar experience and has any thoughts or suggestions. Cheers for reading.
 

Frank Monroe

Occasional Visitor
I have been having a similar problem with my AC5300 for years. But, only it occurs on the 5GHZ-2 band. When the router first boots, the speed on the 5GHZ-2 band is good. But, after an hour or two, the speed on that band is too poor to use. So, I keep that band disabled. It doesn't matter what firmware I use. I never found the cause of the problem.
 

Divader

New Around Here
Hmm I currently have all of those networks enabled 2.4 as my main, and the 2 5s as lightly used guest networks. Strangely enough I'm not getting the poor wired performance today. Maybe that last firmware update did the trick after all...

EDIT: nope, youtube buffering still happening, it's just not as egregious.
 
Last edited:

Divader

New Around Here
These screenshots are a further example of the sort of speed inconsistencies I've been experiencing. I'm almost certain that in the past my big steam downloads always stayed near the upper limit of my connection speed. I now suspect more than ever that my ISP has borked something.

Inconsistant DL speeds 6.PNG
Inconsistant DL speeds 7.PNG
Inconsistant DL speeds 8.PNG
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top