Postmortem needed : OpenVPN server broken after reinstal of Merlin 284.18

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

Patrick9876

Regular Contributor
Yesterday I tried upgrading my RT-AC86U to Merlin 384.19, had some problems, flailed around for a few hours, and eventually returned to 384.18. (The problems had nothing to do with Merlin but I didn't know that at the time.) Prior to this activity my router had been behaving fine. Afterwards almost everything was working fine. But today I discovered that I could not connect to the OpenVPN server running on the router.

First, the server was stuck displaying " Initialinzing the settings of OpenVPN server now, please wait a few minutes to let the server to setup completed before VPN clients establish the connection" (probably since I reloaded 384.18 the day before). I stopped an restarted the server. This time it initialized, but the router's log shows TLS negotiation errors whenever I tried connecting.

Eventually I decided that I would re-export the OpenVPN config. After a brief panic over not finding the Export button, re-applied the OpenVNP settings and the Export button magically appeared. After putting the new config in the client (that happens to be a laptop sitting right next to me) I was able to connect with no problem.

But why did this happen?

The flailing involved loading 384.19 and at least 2 resets to factory settings and a reload of 384.18 (each followed by a reload of a config backup taken before this adventure). There was also a reformat and reload of JFFS after loading 384.19, and another reload of JFFS after reloading just in case the config reload didn't include that.

I expected that to have put OpenVPN back the way it was before all this activity. In fact I expected OpenVPN to not be effected by the upgrade to 384.19. Was I being naive?






I thought maybe my messing around caused new certificates to be created (for no obvious reasons) so I was going to export a new OpenVPN config, but the Export button seems to be missing.)
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top