[Preview 384/NG] Asuswrt-Merlin 384.5 early test builds

D_Day

Senior Member
Yeah just noticed that. Still bizarre that I cannot upgrade to alpha 2.

I have the AC68U and I’m waiting until 384.5 has been fully tested before I upgrade and especially if there is going to be a problem with downgrading.
I hope you get yours sorted out.
 

DonnyJohnny

Very Senior Member
Yeah just noticed that. Still bizarre that I cannot upgrade to alpha 2.

Firstly reboot router. Next.

Is there any add on you have installed and was loaded like dnscrypt-proxy which take a lot of memory?
Suggest you kill those process to free memory,
Temporary off AIprotection which also eat some memory.

Execute the following command right before you try to flush the new firmware.
sync; echo 3 > /proc/sys/vm/drop_caches
This will free up more memory.

After complete flushed, do a manual power cycle to reboot router.
 

scifimike12

New Around Here
Firstly reboot router. Next.

Is there any add on you have installed and was loaded like dnscrypt-proxy which take a lot of memory?
Suggest you kill those process to free memory,
Temporary off AIprotection which also eat some memory.

Execute the following command right before you try to flush the new firmware.
sync; echo 3 > /proc/sys/vm/drop_caches
This will free up more memory.

After complete flushed, do a manual power cycle to reboot router.

Nothing installed. I literally restored it back to defaults (where it prompts you to use router as a router/AP/Media Bridge/etc) but it still does not take the flash. I also input that command prior to flashing but nothing.
 

DonnyJohnny

Very Senior Member
Nothing installed. I literally restored it back to defaults (where it prompts you to use router as a router/AP/Media Bridge/etc) but it still does not take the flash. I also input that command prior to flashing but nothing.
Just to check if you downloaded the correct firmware as often many eyes crossed and see ac86 as ac68.
Have you try redownload the firmware and have you done a checksum to Ensure integrity of the file is good?
 

HuskyHerder

Senior Member
Can you elaborate? No idea what that means.
All I can give you is this. Sorry ...

Yes in advance :p default initialized still present.


Further follow up, that error (invalid character) only shows up in Safari, it doesn't show in Chrome.

Screen Shot 2018-04-07 at 17.48.41.png
 
Last edited:

sentinelvdx

Very Senior Member
So far 384.5 Alpha 2 doing great. Only thing I have noticed is that AiCloud App for android is no more showing clients on this firm.
I did a rollback just to check and Aicloud shows clients again.
Apart from that I really lile 384.5 A2

Sent from my SM-G935FD using Tapatalk
 
Last edited:

Kal1975

Regular Contributor
I'm still at 380.68 and I was going to upgrade to 384.4_2 but have decided to wait for 384.5 instead.

I was reading the thread and saw the OpenVPN client screen capture. I was comparing against the screen in 380.68 and noticed these differences:
  • "automatic start at boot" instead of "start with wan"
  • Firewall entry exists in 380.68 but not in 384.5
  • Poll Interval option in 380.68 but not in 384.5
  • Keys and Certificates button in 384.5 ... I think that would go to the same popup window as the link beside Username/Password Auth. Only option in 380.68 ... correct?
  • Only 380.68 has option "Block routed clients if tunnel goes down". This does not exist in 384.5 but it looks like a useful feature
Can someone comment on the above.

Thank you
 

DonnyJohnny

Very Senior Member

Reinvented

Regular Contributor
Alpha 2 wasn't playing nicely on my AC3100 after a fresh install. Traffic Monitor at first showed out of the table, and was corrected slightly with a forced browser refresh. Nothing was populating the text fields under 2.4 GHz or 5 GHz wireless incoming traffic. However, it did show slight pixelation on the sides of the table like it was writing there. Went back to 384.4_2 and it was fixed.

QoS has always been setup on my network using Adaptive QoS and Manual bandwidth values of 100/100. I get that full speed on 384.4_2, and on Alpha 2, I ended up getting tons of Bufferbloat and less than half of my upload speed.
 

D_Day

Senior Member
I'm still at 380.68 and I was going to upgrade to 384.4_2 but have decided to wait for 384.5 instead.

I was reading the thread and saw the OpenVPN client screen capture. I was comparing against the screen in 380.68 and noticed these differences:
  • "automatic start at boot" instead of "start with wan"
  • Firewall entry exists in 380.68 but not in 384.5
  • Poll Interval option in 380.68 but not in 384.5
  • Keys and Certificates button in 384.5 ... I think that would go to the same popup window as the link beside Username/Password Auth. Only option in 380.68 ... correct?
  • Only 380.68 has option "Block routed clients if tunnel goes down". This does not exist in 384.5 but it looks like a useful feature
Can someone comment on the above.

Thank you

Kill switch option is under redirect traffic option, it’s been there for a while.
The changes in 384.5 look good but I’m waiting until the final release to install.
 

Wutikorn

Senior Member
Please reenable that page and make it to send feedback to you please do that
Many of the feedbacks/problems may be due to some basic misconfiguration, RMerlin does not have so much time as a group of Asus engineers to keep track of every feedbacks/problems. In those cases, other people in this forum can help reduce problems sent to him by linking to known solutions. Therefore, only a few unsolved problems get sent to RMerlin and he will have more time to solve/help fix them as he does not need to answer what he has already answered.
 

jernau

Regular Contributor
Upgraded to this after lots of wi-fi issues with 384.4-2 on my AC3200 and downgrading to 380.69-2 which caused multiple lock-ups on the router after a day or so of usage. Been running 385 alpha 2 for about a day now with 35 or so connected devices and so far this is stable.

Many thanks for the continued hard work on these builds @RMerlin !!

***Update****
Well after about 24 hours same issue again unfortunately woke up to find that 2.4Ghz radio is no longer working and only way to get 2.4Ghz clients reconnected was to power cycle the router. Have now revered back to 384.3_beta3 but not holding out much hope. I have now tried various firmware versions and tried to roll back to 380.69_2 but no joy. I appreciate this not an issue @RMerlin has caused but something in the wireless drivers for this router but I'm now getting to the point I will have to start looking at a router from another manufacturer as the RT-AC3200 is just broken at this point. I just cant understand why some people are stating that this router is working fine on the latest firmware, i'm convinced it has something to do with number of clients connected or some features not been used by some owners.
 
Last edited:

skeal

Part of the Furniture
This is an incredible new alpha! :D Really, really nice changes. Keep up the great work sir you are awesome!
 

scjr

Very Senior Member
This is an incredible new alpha! :D Really, really nice changes. Keep up the great work sir you are awesome!
Agreed. It doesn’t even feel like an alpha build. This will only get better. Good stuff.
 

stambeccuccio

Senior Member
I agree, although Asus has taken a pace of an update (and fix) at month and even more (currently RT-AC68U has firmware 384.20648_GPL) while this Alpha 2 is still based on 384.20624_GPL.

It's just small fixes ... but I think it's really hard for Merlin to keep up with GPL_ updates so fast.

The fact that Asus releases updates/fixes so fast it's good for users, but I think it creates some difficulties for Merlin.
 

Fitz Mutch

Senior Member
...
[*]Firewall entry exists in 380.68 but not in 384.5
...
I have my own OpenVPN server "custom" firewall rules written in /jffs/scripts/openvpn-event. Otherwise, the built-in firewall rules for OpenVPN server in Asuswrt-Merlin 384.5 interfere with my Tor firewall rules. Please bring back the custom firewall in OpenVPN server, as it lets me control the firewall.

I have reverted the "run the firewall rules" section for now.
https://github.com/RMerl/asuswrt-me...aeb464c/release/src/router/rc/openvpn.c#L1379
 
Last edited:

RMerlin

Asuswrt-Merlin dev
All I can give you is this. Sorry ...

Yes in advance :p default initialized still present.


Further follow up, that error (invalid character) only shows up in Safari, it doesn't show in Chrome.

View attachment 12601

You probably have an autofill function in your browser that's incorrectly filling one of the fields on the Advanced page. Disable your autofill.
 

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top