problem resolving lan devices

eleVator

Occasional Visitor
RT-AC86U's Domain Name: test.lan
Entered a few Hostnames under LAN > DHCP Server > Manually Assigned IP

The hosts have been getting their IPs and are working.
Just now i would like to be able to ping them by hostname.lan but i cannot even ping the router (test.lan)

Could use some pointers where to look.


Code:
 amtm 3.4 FW               by thelonelycoder
RT-AC86U (aarch64) FW-386.7 @ 192.168.1.1
    The Asuswrt-Merlin Terminal Menu        

1  open     Diversion                 v4.3.2
2  open     Skynet                    v7.2.8

4  open     YazFi                     v4.4.2
5  open     scribe                    v2.4.3

7  open     unbound Manager            v3.22
8  open     nsrum                    v30.4.0

j1 open     connmon                   v3.0.2
j2 open     ntpMerlin                 v3.4.5
j3 open     scMerlin                  v2.4.0

j4 open     spdMerlin                 v4.4.4
j5 open     uiDivStats                v3.0.2
j6 open     uiScribe                  v1.4.5

di open     dnscrypt installer        v2.4.7
 

ColinTaylor

Part of the Furniture
Have you changed any of the default DNS-related settings? e.g. LAN > DHCP Server > DNS Server 1/2 or DNSFilter.

Are you using the VPN client on the router?

From one of the affected clients enter this command and post the complete output:
Code:
nslookup google.com

If DNS is setup correctly you should also be able to ping clients without using the domain name, e.g. ping hostname.

EDIT: Just seen an error in your post.

If your domain is test.lan then your router's name would be RT-AC86U.test.lan and your client hostname.test.lan
 
Last edited:

eleVator

Occasional Visitor
Have you changed any of the default DNS-related settings? e.g. LAN > DHCP Server > DNS Server 1/2 or DNSFilter
DNS Server 1/2 are both empty and so is DNSFilter ON and Filter Mode Router, didn't touch these settings.

Are you using the VPN client on the router?
Yes, two NordVPN clients are running with VPN Director (policy rules) enabled for 192.168.1.0/24

I am guessing that, Accept DNS Configuration: Exclusive is probably the culprit here?


Code:
$ nslookup google.com
Server:         192.168.1.1
Address:        192.168.1.1#53

Non-authoritative answer:
Name:   google.com
Address: 142.251.36.46
Name:   google.com
Address: 2a00:1450:400e:810::200e


The Hostname thing is pretty confusing.
Host Name: test
RT-AC86U's Domain Name: test.lan

Is the router always RT-AC86U ?
 

ColinTaylor

Part of the Furniture
DNS Server 1/2 are both empty and so is DNSFilter ON and Filter Mode Router, didn't touch these settings.
DNSFilter isn't on by default, but that's not your probem.

Yes, two NordVPN clients are running with VPN Director (policy rules) enabled for 192.168.1.0/24

I am guessing that, Accept DNS Configuration: Exclusive is probably the culprit here?
Yes, that would be my guess. You're sending the clients DNS requests to the VPN provider's servers, which have no knowledge of your LAN device names.

The Hostname thing is pretty confusing.
Host Name: test
RT-AC86U's Domain Name: test.lan

Is the router always RT-AC86U ?
No, you can change the router's hostname under LAN - LAN IP.

In the example you've just posted the router's hostname is "test" and the domain is "test.lan". So the router's FQDN is test.test.lan.
 
Last edited:

eleVator

Occasional Visitor
Thanks for the hints.

Just need to figure out now how to effectively run VPN clients and be able to resolve local names without having dnsleaks with merlinWRT.
Surely there is a way to do it manually but i am not there with my knowledge.

Guess when i find the time, i could tinker and learn, start using pi's and other spare openWRT routers and split up services between them.
 

Similar threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top