Problem with AI mesh guest network with 2.4 Ghz band

  • ATTENTION! As of November 1, 2020, you are not able to reply to threads 6 months after the thread is opened if there are more than 500 posts in the thread.
    Threads will not be locked, so posts may still be edited by their authors.
    Just start a new thread on the topic to post if you get an error message when trying to reply to a thread.

mustang

New Around Here
I have a ASUS RT-AX58U (primary / first floor) and RT-AC3100 (node / second floor) setup with AI mesh network. I decided that I wanted to place all my IOT devices such as thermostats, Harmony Hubs, Doorbells, Rachio controller, sump pump float, ect on a guest network. These devices all work in the 2.4Ghz band. My problem is that when I connect these devices to the guest 2.4 Ghz network, everything connects to the RT-AX58U router regardless of proximity. Some devices are closer to the RT-AX58U and some are closer the RT-AC3100, but everything connects to the primary router only when using guest network.

I tried manually binding the closer devices to the node router, but it stated the signal was too weak, despite closer proximity.

To troubleshoot I moved the RT-AC3100 node within 3 feet of the second floor wall thermostat and it would still only connect to the RT-AX58U on the first floor, maybe 30-40 feet away.

Next I thought that maybe the RT-AC-3100 had a weak 2.4 Ghz signal, so I moved the RT-AC3100 to the first floor (primary) and moved the RT-AX58U (node) to the second floor. Even with the RT-AX58U router within 3 feet of the second floor thermostat, but it would only connect the primary router, this time a RT-AC3100 on the first floor.

I went back and the RT-AX58U (first floor / primary) and RT-AC3100 (second floor / node). This time a connected the second floor thermostat to the main network and its made a connection to the RT-AC3100 node on the second floor.

So it appears there is an issue with using guest network with 2.4 Ghz band. I don't think its a hardware issue.

I have already installed latest firmware and did multiple factory resets without any improvement.

I have been in contact with ASUS customer support, but after 1 month they have not been helpful. They suggested I disable roaming assistant and use roaming block list which did not help.

Any suggestions would be appreciated....
 

ColinTaylor

Part of the Furniture
Don't use the first guest SSID, use the second or third. See if that makes a difference.

What firmware versions are you using?
 
Last edited:

bbunge

Part of the Furniture
Don't use the first guest SSID, use the second or third. See if that makes a difference.

What firmware versions are]
Don't use the first guest SSID, use the second or third. See if that makes a difference.

What firmware versions are you using?
No, he wants the Guest to be on the node!
Use Guest 1 but use WPA2 as the AC router will not do WPA3. If the clients were connected with WPA3 you will have to forget those connections and connect again.
 

ColinTaylor

Part of the Furniture
Thank for the correction, I misinterpreted his post. :oops:
No, he wants the Guest to be on the node!
Use Guest 1 but use WPA2 as the AC router will not do WPA3. If the clients were connected with WPA3 you will have to forget those connections and connect again.
 

Similar threads

Latest threads

Sign Up For SNBForums Daily Digest

Get an update of what's new every day delivered to your mailbox. Sign up here!
Top