1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Problem with Guest Network (Wrong Password)

Discussion in 'Asuswrt-Merlin' started by psychosb, Feb 19, 2020.

  1. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    Hello Everyone.

    I'm having some problems with my Guest Networks, can anyone help me?

    My Guest network works only for a couple hours (couldn't measure how long, but It's about 3) and after that any Device that tries to connect (even devices that was connected before) get the "Incorrect Password" message.

    If I reboot the router or kill and re-create the guest Network it starts working again.

    My router is a AC88U and firmware 384.15. I have also an AIMESH node with a AC68P router, also using 384.15.

    Not sure since when this is happening, only noticed because I connected an IOT device on this network for tests and noticed that it keeps disconnecting.

    Thanks
     
  2. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    10,915
    Location:
    UK
    Check that you haven't setup an "Access time" restriction for the guest network.
     
  3. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    It's not! The Unlimited access is enabled.
     
  4. EventPhotoMan

    EventPhotoMan Very Senior Member

    Joined:
    Mar 29, 2018
    Messages:
    637
    I get that every once in a while also, it’s usually with my iPhone and I end up rebooting my iPhone
     
  5. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    It wouldn't bother me if it was once in a while, but this is very often.

    Just made a small test, rebooted my iPad that has the Guest Network saved, but the "Wrong Password" problem still happen.

    I'll try to reset to default settings and re-configure the router. Can't think in any other test right now.
     
  6. EventPhotoMan

    EventPhotoMan Very Senior Member

    Joined:
    Mar 29, 2018
    Messages:
    637
    Ok when I reboot, I forget the SSID, turn wifi off, reboot, turn wifi back on then reconnect to wifi.

    yes a pain in the but.

    my iPhone at the time won’t connect to anything.
     
  7. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    My problem only happens on the guest networks. My main SSID works perfectly.

    Just did a hard reset, reconfigured the router and the Guest network still have the same problem.

    I think I'll give a try to the stock firmware to see if it changes.
     
  8. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    Just an last update.

    Flashed with the Asus stock firmware (latest version) and the problem with the Guest Wifi has gone.

    EDIT: Has not gone. Just taked a little longer to happen.
     
    Last edited: Mar 2, 2020
  9. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    I had the same problems with the latest version of the Asus Stock Firmware.

    If anyone is having the same problem with the AC88-U and the 2.4Ghz Guest Network problem, I have only managed to fix this downgrading the firmware to the 384.13.0.

    All working fine now.