1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice

Welcome To SNBForums

SNBForums is a community for anyone who wants to learn about or discuss the latest in wireless routers, network storage and the ins and outs of building and maintaining a small network.

If you'd like to post a question, simply register and have at it!

While you're at it, please check out SmallNetBuilder for product reviews and our famous Router Charts, Ranker and plenty more!

Problem with Guest Network (Wrong Password)

Discussion in 'Asuswrt-Merlin' started by psychosb, Feb 19, 2020.

  1. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    Hello Everyone.

    I'm having some problems with my Guest Networks, can anyone help me?

    My Guest network works only for a couple hours (couldn't measure how long, but It's about 3) and after that any Device that tries to connect (even devices that was connected before) get the "Incorrect Password" message.

    If I reboot the router or kill and re-create the guest Network it starts working again.

    My router is a AC88U and firmware 384.15. I have also an AIMESH node with a AC68P router, also using 384.15.

    Not sure since when this is happening, only noticed because I connected an IOT device on this network for tests and noticed that it keeps disconnecting.

    Thanks
     
  2. ColinTaylor

    ColinTaylor Part of the Furniture

    Joined:
    Mar 31, 2014
    Messages:
    12,148
    Location:
    UK
    Check that you haven't setup an "Access time" restriction for the guest network.
     
  3. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    It's not! The Unlimited access is enabled.
     
  4. EventPhotoMan

    EventPhotoMan Very Senior Member

    Joined:
    Mar 29, 2018
    Messages:
    690
    I get that every once in a while also, it’s usually with my iPhone and I end up rebooting my iPhone
     
  5. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    It wouldn't bother me if it was once in a while, but this is very often.

    Just made a small test, rebooted my iPad that has the Guest Network saved, but the "Wrong Password" problem still happen.

    I'll try to reset to default settings and re-configure the router. Can't think in any other test right now.
     
  6. EventPhotoMan

    EventPhotoMan Very Senior Member

    Joined:
    Mar 29, 2018
    Messages:
    690
    Ok when I reboot, I forget the SSID, turn wifi off, reboot, turn wifi back on then reconnect to wifi.

    yes a pain in the but.

    my iPhone at the time won’t connect to anything.
     
  7. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    My problem only happens on the guest networks. My main SSID works perfectly.

    Just did a hard reset, reconfigured the router and the Guest network still have the same problem.

    I think I'll give a try to the stock firmware to see if it changes.
     
  8. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    Just an last update.

    Flashed with the Asus stock firmware (latest version) and the problem with the Guest Wifi has gone.

    EDIT: Has not gone. Just taked a little longer to happen.
     
    Last edited: Mar 2, 2020
  9. psychosb

    psychosb Occasional Visitor

    Joined:
    Aug 16, 2012
    Messages:
    29
    I had the same problems with the latest version of the Asus Stock Firmware.

    If anyone is having the same problem with the AC88-U and the 2.4Ghz Guest Network problem, I have only managed to fix this downgrading the firmware to the 384.13.0.

    All working fine now.
     
  10. chrisinsocalif

    chrisinsocalif Occasional Visitor

    Joined:
    Jan 3, 2013
    Messages:
    47
    Location:
    Southern California
    Have you tried any of the newer firmwares? I have had the same problem after resetting my router but didn't have the problem on ***.14 and ***.15 and problem didn't start until I hard reset my AC88U for version 16. I downgraded my firmware but the problem persists.
     
  11. Lazy Larry

    Lazy Larry Occasional Visitor

    Joined:
    May 8, 2019
    Messages:
    20
    I have using version 384_16_0 as my first foray into using Merlin to give me more control on the IP routing via the VPN Client. I too have noticed that the Guest Network 'loses' its Password after a while.

    I have downloaded 384_13_0 but struggling to upload this to my AC88U as it keeps reporting that the firmware is invalid. Do I need to put the AC88U into firmware recovery mode and upload the older version using LAN?
     
  12. RMerlin

    RMerlin Super Moderator

    Joined:
    Apr 14, 2012
    Messages:
    33,289
    Location:
    Canada
    It's a bug in newer Asus firmware where it fails to properly validate the firmware header. The just released 384.17 firmware contains a workaround to allow it to be flashed on these newer releases. Note however that going from stock RT-AC88U to Asuswrt-Merlin will require a factory default reset afterward, due to a change Asus made in 384_81790 which is not compatible (yet) with my firmware.
     
    Vexira likes this.
  13. Lazy Larry

    Lazy Larry Occasional Visitor

    Joined:
    May 8, 2019
    Messages:
    20
    Thanks for the confirming the availability of 384.17. Does this version fixes the Guest Password issues or only the header issue to allow the firmware to be updated without errors being reported?
     
  14. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    13,055
    Is the Guest network SSID 'special' in any way? Try an SSID that has never been used before that is 8 alphanumeric characters long with no spaces, punctuation, special characters, or smiley faces. The password should be 16 characters long with the same attributes too.
     
  15. RMerlin

    RMerlin Super Moderator

    Joined:
    Apr 14, 2012
    Messages:
    33,289
    Location:
    Canada
    I'm not aware of any Guest password issue, and if there were, any fix would have to come from Asus.
     
    Vexira likes this.
  16. jeff3820

    jeff3820 Regular Contributor

    Joined:
    Dec 9, 2016
    Messages:
    104
    Try this: Under Wireless, Professional scroll down until you see DTIM and if the setting is 1 change it to 3. Apple devices prefer DTIM=3 and the mistaken WiFi password issues are one of the symptoms. Side benefit is that you might see slightly better battery performance.
     
    L&LD likes this.
  17. Lazy Larry

    Lazy Larry Occasional Visitor

    Joined:
    May 8, 2019
    Messages:
    20
    Changed the Guest SSID from Asus-Guest to Asus-Guest2 to no avail. Nothing special about the password just Upper and lowercase characters and numbers, no special characters etc to deal with. Same problem!
     
  18. Lazy Larry

    Lazy Larry Occasional Visitor

    Joined:
    May 8, 2019
    Messages:
    20
    DTIM is already set to a 3 unfortunately (or should I say fortunately) but yet the problem with the Guest network persists.
     
  19. Lazy Larry

    Lazy Larry Occasional Visitor

    Joined:
    May 8, 2019
    Messages:
    20
    Sadly the problem with the Guest network appeared coincidentally or not after I uploaded Merlin 834.16 and remained with 834.17. I will revert to 834_13 as mentioned by another forum member before reverting to stock Asus firmware if that doesn't fix my Guest network issues.
     
  20. L&LD

    L&LD Part of the Furniture

    Joined:
    Dec 9, 2013
    Messages:
    13,055
    'Asus-Guest' and 'Asus-Guest2' are not strict alphanumeric characters. Neither are they 8 characters long. :)

    I'm also guessing that you've used them before too? :)